Solved

2 Cisco 1720 WIC changes from T1 to WIC-1T Serial for frame relay

Posted on 2006-06-21
34
458 Views
Last Modified: 2012-08-14
Hello,

I have a client who is moving from a Point to Point to a frame and I have to switch out the existing t1 WIC to a WIC-1T Serial WAn interface.

Most of my cisco experiences are with the T1 cards. I have a handy Cisco guide with good commands scenarios for add this WIC but was wondering if anyone had any more specific instructions/advice.

I relaize this request is somewhat generic and I apologize. I will be happy to split up points for useful help.

I would like to do this as soon as i can but need to limit downtime for client.
0
Comment
Question by:dolphan2013
  • 20
  • 10
  • 4
34 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 16952090
You don't have to change out the WIC. The T1 WIC supports frame-relay just fine..

Here's an example T1 Wic with frame-relay config:

interface Serial0/0
 encap frame-relay IETF

interface Serial0/0.1 point-to-point
 ip add 12.34.56.7 255.255.255.252
 frame-relay interface-dlci 161

! DONE !
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 16952095
BTW, the configuration is identical even if you swap out the T1 WIC for a Serial WIC with external DSU...
0
 
LVL 12

Expert Comment

by:Scotty_cisco
ID: 16952467
The only thing I would add to this is if it is a fractional T1 and you have a limited port speed

I would then add

interface serial 0/0

servce-module-t1 timeslots 1-x

thanks
Scott
0
 

Author Comment

by:dolphan2013
ID: 16954512
Hi Guys, Sorry for the lack of info..i was in a hurry this morning. It is a frac t-1, 768 for the frame (the rest for internet and phone).....the IAD has a serial interface.
0
 
LVL 12

Expert Comment

by:Scotty_cisco
ID: 16954757
so what type of interface is in the router a wic-1dsu-t1 or a wic-1t?  if it is a wic-1dsu-t1 you will want

service-module-t1 timeslots 1-12 so it knows were to listen for data.

Thanks
Scott
0
 

Author Comment

by:dolphan2013
ID: 16954789
The WIC 1-t is what I am installing.
0
 

Author Comment

by:dolphan2013
ID: 16954809
I have been given port speed 704, cir = 704, serial port = 0, DLCI = 75 from the provider.
0
 
LVL 12

Expert Comment

by:Scotty_cisco
ID: 16954823
then the CSU/DSU is required and that is were you will input the timeslots not in the serial interface.

Thanks
Scott
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 16954951
The port speed is configured in the IAD - CSU/DSU, so I hope it comes pre-configured.

interface Serial0/0
 encap frame-relay IETF <== verify with provider if IETF or not

interface Serial0/0.1 point-to-point
 ip add 12.34.56.7 255.255.255.252  <== whatever you want that matches the other end
 frame-relay interface-dlci 75
 bandwidth 704  <== not necesary, but useful

Once you get it connected, use:
 router#show frame-relay pvc
Look for anything that shows ACTIVE. If it is not PVC 75, then you need to change the interface-dlci ## to match the one that is showing up active.
0
 

Author Comment

by:dolphan2013
ID: 16955111
Thanks...also, in the information the vendor gave to me the listed location A as HOST and location B as REMOTE..is there any configuration for this or do you think it is just reference?
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 16955170
Just reference... although if they gave you DLCI like this:
HOST = 75
REMOTE = 25

Then in your Host config, you want interface-dlci 25 (remote), in your remote's config you want interface-dlci 75 (host)
0
 
LVL 12

Expert Comment

by:Scotty_cisco
ID: 16955184
Cisco routers as a not above version I think 11.2 will autodetect unused DLCI's and try to use them on a correct pvc but bet to statically set them
0
 

Author Comment

by:dolphan2013
ID: 17006172
Hello, Do i need to make any configuration changes before I take out the existing t1 WIC? Or do I take it out and issue commands as ablove?

Thanks,
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17006344
I would suggest making sure the new configuration works before I do anything. You do not have to remove the existing T1 WIC at all, just administratively shut it down.
 interface serial 0/0
  shut

0
 

Author Comment

by:dolphan2013
ID: 17027137
Hello,

Everything has been going smoothly, I got everything setup on the "HOST" and i when i use:
router#show frame-relay pvc

I get an ACTIVE status.

However, When i use the same command on the "REMOTE" I get a status of DELETED.

Thoughts?
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17027165
Can you post results from both? Could be simply reversed DLCI's on the PVC's
0
 

Author Comment

by:dolphan2013
ID: 17027184
That was quick response! Thanks.....I am on my way to remote site as the have no internet for me to remote connect to without frame setup....I will post those results in about 30 minutes if you happen to still be around...Thanks again.....

Here is HOST:

show frame-relay pvc

PVC Statistics for interface Serial0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 75, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0

  input pkts 0             output pkts 181          in bytes 0
  out bytes 5430           dropped pkts 0           in FECN pkts 0
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0
  in DE pkts 0             out DE pkts 0
  out bcast pkts 181       out bcast bytes 5430
  pvc create time 03:21:35, last time pvc status changed 01:37:15
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 79

Expert Comment

by:lrmoore
ID: 17027219
>DLCI = 75, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0
"Serial0" should be "Serial0.1"

Check your config and make sure that you have:
  interface serial 0.1 point-to-point
   ip address x.x.x.x 255.255.255.xxx
   frame-relay interface-dlci 75

Let's see "REMOTE" when you get a chance....
0
 

Author Comment

by:dolphan2013
ID: 17027276
Ok will do...I am alos wondering if there is an issue with IAD at REMOTE. It was not on UPS and I shut Down IAD and plugged it into one and noe the phone lines that are in use on the IAD are not working.
0
 

Author Comment

by:dolphan2013
ID: 17027288
IAD is backup with Phone wroking after 2nd reboot....

here is Remote info prior to make change you requested to serial

show frame-relay pvc

PVC Statistics for interface Serial0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          0            0            1            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 75, DLCI USAGE = LOCAL, PVC STATUS = DELETED, INTERFACE = Serial0

  input pkts 0             output pkts 0            in bytes 0
  out bytes 0              dropped pkts 0           in FECN pkts 0
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0
  in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  pvc create time 02:09:18, last time pvc status changed 00:06:53
0
 

Author Comment

by:dolphan2013
ID: 17027299
When i try to enter command ;

(config)#interface Serial0/0.1 point-to-point

I get % Invalid input detected at '^' marker.
0
 

Author Comment

by:dolphan2013
ID: 17027345
This is from Remote...not sure if it helps:

show interface serial0
Serial0 is down, line protocol is down
  Hardware is PowerQUICC Serial
  Description: Frame-Relay to West Hartford
  Internet address is 192.168.1.2/30
  MTU 1500 bytes, BW 704 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation FRAME-RELAY IETF, loopback not set
  Keepalive set (10 sec)
  LMI enq sent  2, LMI stat recvd 0, LMI upd recvd 0, DTE LMI down
  LMI enq recvd 0, LMI stat sent  0, LMI upd sent  0
  LMI DLCI 1023  LMI type is CISCO  frame relay DTE
  Broadcast queue 0/64, broadcasts sent/dropped 0/0, interface broadcasts 0
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 02:34:06
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue :0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     8 packets output, 106 bytes, 0 underruns
 --More--              0 output errors, 0 collisions, 67 interface resets
     0 output buffer failures, 0 output buffers swapped out
     4 carrier transitions
     DCD=down  DSR=down  DTR=up  RTS=up  CTS=up
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17027349
interface serial 0
 encap frame-relay IETF
interface serial 0.1 point-to-point  <== notice 0.1 not 0/0.1
  frame-relay interface-dlci 75

Looks like both ends need 75 as the interface dlci.



0
 

Author Comment

by:dolphan2013
ID: 17027380
Same issue......i will post  results below...I know i  am a novice...thanks for your help.....The IAD is connected to the router via serial cable....would/should i have a connectivity light showing on eithr the WIC or the IAD now or only when i have router configured corrreclty?

Right now niether is showing a connectivity light....

From Remote:

show frame-relay pvc

PVC Statistics for interface Serial0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          0            0            1            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 75, DLCI USAGE = LOCAL, PVC STATUS = DELETED, INTERFACE = Serial0.1

  input pkts 0             output pkts 0            in bytes 0
  out bytes 0              dropped pkts 0           in FECN pkts 0
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0
  in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  pvc create time 02:47:18, last time pvc status changed 00:44:53

From HOST

show frame-relay pvc

PVC Statistics for interface Serial0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 75, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0.1

  input pkts 0             output pkts 255          in bytes 0
  out bytes 7925           dropped pkts 0           in FECN pkts 0
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0
  in DE pkts 0             out DE pkts 0
  out bcast pkts 255       out bcast bytes 7925
  pvc create time 04:40:25, last time pvc status changed 00:37:05

0
 

Author Comment

by:dolphan2013
ID: 17027401
Serial interface from HOST:

show interface serial0
Serial0 is up, line protocol is up
  Hardware is PowerQUICC Serial
  Internet address is 192.168.1.1/30
  MTU 1500 bytes, BW 704 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation FRAME-RELAY IETF, loopback not set
  Keepalive set (10 sec)
  LMI enq sent  1707, LMI stat recvd 1709, LMI upd recvd 0, DTE LMI up
  LMI enq recvd 0, LMI stat sent  0, LMI upd sent  0
  LMI DLCI 0  LMI type is ANSI Annex D  frame relay DTE
  Broadcast queue 0/64, broadcasts sent/dropped 277/0, interface broadcasts 0
  Last input 00:00:08, output 00:00:08, output hang never
  Last clearing of "show interface" counters 05:00:24
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue :0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     1709 packets input, 25401 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     1 input errors, 0 CRC, 1 frame, 0 overrun, 0 ignored, 0 abort
     1989 packets output, 38308 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
 --More--              0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up


Serial interface from REMOTE:

show interface serial0
Serial0 is down, line protocol is down
  Hardware is PowerQUICC Serial
  Description: Frame-Relay to West Hartford
  Internet address is 192.168.1.2/30
  MTU 1500 bytes, BW 704 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation FRAME-RELAY IETF, loopback not set
  Keepalive set (10 sec)
  LMI enq sent  2, LMI stat recvd 0, LMI upd recvd 0, DTE LMI down
  LMI enq recvd 0, LMI stat sent  0, LMI upd sent  0
  LMI DLCI 1023  LMI type is CISCO  frame relay DTE
  Broadcast queue 0/64, broadcasts sent/dropped 0/0, interface broadcasts 0
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 03:01:45
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue :0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     8 packets output, 106 bytes, 0 underruns
 --More--              0 output errors, 0 collisions, 121 interface resets
     0 output buffer failures, 0 output buffers swapped out
     4 carrier transitions
     DCD=down  DSR=down  DTR=up  RTS=up  CTS=up
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 17027436
On REMOTE, Serial 0 down, DCD=down
>LMI enq sent  2, LMI stat recvd 0, LMI upd recvd 0, DTE LMI down
This is typically indicating that the T1 is not enabled by the provider yet. Have you contacted the frame-relay provider tech support?
You are not receiving LMI from the provider.

One side should not be UP until both sides are in sync because it is a point-to-point PVC.
They may have you in a loop somewhere. This is typical of providers because until you have the CPE equipment in place and operational, their circuit stays in an alarm state and they will often loop it or shut it down to disable the alarms until you call them and confirm that you have the equipment turned on and configured at your end.

I suspect that once they turn it on you will see 2 x DLCI's at the REMOTE site
DLCI = 25, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0
  *and*
DLCI = 75, DLCI USAGE = LOCAL, PVC STATUS = DELETED, INTERFACE = Serial0.1



0
 

Author Comment

by:dolphan2013
ID: 17027453
Ok thanks, I will touch base with them and check it out. You were a huge help.

Regards,
0
 

Author Comment

by:dolphan2013
ID: 17030048
Hello, you were correct they had not turned it on. Now the REMOTE site does show active but I am unable to to ping from remote to host or host to remote. Any ideas?

show config
Using 716 out of 29688 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Windsor
!
no logging console
!
memory-size iomem 25
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface FastEthernet0
 ip address 192.168.5.1 255.255.255.0
 speed auto
 half-duplex
!
 --More--         interface Serial0
 description Frame-Relay
 bandwidth 704
 ip address 192.168.1.2 255.255.255.252
 encapsulation frame-relay IETF
 no fair-queue
!
interface Serial0.1 point-to-point
 bandwidth 704
 frame-relay interface-dlci 75  
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
no ip http server
!
!
line con 0
line aux 0
line vty 0 4
 password controlvt
 login
!
no scheduler allocate
 --More--         end
0
 

Author Comment

by:dolphan2013
ID: 17030054
The above was for the remote site
0
 

Author Comment

by:dolphan2013
ID: 17030067
For the HOST side


Using 760 out of 29688 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname
!
no logging console
enable secret 5 $1$l5HG$2ljhGFb2oHFehRSoXQSRG1
!
memory-size iomem 25
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface FastEthernet0
 ip address 192.168.10.1 255.255.255.0
 speed auto
!
 --More--         interface Serial0
 bandwidth 704
 ip address 192.168.1.1 255.255.255.252
 encapsulation frame-relay IETF
 no fair-queue
!
interface Serial0.1 point-to-point
 bandwidth 704
 frame-relay interface-dlci 75  
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.10.150
ip route 192.168.5.0 255.255.255.0 192.168.1.2
no ip http server
!
!
line con 0
line aux 0
line vty 0 4
 password
 login
!
no scheduler allocate
 --More--         end
0
 

Author Comment

by:dolphan2013
ID: 17030079
Do I need to use frame-relay map
0
 

Author Comment

by:dolphan2013
ID: 17030125
i hve it now...i have the ip associate with serial0 instead of serial0.1
0
 

Author Comment

by:dolphan2013
ID: 17030212
Thanks again for your help. I am up and running now. I see where i made some mistakes and will clean them up.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17031096
Glad you got it going!

- 3 Cheers for you!
0

Featured Post

What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

Join & Write a Comment

This article is a guide to configure bridging on Cisco Routers.  This is something I never knew was possible until after making a few phone calls to Cisco.  Using bridging saved our company money by not requiring us to purchase a new switch.  Bridgi…
We've been using the Cisco/Linksys RV042 for years as: - an internet Gateway - a site-to-site VPN device - a leased line site-to-site subnet-to-subnet interface (And, here I'm assuming that any RV0xx behaves the same way as an RV042.  So that's …
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

24 Experts available now in Live!

Get 1:1 Help Now