Solved

Cannot ping other machines on a VPN Network

Posted on 2006-06-21
16
238 Views
Last Modified: 2010-03-19

I configured a VPN connection using two PIX fiewalls. The VPN is using IPsec.
I am not able to ping the other machines on Subnet B from subnet A and cannot connect via remote desktop, although mail is able to go through from subnet A to B and changes done in Active directory can repliacte to servers on the other subnet.

DNS is resloving okay

Subnet A is using 10.183.158.0
Sunber B is using 192.168.1.0

What coould be the problem?
0
Comment
Question by:anyirongo
16 Comments
 
LVL 25

Expert Comment

by:Cyclops3590
Comment Utility
please post your config, I suspect an acl issue, but just speculating without seeing the config
0
 
LVL 25

Expert Comment

by:Cyclops3590
Comment Utility
oh and for post sites please
0
 

Author Comment

by:anyirongo
Comment Utility
Editor

I am failing to post to this question. I have getting a "question not found error". How to I proceed.
0
 

Author Comment

by:anyirongo
Comment Utility
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
hostname lsk
domain-name lsk.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list inside permit tcp any any eq domain
access-list inside permit udp any any eq domain
access-list inside permit tcp any any eq ftp
access-list inside permit tcp any any eq ftp-data
access-list inside permit tcp any any eq https
access-list inside permit tcp any any eq ssh
access-list inside permit tcp any any eq pop3
access-list inside permit tcp any any eq www
access-list inside permit icmp any any
access-list inside permit tcp any any eq telnet
access-list inside permit tcp any any eq smtp
access-list outside permit icmp any any
access-list outside permit tcp any any eq smtp
access-list outside permit tcp any any eq pop3
access-list outside permit tcp any any eq www
access-list 101 permit ip 10.183.158.0 255.255.255.128 192.168.1.0 255.255.25

0
 

Author Comment

by:anyirongo
Comment Utility

second part of the config. Managed to post this time

pager lines 24
logging on
logging timestamp
logging trap debugging
logging facility 21
logging host inside 10.183.158.10
no logging message 111005
mtu outside 1500
mtu inside 1500
ip address outside 196.193.34.50 255.255.255.255
ip address inside 10.183.158.8 255.0.0.0
ip audit info action alarm
ip audit attack action alarm
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface www 10.183.158.19 www netmask 255.255.2
255 0 0
static (inside,outside) tcp interface smtp 10.183.158.7 smtp netmask 255.255.
.255 0 0
0
 

Author Comment

by:anyirongo
Comment Utility

last part of the config is:

access-group outside in interface outside
route outside 0.0.0.0 0.0.0.0 196.193.34.49 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 10.183.158.0 255.255.255.128 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set lusaka esp-des esp-md5-hmac
crypto map z 1 ipsec-isakmp
crypto map z 1 match address 101
crypto map z 1 set peer 196.193.35.54
crypto map z 1 set transform-set lusaka
crypto map z interface outside
isakmp enable outside
isakmp key ******** address 196.193.35.54 netmask 255.255.255.255
isakmp identity address
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption des
isakmp policy 1 hash md5
isakmp policy 1 group 1
isakmp policy 1 lifetime 1000
telnet 10.183.158.0 255.255.255.128 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 10.183.158.25-10.183.158.126 inside
dhcpd dns 10.183.158.6 213.193.32.2
dhcpd wins 10.183.158.6
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd domain lsk.com
terminal width 80
0
 
LVL 25

Expert Comment

by:Cyclops3590
Comment Utility
are you using a mask of 255.0.0.0 or 255.255.255.128?  this should be the same I assume this is part of this problem
access-list 101 permit ip 10.183.158.0 255.255.255.128 192.168.1.0 255.255.25
ip address inside 10.183.158.8 255.0.0.0
0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 
LVL 25

Expert Comment

by:Cyclops3590
Comment Utility
also, what is the config of the other site
0
 

Author Comment

by:anyirongo
Comment Utility
config for subnet B

access-list 101 permit ip 192.168.1.0 255.255.255.0 10.183.158.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 81.199.96.61 255.255.255.240
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm logging informational 100

should the subnet address be the same on all e.g. 255.255.255.128?
0
 
LVL 25

Expert Comment

by:Cyclops3590
Comment Utility
Technically it doesn't have to but its definitely good practice.  Reason is because if a packet from B to A goes to say 10.183.158.153.  It will route to A, but A cant get it back to B (even if the host did exist).

Match up the subnets, try again, and then we'll see where we're at.  I still don't think this will solve the problem but it should get the config cleaned up a little anyway
0
 
LVL 1

Expert Comment

by:ttist25
Comment Utility
I know this doesn't make sense but, I had a similar issue and spoke with a Cisco tech who advised me to change the IP addressing scheme from 192.168.1.x to 172.32.x.x and it worked.

Something about the way Microsoft routes the 192.168.1.x addresses.
0
 

Author Comment

by:anyirongo
Comment Utility

Managed to reslove the problem. this was due to use of ethernet DLS modems on the WAN. Ethernet ports generate alot of traffic through boardcasts. when we replaced ethernet DSL modems with serial DSL modems the problem was resloved.

Please close the discussion
0
 
LVL 25

Expert Comment

by:Cyclops3590
Comment Utility
post a Q in the Community Support area referencing the URL for this question.  And ask for a PAQ/Refund.
0
 
LVL 25

Expert Comment

by:Cyclops3590
Comment Utility
just out of curiousity what made you decide to switch out the modems.  I'm just curious since they worked for some traffic I wouldn't have thought they'd be the problem.  Just replaced them due to running out of ideas or what?

BTW, good job solving the issue by yourself
0
 

Accepted Solution

by:
ee_ai_construct earned 0 total points
Comment Utility
PAQ / Refund
ee ai construct, community support moderator
0

Featured Post

What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

Join & Write a Comment

What’s a web proxy server? A proxy server is a server that goes between clients and web servers, used in corporate to enforce corporate browsing policy and ensure security. Proxy servers are commonly used in three modes. A)    Forward proxy …
Hi All,  Recently I have installed and configured a Sonicwall NS220 in the network as a firewall and Internet access gateway. All was working fine until users started reporting that they cannot use the Cisco VPN client to connect to the customer'…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now