Solved

SCSI drive failed in RAID 5, Adaptec RAID software won't recognize new drive to rebuild array

Posted on 2006-06-21
5
688 Views
Last Modified: 2008-01-09
I have a custom built server that is running a RAID 5 and RAID 1 split backplane.  The OS is Win2003 and it is running an Adaptec SCSI RAID card.  One of the drives recently failed and I went to install the new drive and rebuild the array using the adaptec manager (not in the OS) and it will not recognize the new drive.  when i put the old drive back in it recognizes it but shows that it cannot rebuild it.  i have tried 3 different drives and none of them show up so I figure that I am doing something wrong.  Anybody know what I might need to do to get the new drive to show up?  All drives are in bays and are hot swapable so all their jumpers are the same and I can't find any difference from the new drive and the old busted drive in terms of jumper settings etc.  What am I not seeing/doing?

thanks
Futureman
0
Comment
Question by:futureman
  • 2
  • 2
5 Comments
 
LVL 5

Expert Comment

by:VortexAdmin
Comment Utility
Are you sure it's not in the section of drives that's not part of the array?  Perhaps you're looking at the properties of the array you already have?  If you go to Manage can you see the drive online?  Is it an identical drive to what you already have with the jumpers set to auto assign?

What if you were to try switching one of the working drives to the bay you're having a problem with and put the new drive where it was.  Perhaps it has to do with your hot swap settings, as if you shut down that bay somehow when you disabled the drive.
0
 

Author Comment

by:futureman
Comment Utility
all the drives are part of an array, i made sure that this one was for the RIAD 5 array and not the RAID 1.  I am sure I am in the right spot regarding the array structure.  THe drives are identical right down to the serial numbers.  The jumpers are exactly the same.  We tried switching a working drive with the new one and it worked fine in the bay from the dead drive and we even swapped locations for the bays and the new drive still doesn show.  very strange.  we thought that maybe we had been sent 2 bad drives (we bought 1 extra) but we just received two new ones and we get the same thing so we think there has to be something going on.

thanks again
futureman
0
 
LVL 5

Accepted Solution

by:
VortexAdmin earned 80 total points
Comment Utility
So to be clear, moving a good drive to where the bad one was, the good drive still works.  Putting a new drive where you just had that good drive originally, the new one still isn't recognized?  

How many drives are there total?  Could there be something wrong with the cage you're using or is it just a simple C shaped bracket?
0
 
LVL 2

Assisted Solution

by:mutley69
mutley69 earned 45 total points
Comment Utility
Maybe the newer drives have another firmware rev. That may cause problems for the rebuild - not having enough sectors to rebuild the R5. Can you send some more specs: raid controller, bios rev., harddisks (bios rev. on the harddisks)...

It may be best to do an upgrade to the latest version of the firmwares (raid-controller + scsi disks!) - It's best to try to backup first - so that you have a least all the data you need.

There's the option of reformatting the R5 at the end- and put the data back to it using some kind of restore. (of course it isn't the way you want it - you bought R5 to rebuild it for you in the background!)

The jumpers are exactly the same - i hope you mean the same way jumpered as the drive that's being replaced... Wrong jumpers - may cause problems - e.g. some older drives had a write protect jumper... Check to see there's no bad jumper contact left (sometimes these contacts get out of the plastic - it's not easy to see - i've had this once - and it's a thing you can check quickly).

Have you tried to contact adaptec about this?

0
 

Author Comment

by:futureman
Comment Utility
sorry, looks like the drives have different part numbers even though the model numbers are the same - not sure why i didn't notice that .  So the difference was the drives were about 200mb different in size.

thanks guys.

Futureman
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

Suggested Solutions

Problem description :  Some external hard disks / USB flash drives do not show actual space as mentioned in the factory settings. This is a common problem when you use an 8 GB USB drive to make it bootable to install a firmware/ driver on a serv…
Having issues meeting security compliance criteria because of those pesky USB drives? Then I can help you! This article will explain how to disable USB Mass Storage devices in Windows Server 2008 R2.
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now