Net Send Command not working - getting unable to find alias error message but pings work

Hello,

I am trying to use the net send command and it is not working for any computers on our network.  We are getting a message that the alias cannot be found.  However I can ping and do dns lookups on those computers all day long.


N:\>net send cwhitaker600m "test messagE"
An error occurred while sending a message to CWHITAKER600M.

The message alias could not be found on the network.

More help is available by typing NET HELPMSG 2273.


N:\>ping cwhitaker600m

Pinging cwhitaker600m.AHTNAGOV-SAC.local [192.168.25.85] with 32 bytes of data:

Reply from 192.168.25.85: bytes=32 time<1ms TTL=128
Reply from 192.168.25.85: bytes=32 time<1ms TTL=128

Ping statistics for 192.168.25.85:
    Packets: Sent = 2, Received = 2, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms
caw01Asked:
Who is Participating?
 
Chris DentConnect With a Mentor PowerShell DeveloperCommented:

Hi,

Windows XP SP2 and Windows 2003 have the Messenger Service disabled by default. Have you checked it's enabled on the clients you are trying to Net Send to?

Chris
0
 
SanDiegoComputerCommented:
is the messenger service running on the client workstation?

I really don't recommend using net send as it has been the target of many spam attacks and such.  By default it is off on XP pro.
0
 
caw01Author Commented:
Nope, just enabled it and now it is working...

While I figure out how this will impact us, is there any way to turn this service on or change it's startup type from a command line (login script).

- Chris
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
dooleydogCommented:
and when you have enabled it, try this, it is a gui interface for net send, and it is freeware.

http://www.snapfiles.com/get/netsendgui.html

Good Luck,
0
 
SanDiegoComputerCommented:
You can indeed enable it from a logon script.  Just write a vbscript that sets the value of Start to 2 in the registry for the messenger service.  hklm\system\currentcontrolset\services

You can then either wait for a restart by the user and it will auto-start or you can "net start" the service.

By the by, the messenger service goes away compleatly from Windows in Vista so don't get too comfortable with using it.

0
 
bilbusCommented:
net send spam only works if you are connected to internet without a firewall .... if you are thats the least of your problems.

If you want to stop users from sending netsend to other users, you can user a GPO to enable firewall on all desktops, and an execption for the workstation/servers you want to connect from
0
 
Jay_Jay70Commented:
don't use the net send service. with messenger enabled, you are open for crap. also, if you value your network setup, dont enable the windows firewall........!!! i hate to say it, but even windows messenger is more secure than the messenger service
0
 
bilbusCommented:
why do you say that jay? if you control windows firewall with GPO i think its great.

Can you go into more detail?

in my example messenger service is secure because it will only accept connections from a server or a permited ip address IE admin workstation
0
 
Jay_Jay70Commented:
only that within the environment i operate in (mostly domains and sadly, some workgroups) the majority os support calls that have been generated with xp and network connectivity have been resolved bu turning off microsofts sad excuse for a security wall..... basically your off the shelf DSL router contains a more powerfull and secure firewall than the windows firewall does.

I am sure there has to be benefits with it somewhere but to date, i can confidently say that in over 140 sites in my site alone, i will never allow the windows firewall to enabled, it even screws up database access from a client to a server!

just a personal opinion and experience, i dont mean to say anyone is wrong with how they do things :)
0
 
caw01Author Commented:
I have had the same experience.  In some cases it has been a matter of updating software (cisco vpn) and in some cases the only option is to turn it off.  I'm not worried about the other computers on my own network...

Anyways, starting the messenger service resolved this issue.  Thanks Guys.
0
 
bilbusCommented:
for cisco vpn

Open UDP Port 62515

Click Start, and then click Control Panel.
Double-click Windows Firewall (or click Security Center and then Windows Firewall).
In the Windows Firewall control panel, click the Exceptions tab.
Click Add Port.
In the Name field, type UDP 62515 Cisco VPN.
In the Port number field, type 62515.

Click the UDP radio button.
Click OK to add the port. It should appear in the list of Programs and Services. It should be checked.
Click OK to close the Windows Firewall control panel.
Attempt to connect with the Cisco VPN Client. If successful, you are finished.

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.