Solved

IIS Serving Pages to Other Machine on Home LAN

Posted on 2006-06-21
6
199 Views
Last Modified: 2010-08-05
I'm doing ASP.NET development on an XP Pro SP2 PC ("PC1"), and I'd like to use another PC ("PC2" with XP Home SP2) on my home LAN for some additional testing.

The LAN has an internet gateway router/hub shared by both machines, and I've set up and can do file sharing and print sharing between PC1 and PC2.

I've got IIS (which came with XP Pro) set up on PC1.  I can access my ASP.NET development site through this IIS and it seems to work fine for local access to those aspx pages on PC1.

My question is:  what do I need to do to allow PC2 to browse my aspx pages on PC1?

Any guidance on this would be appreciated.

Thanks!


0
Comment
Question by:codequest
  • 3
  • 3
6 Comments
 
LVL 13

Accepted Solution

by:
2hype earned 500 total points
ID: 16954603
If you can do file/print sharing everything is probally already setup right.  On PC2.  If you go to IE and type in http://computername or http://IPAddress does the website not open up?  If Windows Firewall is on the WIndows XP Pro Machine ensure you open up port 80.
0
 
LVL 2

Author Comment

by:codequest
ID: 16955679
Thanks for the input.  When I type in http://(PC1Name)  from IE on PC2 I get  error 403 not authorized.

I'm using Norton on the XP Pro machine and keep Windows Firewall off.   Norton Firewall Network settings sez the PC2 IP address is already in the Trusted Zone (plus since file sharing works I'm assuming that's not an issue?)




0
 
LVL 13

Expert Comment

by:2hype
ID: 16955834
In IIS if you go to your Website.  Right Click and select Properties.  Select Directory Security Tab.  Click Edit under Authentication and Access Control.  And select Enable Anonymous Access.

Also right click Website and select permissions.  Ensure Everyone has read.

If that does not work try disabling Norton to see if it allows you to conncet
0
Give your grad a cloud of their own!

With up to 8TB of storage, give your favorite graduate their own personal cloud to centralize all their photos, videos and music in one safe place. They can save, sync and share all their stuff, and automatic photo backup helps free up space on their smartphone and tablet.

 
LVL 2

Author Comment

by:codequest
ID: 16956055
Lessee here....Checked Anonymous Access, and it was already set.
Saw that the inetpub folder was not shared, so made it shared.   Checked permissions in inetpub and it says Everybody Read.
Norton Off doesn't make any difference.

IIS Default Web Site Home Directory points to my development folder, and I can access it from PC2.

Ah, I can see inetpub from PC2, but can't access it...says I don't have permission.  I'll look into that.

So, there's a problem in letting PC2 access certain folders on PC1, including inetpub.   It can access other folders, and I can't easily see the difference.

This may be related to a problem I had a while back with permissions on this machine.

This LAN testing requirement for the ASP.NET app is not urgent.  You've answered the original question and this permissions issue is something different.  So I'm going to give you the points for this and ask another question on the permissions issue later.  Sorry if this leaves you in the lurch, partly it's because I'm losing focus here and need to get back to some other things.

Thanks for the help on the orginal question.
0
 
LVL 13

Expert Comment

by:2hype
ID: 16956318
If you cant get into the Inetpub folder because of permissions try logging onto the Windows XP Home machine with the same username and password as the XP Pro Machine (something with Admin permissions).

You can also right click the inetpub and click properties.  Click the Security Tab.  Ensure that everyone has read control.  If there is no security tab go to My computer click tools --- folder options -- click the view tab -- scroll to the bottom and uncheck simple file sharing (reccommended).  Now a sercurity tab should appear.
0
 
LVL 2

Author Comment

by:codequest
ID: 16962395
Thanks for the message.  I adjusted permissions on the inetpub and can now access it from PC2.  I still get the  "HTTP Error 403 Forbidden Internet Explorer".   I notice there are a lot of entries for that on the web...I'll look into some of those and if I can't get it going I'll post another question on that specifically.

Thanks again for your suggestions.  
0

Featured Post

Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

A brief overview to explain gateways, default gateways and static routes OR NO - you CANNOT have two default gateways on the same server, PC or other Windows-based network device. In simple terms a gateway is formed when a computer such as a serv…
This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
Along with being a a promotional video for my three-day Annielytics Dashboard Seminor, this Micro Tutorial is an intro to Google Analytics API data.
With the power of JIRA, there's an unlimited number of ways you can customize it, use it and benefit from it. With that in mind, there's bound to be things that I wasn't able to cover in this course. With this summary we'll look at some places to go…

895 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now