• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2381
  • Last Modified:

Problem after Subclass webutil object

I am following a document to attack webutil (1.0.6) with forms 10g. I have completed all the steps successfully for configuration of webutil. But at the second last step which is as follows, I am stuck up.
 
   *  Create a new FMB.
   *  Open webutil.olb, and Subclass (not Copy) the Webutil object to the form.
   *  There is no need to Subclass the WebutilConfig object.

Completed successfully ... Now author of document ask me to
   
   *  Attach the Webutil.pll Library, and remove the path.

What does it mean. Webutil.pll library is already attached. And which path should I remove. where it is?

Please, this is very urgent
0
annasad
Asked:
annasad
  • 2
2 Solutions
 
jwahlCommented:
if you try to attach a library you may get the message "attached library name contains a non-portable directory specification. remove path?". with the option "yes" this path will be removed.

try to remove webutil.pll from forms and attach it again to get the message above.

0
 
annasadAuthor Commented:
Hi jwahl

I attached webutil.pll library by following method

    *  Open webutil.pll, do a "Compile ALL" (shift-Control-K), and generate to PLX (Control-T)

Library is attached successfully, but no any message dialog is appeared to remove the path. I have removed the webutil.pll and .plx files from forms90 and do the same procedure again but again no message dialog.

My OS is Windows XP professional service pack I
Database  : Oracle 9i
Developer : Oracle developer 10g
Webutil     : Webutil 1.0.6

I am describing complete procedure to install webutil, may be I am doing something wrong. Please guide me if I am on wrong

I know this will be very hactic but I am really in trouble. If somebody know the problem help me ....

    *  Download Jacob_18.zip and unzip the file
    *  Copy jacob.jar to [OraHome]\forms90\java\ and copy jacob.dll [OraHome]\forms\webutil\
    *  Add [OraHome]\jdk\bin to the PATH
    *  Sign frmwebutil.jar and jacob.jar
    *  Create user webutil and execute the script file "create_webutil_db.sql" after login to user webutil
    *  Create public synonym for webutil_db and connect to system user for granting execute on webutil_db to public
    *  Modify [OraHome]\forms90\server\default.env and append [OraHome]\jdk\jre\lib\rt.jar to the CLASSPATH entry
    *  Start OC4J instance
    *  Start Forms Builder and connect to webutil schema
    *  Open webutil.pll, do a "Compile ALL" (shift-Control-K), and generate to PLX (Control-T).
    *  Create a new FMB. Open webutil.olb, and Subclass (not Copy) the Webutil object to the form.
    *  There is no need to Subclass the WebutilConfig object.

ABOVE MENTIONED STEPS ARE COMPLETED SUCCESSFULLY WITHOUT ANY ERROR OR WARNING

WHEN I TRY TO OPEN THE CANVAS PROVIDED BY WEBUTIL.OLB IT GIVES ME THE FOLLOWING ERROR

          FRM-13008: Cannot find javabean with name
          'oracle.forms.webutil.ClientInfo.GetClientInfo.'

          FRM-13008: Cannot find javabean with name
          'oracle.forms.webutil.file.fileFunctions.'

          FRM-13008: Cannot find javabean with name
          'oracle.forms.webutil.host.Host.'

AND LOT MANY OTHERS (ABOUT 9 OR 10) THEN IF I PROCEED

    *  Attach the Webutil.pll Library, and remove the path. (PROBLEMATIC STEP)

    *  Add an ON-LOGON trigger with the code:   NULL;   to avoid having to connect to an RDBMS (optional).
    *  Create a new button on a new canvas, with the code:   show_webutil_information (TRUE);
        in a WHEN-BUTTON-PRESSED trigger.

THIS CODE ALSO GIVE ME AN ERROR

    *  Compile the FMB to FMX, after doing a Compile-All (Shift-Control-K).
    *  Under Edit->Preferences->Runtime in Forms Builder, click on "Reset to Default" if the "App Server URL" is empty.
       Then append "?config=webutil" at the end, so you end up with a URL of the form
        http://server:port/forms/frmservlet?config=webutil
    *  Run your form.

DUE TO ERROR FORM IS NOT EXECUTED

Best regards





0
 
jwahlCommented:
try this:

* open form in form builder
* open node "attached libraries"
* delete library "webutil.pll"
* create library  --> browse for "webutil.pll"
* attach
* now you should get the message described above
* remove path? --> yes
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now