Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 350
  • Last Modified:

MOM 2005 SP1 problems installing

I have Windows 2003 server fully updated. Now I try to install MOM 2005 but I get the error that I need installer 3.1, but I am already working with a higher version. Can anyone help me with this problem.

Thx,

Alexander
0
adenhartog
Asked:
adenhartog
  • 6
  • 5
  • 2
  • +1
1 Solution
 
callrsCommented:
Reinstall the installer: http://www.softwarepatch.com/windows/wininstallnt.html
Then Installl MOM
0
 
adenhartogAuthor Commented:
Thx for the quick answer, but I tried that option already. When installing this patch I get the error a newer version is already installed.
0
 
ded9Commented:
http://support.microsoft.com/kb/893803/

download latest one which is released for windows 2003 download and try it first
above is the link


if above solution doesnt work then


The first thing I'd try is to reinstall the Microsoft Windows Installer engine files: Run the following command from a command prompt:

msiexec /unregister

Delete the Msi.dll, Msiexec.exe, and Msihnd.dll files from the system folder. You must rename these files from the command prompt.

Restart Windows.

Run the Instmsi.exe program to install and register the engine files again

Reps
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
war1Commented:
Greetings, adenhartog !

You may need to uninstall Windows Installer first. Go to Control Panel > Add and Remove Programs.  Select Updates and look for Windows Installer to remove.  After removing Windows Installer, new install new version.

Best wishes!
0
 
adenhartogAuthor Commented:
Hello war1,

I removed the patch off Windows installer. But it still didn't work. But is Windows installer not beiing updated with Windows SP1?

Best regards,
0
 
ded9Commented:
did you try my solutions

Reps
0
 
adenhartogAuthor Commented:
Hello ded9,

Yes I did.

I already try to install the file, but this doesn't work.

Did this part:
----------------------------------------------------------------------------------------------------------------------------------------------------------
msiexec /unregister
Delete the Msi.dll, Msiexec.exe, and Msihnd.dll files from the system folder. You must rename these files from the command prompt.
Restart Windows.
----------------------------------------------------------------------------------------------------------------------------------------------------------

Then try to install it, but this didn't work. Installer was still running. But maybe I am doing something wrong.

Best regards,
0
 
war1Commented:
>> But is Windows installer not beiing updated with Windows SP1?

Yes, a new Windows Installer is updated with Windows XP SP1.  But MOM 2005 is not recognizing it.  Do you have Windows XP SP2 installed?  If not, you will need it for this and other programs.

http://support.microsoft.com/windowsxpsp2
0
 
ded9Commented:
first try to kill the installer process by CTRL +alt +delete and select the instller process

http://www.tech-recipes.com/windows_tips446.html

Also try this utility to kill process

http://www.sysinternals.com/Utilities/ProcessExplorer.html


And then try my solution

Reps

 
0
 
adenhartogAuthor Commented:
Hi war1,

It is Windows 2003 server R2 and not XP. But thx for the info anyway.

Alexander
0
 
adenhartogAuthor Commented:
Hello ded9,

There is no process running with that name.

Nice util by the way ProcessExplorer.

Thx

Alexander
0
 
ded9Commented:
boot in safe mode and try to install
0
 
callrsCommented:
Try cleaning the system
- Antivirus with updated defs (use free AVG from www.grisoft.com if you don't have antivirus)
- Anti-Spyware etc.: http://www.lavasoft.de/software/adaware/   http://forums.majorgeeks.com/showthread.php?t=35407  
- Check system files: http://ask-leo.com/what_is_the_system_file_checker_and_how_do_i_run_it.html
- Disable unneeded startup items: http://www.sysinternals.com/Utilities/CAutoruns.html
0
 
adenhartogAuthor Commented:
Thx for all the help! I have reinstalled the server without any service packs and then installed MOM. Seeing that ded9 was giving the most help on this subject it is only fair he should get the points.
0
 
ded9Commented:
adenhartog

Thank you
 points

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 6
  • 5
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now