?
Solved

Crystal XI ActiveXReportViewer - not printing

Posted on 2006-06-22
7
Medium Priority
?
244 Views
Last Modified: 2008-01-09
Hi guys
I've got a CrystalXI ActiveXReportViewer to display my reports from VB.
They seem to be working a treat, other than one small problem!  When you press the print button nothing happens at all, don't get any error messages, no print, whatever.
I have some reports where I am sending the reports directly to the printer and these are fine, so I know the printer is OK.  I can't do this for all the reports though, as the majority the user wants to view first.
The other buttons, such as export etc work.
Anyone got any ideas?
Thank you very much
Zoe
0
Comment
Question by:zoebracken
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
7 Comments
 
LVL 85
ID: 16959420
When you say "press the print button", do you mean the File - Print menu item, or are you using the CR builtin toolbar?
0
 

Author Comment

by:zoebracken
ID: 16959749
Hiya
Yes - the built in toolbar in the viewer object
Zoe
0
 
LVL 101

Expert Comment

by:mlmcc
ID: 16965047
I assume the reports in question were built with a printer?

Is that printer available when you run the reports?

mlmcc
0
 

Author Comment

by:zoebracken
ID: 16976787
I built them on my laptop while on the train.
Surely you don't have to be connected to a printer at the time of developing the reports for them to ever print out??

Saying that, I did try installing Crystal Reports on the PC that I was installing the reports on, and when this didn't fix the problem, I opened the report up (in the designer, checked that I could print from the print preview and saved, but this didn't seem to fix the problem.  While the print worked fine in designer, did nothing via the ActiveX Viewer
0
 
LVL 101

Accepted Solution

by:
mlmcc earned 2000 total points
ID: 16976988
Actually you do.  To solve the problem on the laptop, install a printer driver and set it as default.  The printer doesn't have to be there butthe driver needs to be.

Depending on version, there is a flag under REPORT OPTIONS for NO PRINTER.  Uncheck it an you should be able to print.

mlmcc
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hot fix for .Net Crystal Reports 10.2.3600.0 to fix problems with sub reports running on 64 bit operating systems ISSUE: Reports which contain subreports fail with error "Missing Parameter Value" DEPLOYMENT SERVER OS: Windows 2008 with 64 bi…
Hello everyone, Hope you find this as helpful as we did. We have on the company I work for an application built in Delphi V with Crystal Reports 8. We all know that Crystal & Delphi can be temperamental sometimes and the worst thing is, nearly…
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…
In this video, Percona Solution Engineer Dimitri Vanoverbeke discusses why you want to use at least three nodes in a database cluster. To discuss how Percona Consulting can help with your design and architecture needs for your database and infras…
Suggested Courses

801 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question