Solved

Folder link for FTP

Posted on 2006-06-22
7
240 Views
Last Modified: 2013-12-15
Experts,

I've installed vsFTP Server for my debian box, each FTP user has their /home default folder, but in my case I have to link my /DATA folder for my FTP home folder. Im using ln command to create link but when I browse my ftp using windows explorer there in no visible link name listed for my /DATA folder. Is it correct to use ln command?

Thanks :)

0
Comment
Question by:marvelsoft
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
7 Comments
 
LVL 14

Expert Comment

by:xberry
ID: 16974231
Likely you did create a 'hard link' - Definition: http://www.computer-dictionary-online.org/index.asp?q=hard+link

instead of a 'symbolic link': http://www.computer-dictionary-online.org/index.asp?q=symbolic%20link

Symbolic link is created with

ln -s <originalfile> <linkfile>

e.g:  ln -s /home /DATA

Also see

$ man ln

for that
0
 

Author Comment

by:marvelsoft
ID: 16975856
I tried using both soft and hard links, but hard links is capable for folders.
Using soft links works but the problem is when you open/browse ur ftp using windows explorer softlinks names is not displayed.

Do you have suggestions for that?
0
 

Author Comment

by:marvelsoft
ID: 16975862
Correction: Hard links is not capable for folders.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 14

Assisted Solution

by:xberry
xberry earned 40 total points
ID: 16977916
>>> softlinks names is not displayed

is a case of permissions I'd say. Use chmod to change that, at least it should be 644.

Does the problem only occur with the Internet Explorer, or with all browsers ?
0
 

Author Comment

by:marvelsoft
ID: 16990577
When I tried 644 a unknown link is displayed when I used Windows Explorer. And then when open the link Internet Explorer is activated telling that the link is  URL.
0
 
LVL 14

Accepted Solution

by:
xberry earned 40 total points
ID: 16990883
Hmm, . . . what happens if you use a different Browser .(Mozilla, Firefox, Opera . . ) ?
0
 

Author Comment

by:marvelsoft
ID: 16999078
Well thats an alternative ways. Thanks xberry.
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Little introduction about CP: CP is a command on linux that use to copy files and folder from one location to another location. Example usage of CP as follow: cp /myfoder /pathto/destination/folder/ cp abc.tar.gz /pathto/destination/folder/ab…
Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question