Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Exchange Server 2003 SMTP Queue Problem

Posted on 2006-06-22
14
325 Views
Last Modified: 2012-05-05
 I have an Windows 2003 Advanced Server running Exchange 2003 SP1 on it.  It is not a domain controller.  Mail works perfectly on it 99% of the time.  All Windows updates have been done.  It has Symantec Mail Security and Symantec for Exchange running with all the Symantec reccommended exclusions for the email files and folders done.  Mail flows thru the SMTP Virtual server just fine.  Until the queue grows to 2000.  Then it refuses to accept any more smtp mail until one of the existing queue items releases.  It seems to have a limit of some kind on the number of queue items it can process.  I cannot find a setting to change this.  Has any one run into this?  Is there  asetting I am missing?  Maybe an IIS setting?
  My current solution is to simply clear the queue.  But I know I probably loose a couple of legitimate NDR's when I do that so..........
0
Comment
Question by:massconn
  • 6
  • 4
  • 2
14 Comments
 
LVL 18

Expert Comment

by:amaheshwari
ID: 16962400
Go to exchange System Manager .Go to administrative Group and expand your exchange server .Go to Protocols and there in smtp =>Default SMTP server.Right click on default smtp server go to delivery tab then outbound connections..check setting Limit no. of connection to.


Thanks
0
 

Author Comment

by:massconn
ID: 16962445
 It says 5000.  Maybe I should up this number?
0
 
LVL 104

Expert Comment

by:Sembee
ID: 16963878
Any reason you haven't gone to Service Pack 2 for Exchange 2003?
Is there any reason why your queue grows so large? Most people would be concerned if it got about 10 or 15, let alone 2000.

Simon.
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:massconn
ID: 16963948
  Ok.  I guess technically there is 1 Queue and 1 smtp list of current seesions.  My queue currently has 52 in it but my smtp current sessions grow to 2000 in about a week.  I assume these are emails my server is trying to send as NDR's.  These grow to 10-15 in about a minute if I clear them all.  Heavy spam?
0
 
LVL 104

Expert Comment

by:Sembee
ID: 16964300
Current sessions is 2000? You have a problem there - that is not normal behaviour.
The sessions not being cleared down is means that something is interrupting the SMTP traffic.  The usual culprit is a firewall or other application that is scanning the SMTP traffic.

As you are on Windows 2003 SP1, I would take the machine to Exchange 2003 SP2. Then configure recipient filtering and the tar pit. That will deal with any directory harvest attacks that might be causing the broken sessions.
http://www.amset.info/exchange/filter-unknown.asp

Then look at anything that gets in the way of the SMTP traffic and check whether it could be the culprit. If the firewall has any SMTP scanning features, turn them off.

Simon.
0
 

Author Comment

by:massconn
ID: 16964618
 Ok I never said I was on Windows SP1.  Only Exchange Server SP1.  I have no firewall (except my Cisco) to get in the way.  You think my Cisco Firewall may be causing this?  Please remember it takes a week or so for the sessions to get to 2000.  And that mail delivers normally until it gets there.  I would estimate I get about 7,000 emails a day into my server (purely a guess though).
0
 
LVL 104

Accepted Solution

by:
Sembee earned 125 total points
ID: 16964930
You aren't on Windows 2003 Sp1 either?
Do you have a vendor who doesn't support that service pack? Otherwise there is no excuse for not keeping up to date on service packs. You are basically running code that is over 18 months old and a lot has happened in 18 months. I will not even allow a server to connect to the internet until it has been service pack 1.

The Cisco firewall I would suspect is causing this problem. Do you have the fixup SMTP option enabled? That is notorious for causing SMTP problems and should be disabled.

Whether it take a day, a week or a month to get to 2000 sessions, it doesn't matter. You should get anywhere that number. I have built sites that deal with five or six digit levels of email messages and they don't get those sorts of problems.

Sneaky trick for getting email numbers - upgrade to SP2, then enable the built in intelligent message filter. Leave it set to do nothing. It will monitor the traffic and assign each message a score - but do nothing with the message. You can then use perfmon to look at the number of messages going through the filter.

Simon.
0
 

Author Comment

by:massconn
ID: 16971597
 I turned off fixup smtp and it appears to have solved my problem.  My Pix has been in place for several years (with OS upgrades) and its a little hard to believe that this has happened now.  Live and learn.
0
 
LVL 18

Expert Comment

by:amaheshwari
ID: 16971608
Great!!!
0
 
LVL 104

Expert Comment

by:Sembee
ID: 16974369
I have seen many sites with a PIX run for years without any issues, then one day, something happens and they start getting problems. Difficult to find what changed, but turning off fixup smtp has resolved the issue so many times that it is now the first thing I suggest and I disable the feature on new installations to ensure that it is trouble free.

Don't forget to close the question.

Simon.
0
 

Author Comment

by:massconn
ID: 16984954
 Sorry but I do not know how to close.  I checked this morning and I only have 225 in my SMTP Current Sessions.  Usually I would have 1500 or so over a weekend.
0
 

Author Comment

by:massconn
ID: 16985719
 I would really like to close this.  The suggested action was to look in the help to find out how.  Here is what I found:

Generally, there are four ways:

Select a comment (or comments) as the answer
If there are no expert comments, you have the option to delete your own question by clicking the Delete Question link at the bottom of the page
Leave a request in the Community Support topic area for a refund to close the question
Leave a request in the Community Support topic area to delete the question

  And this does not help me figure out how to close it.  So could an admin please close it for me?  if not just let me know.  :-)
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This process describes the steps required to Import and Export data from and to .pst files using Exchange 2010. We can use these steps to export data from a user to a .pst file, import data back to the same or a different user, or even import data t…
MS Outlook is a world-class email client application that is mainly used for e-communication globally.  In this article, we will discuss the basic idea about MS Outlook, its advanced features, and types of MS Outlook File formats.
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question