Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Problem receiving POP Email

Posted on 2006-06-22
14
Medium Priority
?
363 Views
Last Modified: 2010-04-08
Hi,

I'm hvaing trouble receiving POP e-mail from an ISP from behind a PIX 506 firewall.  Attempts to telnet to port 110 from behind the firewall fail, however, from outside the pix the connection is fine, so I know it is something in the firewall configuration.

I have the following access-list applied on the outside interface in.

access-list rdpin permit tcp any interface outside eq 3389
access-list rdpin permit tcp host [ISP Mail Server] gt 1024 any

Initially, the access-list was for the RDP only, however I thought opening the ports above 1024 was the problem with POP.  With no access-list it still does not work and opening pop3 port does not work either.  What needs to be open for POP to function on the internal network?
0
Comment
Question by:caplinktech
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
  • +2
14 Comments
 
LVL 13

Expert Comment

by:prashsax
ID: 16963045
Are you able to browse internet from behind the firewall.

I mean are you able to telnet on port 80 of any website. e.g google.com etc.

If yes, then you need to modify your IN to OUT access-list.
0
 

Author Comment

by:caplinktech
ID: 16963375
I can browse the internet from behind the pix, but telnetting to port 80 from behind the pix fails.
0
 
LVL 13

Expert Comment

by:prashsax
ID: 16963427
Are you using some proxy server.

0
Q2 2017 - Latest Malware & Internet Attacks

WatchGuard’s Threat Lab is a group of dedicated threat researchers committed to helping you stay ahead of the bad guys by providing in-depth analysis of the top security threats to your network.  Check out our latest Quarterly Internet Security Report!

 

Author Comment

by:caplinktech
ID: 16963585
nope, this is what has me baffled as well.
0
 
LVL 32

Expert Comment

by:rsivanandan
ID: 17074114
To quickly take a look at it, can you post the sanitized configuration of your pix firewall ? (I mean just remove the last 2 octets of your public ips).

Cheers,
Rajesh
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17076877
Do you have any access-lists assigned to you inside interface? By default all traffic is allowed outbound along with the return traffic so you don't need the inbound access-list entry either.
0
 
LVL 1

Expert Comment

by:JEEGO
ID: 17077555
The PIX will dynamically assign ports for traffic that is originated from the inside. As lrmoore indicated, the PIX by default does not filter outbound traffic. If you have no restrictive ACLs applied to the INSIDE interface, then I suggest that you look at you client.

Thanks
 
JEEGO(AL) - in the spirit of the just ended World Cup
0
 

Author Comment

by:caplinktech
ID: 17083120
Sorry for the non prompt reply, but this just has me completely confused.  The POP e-mail manages to work intermittantly at a very rare occurance, like once every 2 weeks for some unknown reason.  I don't think the problem is on the client as none of the computers behind the pix can telnet to port 110 of the pop server which initally led me to believe there was a problem with the ISP.  However, aside of the pix, telnetting to 110 is not a problem at all.

I have the sanitized config below.  It is a very basic config with VPN.

PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password x encrypted
passwd x .2KYOU encrypted
hostname mine
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 100 permit ip 172.16.0.0 255.255.0.0 192.168.10.0 255.255.255.0
access-list 100 permit ip 172.16.0.0 255.255.0.0 192.168.20.0 255.255.255.0
access-list rdpin permit tcp any interface outside eq 3389
access-list rdpin permit tcp host [ISP_Mail_IP] gt 1024 any  <--- I added this hoping it might do something to make it work, it hasn't
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 24.x.x.187 255.255.255.248
ip address inside 172.16.0.1 255.255.0.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnpool 192.168.20.1-192.168.20.10
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 100
nat (inside) 1 172.16.0.0 255.255.0.0 0 0
static (inside,outside) tcp interface 3389 172.16.1.13 3389 netmask 255.255.255.
255 0 0
access-group rdpin in interface outside
route outside 0.0.0.0 0.0.0.0 24.x.x.185 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set caplinkset esp-des esp-md5-hmac
crypto dynamic-map cisco 1 set transform-set caplinkset
crypto map caplink-map 20 ipsec-isakmp dynamic cisco
crypto map caplink-map interface outside
isakmp enable outside
isakmp key x address x netmask x no-xauth
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 1
isakmp policy 10 lifetime 1000
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup caplinkclient address-pool vpnpool
vpngroup caplinkclient dns-server 172.16.1.1
vpngroup caplinkclient wins-server 172.16.1.1
vpngroup caplinkclient split-tunnel 100
vpngroup caplinkclient idle-time 1800
vpngroup caplinkclient password x
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:597baa2bf84618572b50a0b0ac0e7d17
: end
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17083337
I would venture to say that the problem is the ISP's and not yours..
I'm currently using cable modem with PIX506 config very similar to yours and I have zero problems getting pop3 email (all my EE mail) from any of my PC's inside..
Although I did have a problem one time when I changed the outside IP address - the mask defaulted to class A because I fat-fingered it. Only problem I has was email. Pop3 mail server IP was in that same class A network so it never got forwarded to a gateway..

0
 

Author Comment

by:caplinktech
ID: 17084276
That is what has me confused is I have no idea what could be wrong on the ISP end.  

The masks are right and they on the same class A networks anyway (had to double check since I tried everything else).

I just am idealess as what the issue could be because as I said previously, the ISP works flawlessy outside of the Pix.

Is there anymore to trace the packets somehow to try to get a better understanding of what is happening?
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 2000 total points
ID: 17084364
Enable logging to see if anything is being blocked - the PDM log is pretty comprehensive if you enable it.
enable session monitoring (in your console or ssh/ telnet window) or output to syslog server
Try using debug packet and filter on the protocol, i.e.
  debug packet inside dst <pop3IP> netmask 255.255.255.255 proto tcp dport 110 both
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Do you have a windows based Checkpoint SmartCenter for centralized Checkpoint management?  Have you ever backed up the firewall policy residing on the SmartCenter?  If you have then you know the hassles of connecting to the server, doing an upgrade_…
To setup a SonicWALL for policy based routing to be used with the Websense Content Gateway there are several steps that need to be completed. Below is a rough guide for accomplishing this. One thing of note is this guide is intended to assist in the…
Are you ready to place your question in front of subject-matter experts for more timely responses? With the release of Priority Question, Premium Members, Team Accounts and Qualified Experts can now identify the emergent level of their issue, signal…
Please read the paragraph below before following the instructions in the video — there are important caveats in the paragraph that I did not mention in the video. If your PaperPort 12 or PaperPort 14 is failing to start, or crashing, or hanging, …
Suggested Courses

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question