Wireless network dissapears


I have SSID broadcasting turned off.  Some users I have setup to connect automatically and it works fine.  

Some users I want to be able to connect on demand when they need it.  I went through the process of adding the connection manually.  The network is detected and works fine until I go to properties and uncheck “connect when this network is in range”.  After I disable that, the connection changes from connect automatically to connect on demand but then the connection disappears and I can not get it to show up again unless I manually remove and add the connection again.  Any ideas on why it disappears?

Who is Participating?
DarthModConnect With a Mentor Commented:
PAQed with points refunded (500)

Community Support Moderator
Kurt4949Author Commented:
I guess I found the answer here  http://www.microsoft.com/technet/community/columns/cableguy/cg1102.mspx

This is very annoying.  I guess If you want a wireless connection to show up in the list of available networks but you also do not want it to automatically connect then you have to broadcast the SSID name.  That seems to be how it works but why???  That is very annoying.  Now I have to broadcast the name which i did not want to do.

Because Wireless Auto Configuration attempts connections to preferred networks in the available networks list before attempting to connect to preferred networks that are hidden, Wireless Auto Configuration will connect to a preferred network that is broadcasting its SSID before it will connect to a hidden preferred network, even if the hidden wireless network is higher in the list of preferred wireless networks.

You cannot manually connect to a hidden wireless network if the Connect when this network is within range checkbox is cleared on the Connection tab for the properties of the preferred wireless network. Because the wireless network is hidden, it is not displayed in the Choose a wireless network dialog box and cannot be manually connected. You must select the Connect when this network is within range checkbox to connect to the hidden network.
Kurt4949Author Commented:
Maybe they will fix this in XP service pack 3

Another consequence of this behavior is that users must configure the preferred wireless networks corresponding to hidden networks to automatically connect. If not, Wireless Auto Configuration will not automatically try to connect, and the user will not have any way of manually connecting to the hidden network because it does not appear in the Choose a wireless network dialog box.

Microsoft is investigating the ability to better manage hidden networks from the Choose a wireless network dialog box in Windows XP Service Pack 3.
hmm there is a couple of changes that i think could be made with wireless networking with a service pack release but i doubt they will fix it considering vista is here....
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.