Solved

Java jre1.5.0_07 on Centos 4.1

Posted on 2006-06-22
5
745 Views
Last Modified: 2013-11-13
Hi I'm going crazy here.  I need to install jre1.5 for an app I want to use.  This is for an asterisk box.  I dont need it for firefox or other web browser.

I did a Yum install of the jpackage (I dont even know what that means)  it installed 1.4.X

I can from the command line do
java -version and get the version.

So that yum installer seems to work great.

I tried to use the self extracting .bin and the RPM from the Sun site.  Both ways seemed to go through the install fine but the only way I can get it to work is to call it through the full path... /usr/java/jre1.5X/bin/java -version

So my question is:  Step by step...
How do I uninstall 1.4
make it so when I do which java it uses 1.5.

thanks
0
Comment
Question by:livegirllove
  • 3
5 Comments
 
LVL 12

Assisted Solution

by:Heem14
Heem14 earned 250 total points
ID: 16963618
try:

rpm -qa | grep -i java

you should be able to find the name of the 1.4 java rpm..

then do rpm -e name of java 1.4 package

then simply either add /usr/java/jre1.5x/bin to you path, or move the /usr/java/jre........ folder to someplace that is in your path. you may have to set some environment variables like JAVA_HOME JRE_HOME JAVA_ROOT

export 'JAVA_HOME'=/usr/java/jre1.5x/bin

or whatever you move it to if you move it.
0
 
LVL 22

Accepted Solution

by:
pjedmond earned 250 total points
ID: 16963620
First remove java 1.4:

yum remove jpackage


Next ensure that java 1.5 is in your path:

Edit your .bashrc and add the line:

PATH=$PATH:/usr/java/jre1.5X/bin/

then:

. ~/.bashrc

to update your PATH

This will add the directory with all the binaries to you PATH, so you should now be able to run:

java -version

should then give you 1.5 :)

(   (()
(`-' _\
 ''  ''
0
 
LVL 1

Author Comment

by:livegirllove
ID: 16964905
I used a little of both.
I didnt know how to get the yum package name to uninstall so I used the RPM uninstall.

added the path to bashrc and java - version finally works

thanks
0
 
LVL 1

Author Comment

by:livegirllove
ID: 16964950

error: Failed dependencies:
        jre >= 1.5 is needed by asterfax-1.0-rc2.i386

well maybe I spoke to soon
0
 
LVL 1

Author Comment

by:livegirllove
ID: 16965193
nevermind I got it.


0

Featured Post

Master Your Team's Linux and Cloud Stack

Come see why top tech companies like Mailchimp and Media Temple use Linux Academy to build their employee training programs.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
deploy workstation 4 95
PHP installation issues 11 59
windows 7 starter missing password 21 76
Linux Desktop suggestion for Dell Inspiron 3043 13 32
Installations often have prerequisites, such as “Microsoft .Net framework is required for this product”. The usual implementation in MSI installations is system search for a particular registry setting representing the required prerequisite, followe…
The purpose of this article is to demonstrate how we can use conditional statements using Python.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

786 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question