Solved

Route 2 Lans Together With Cisco 2600 Router

Posted on 2006-06-23
6
339 Views
Last Modified: 2013-11-29
Is it possible to route 2 Lans together just using one router with 2 Lan interfaces..  I have a Cisco 2600 Router, LAN A is setup as 192.168.1.x  LAN B is setup as 192.168.0.x.  From network A i am able to ping the LAN A interface on the routers, as well as the LAN B interface on the router, but am not able to get to any computers, or devices on the LAN B network.  Any suggestions would be much appreciated.  Below is a copy of the config.

ip subnet-zero
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.0.254 255.255.255.0
 no ip directed-broadcast
!
interface Serial0/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
!
interface FastEthernet0/1
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
!
ip classless
no ip http server
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password ******
 login
!
end
0
Comment
Question by:shigh01
6 Comments
 
LVL 30

Expert Comment

by:ded9
ID: 16970848
In TCP IP in both A and B
provide default gateway That should be 192.168.1.1 in your case

and prefered dns 127.0.0.1

Try it

Reps
0
 
LVL 30

Expert Comment

by:ded9
ID: 16970857
Also check whether firewalls are not blocking access

1. windows firewall
and

2.  any other firewalls ( norton) etc

Reps
0
 
LVL 9

Accepted Solution

by:
NYtechGuy earned 500 total points
ID: 16970879
shigh-

Yes, you are definitely able to what you are asking.

The problem lies with the default gateway on the device you are trying to ping.  Is the router's interface the default gateway for all devices on each network?  That is essential for communication between devices on the different networks.  I suspect that the devices on one of the networks is using a different default g/w (to get to the internet?)

Alternately, you can add an IP route in the OS to point packets bound for the other network to a different IP then the default gateway.

In windows:
-----------------------------------------------------------------------------------
    > route ADD 157.0.0.0 MASK 255.0.0.0  157.55.80.1 METRIC 3 IF 2
             destination^      ^mask      ^gateway     metric^    ^
                                                         Interface^
      If IF is not given, it tries to find the best interface for a given
-----------------------------------------------------------------------------------

example (in your case):

route add 192.168.0.0 mask 255.255.255.0 192.168.0.254
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 30

Expert Comment

by:ded9
ID: 16970953
If the above solution of my doesnt work


Okay one more thing i noticed Lan B ip should be 192.168.1.3 subnet 255.255.255.0
and default gateway 192.168.1.1

Reps
0
 

Author Comment

by:shigh01
ID: 16971698
That was the problem, I talked to the other Admin at the Other Office and he had a default route that he was not telling me about at all.  So that was the problem, i didn't even think about it.  Thanks all for the quick responses and info.  
0
 
LVL 13

Expert Comment

by:prashsax
ID: 16971736
All you need to do is to configure each machine on network A with default gateway 192.168.0.254.
On network B default gateway should be 192.168.1.1.

Then add the ip routes.

ip route 192.168.0.0 255.255.255.0 192.168.0.254
ip route 192.168.0.1 255.255.255.0 192.168.1.1

That about it, router will do the rest.

0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Radius Debug Error 16 59
cant ping a windows 10 computer 12 56
Classlful vs Classless subneting 18 63
Cisco 3560 switches not seeing VTP V3 12 15
Configuring network clients can be a chore, especially if there are a large number of them or a lot of itinerant users.  DHCP dynamically manages this process, much to the relief of users and administrators alike!
For many of us, the  holiday season kindles the natural urge to give back to our friends, family members and communities. While it's easy for friends to notice the impact of such deeds, understanding the contributions of businesses and enterprises i…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

867 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now