Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1357
  • Last Modified:

Server 2003 Terminal Services printing

I have a customer running Windows server 2003 as a Terminal Server. She is running XP on each of her local PCs. When she connects to the server from her corporate office only her locally connected (USB & LPT) printers are automatically redirected. She has an HP 8000n printer configured with a standard TCP/IP port which does not get redirected. Will terminal services not automatically redirect IP printers? If not what do I need to do to manually map this device?
0
cspcc
Asked:
cspcc
  • 3
  • 3
  • 2
  • +2
1 Solution
 
itcozaCommented:
Hi cspcc,

To answer the question regarding IP printers,  it all depends on how she connects to the printer with her workstatation. How is the printer set up. Has it been configured as a local IP_port printer or is she connecting to the Printer's print server as if it were a computer with a printer that was shared on it, or the last option, a http printer port?

It is alway a good Idea to set up the Terminal server to use network connected printers directly.  This way you as the administrator can decide on the settings of the printer.  The users on the terminal server will then not be able to make changes to the settings that can render the printer useless.  Log onto the Terminal server as the administrator and set up the IP printer. The users of the terminal server will then be able to use this printer.


Regards,
M
0
 
cspccAuthor Commented:
It has been configured as a local IP port printer. Nothing fancy just the basic standard TCP/IP port using the XP TCP/IP Port wizard.
0
 
Darwinian999Commented:
The printer won't be redirected if there isn't a driver or a mapping for it on the Terminal Server. You can use the Terminal Server Printer Redirection Wizard on the server to fix things up for you. It's a free download from http://www.microsoft.com/downloads/details.aspx?FamilyID=9ad27be9-40db-484f-862e-38a094eeeaf7&DisplayLang=en
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
harleyjdCommented:
IP Based ports don't redirect automatically...

Printers That Use Ports That Do Not Begin With COM, LPT, or USB Are Not Redirected in a Remote Desktop or Terminal Services Session
http://support.microsoft.com/default.aspx?scid=kb;%5BLN%5D;302361

I hope that link works - firefox has fudged it up.

Either way, do the registry edit as below and you should be right... I exported it to a .reg file to install on client desktops...

To resolve this problem on a computer that is not running Windows Server 2003, force all ports (including DOT4) on the client computer to be filtered for redirection. To do this, add a DWORD value named FilterQueueType to HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default\AddIns\RDPDR and set its value data to FFFFFFFF.

Follow these steps, and then quit Registry Editor:
1.      Click Start, click Run, type regedit, and then click OK.
2.      Locate and then click the following key in the registry:
HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default\AddIns\RDPDR
3.      On the Edit menu, point to New, and then click DWORD Value.
4.      Type FilterQueueType, and then press ENTER.
5.      On the Edit menu, click Modify.
6.      Type FFFFFFFF, and then click OK.
This enables all ports on the client to be redirected.
0
 
bilbusCommented:
IP printers will never be redirected.

You have two options

If the server and workstation are on the same lan/wan (can you ping her workstation via the local ip from the server?)

If you can just add the IP printer to the server. add user permisions and remove all but the users that you want to print to it (if you dont do that all users will see the printers and be able to print to it)

Option 2
Setup lpt loopback

Share her IP printer on her workstation "printer"
make a batch file that runs on the workstation at startup

net use lpt2  \\workstation\printer

next, add new printer "terminal server printer", LPT2 port, add drivers and your done

Now when the user logs into the server they will print to "terminal server printer" (it will be redirected automaticly)

the print job goes to the users LPT2 port, which is maped to \\workstation\printer

Took me a while to come up with this solution =) but i have it working in my network just fine
0
 
bilbusCommented:
harleyjd, i have used that for dot4 printers ... are you sure "Printers That Use Ports That Do Not Begin With COM, LPT, or USB Are Not Redirected in a Remote Desktop or Terminal Services Session" works with IP printers?

I had my IP printers setup started in 2003 right after server 2003 came out (before KB was published)
0
 
harleyjdCommented:
Yes, Bilbus it works for IP printers...

0
 
bilbusCommented:
hmm good to know thanks
0
 
cspccAuthor Commented:
Harleyjd,
Thanks for the tip - I added the registry entry and all is well!
0
 
harleyjdCommented:
Cheers, cspcc.

Thanks for the points...

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 3
  • 3
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now