Solved

Pix 501 configuration needed.

Posted on 2006-06-23
10
472 Views
Last Modified: 2013-11-16
I have been asked the request to assist in setting up a network for a local company who has expanded into 2 facilities.  They contracted with a provider to connect the 2 sites together and left me with setting a Cisco PIX for VPN Access.  I am amature at best in setting these things up.

Here is what I know....

-Network (A)   is on 10.0.1.0  with 255.255.255.0 subnet  and have a gateway of 10.0.1.254 (Ethernet side of Cisco Router in (A) location) to get to 10.0.2.0 network
-Network (B)   is on 10.0.2.0  with 255.255.255.0 subnet  and have a gateway of 10.0.2.254 (Ethernet side of Cisco Router and network (B) location) to get to 10.0.2.0 network

-Network (A) has a second port on the router which is a serial connection that has an IP Address of 10.0.0.1
-Network (B) has a second port on the router which is a serial connection that has an IP Address of 10.0.0.2

-The hardware connections are :
AdTran router Location (A)
        A Reverse Cable pluged into it and goes to WAN side of Pix.  
        Also there is a serial connection from the AdTran that goes to the Router(10.0.0.1)
-Router (A) site
       Serial connection(10.0.0.1) to AdTran router.
       Ethernet Connection (10.0.1.254) to PIX(10.0.1.252)
-Router (B) site
       Serial connection(10.0.0.2) somehow connects to 10.0.0.1. (Guessing this is through an AdTran as well.
       Ethernet Connection (10.0.2.254)
-Pix 501
      Wan side reverse cable to AdTran router
      Ethernet cable from port 1 to Cisco (A) location (10.0.1.254)
      Ethernet cable from port 4 to 24 port hub
      Internal IP of PIX is 10.0.1.252

What I have setup and tested.
-Set up VPN connection using Cisco Client with Split tunneling.  Using 172.16.1.0 network assigned when connecting to VPN.  
When connected I can Ping all computers and devices on 10.0.1.0.  
I can not see  10.0.0.1       (I can if I am on Site)
I can not see 10.0.0.2       (I can if I am on Site)
I can not see 10.0.2.254    (I can on-site)
I can not see any computers on the 10.0.2.0 network.

I am guessing there is a route I need to add but after 8 hours of playing hit or miss I have come to the Experts.

Below is the config on the router.

Result of firewall command: "show config"
 
: Saved
: Written by admin at 08:36:00.028 EDT Fri Jun 23 2006
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxxxxxxxxxxx encrypted
passwd xxxxxxxxxxxxxx encrypted
hostname pixfirewall
domain-name ciscopix.com
clock timezone EST -5
clock summer-time EDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list MGICORP_User_splitTunnelAcl permit ip 10.0.1.0 255.255.255.0 any
access-list MGICORP_User_splitTunnelAcl permit ip 10.0.2.0 255.255.255.0 any
access-list outside_cryptomap_dyn_40 permit ip any 172.16.1.0 255.255.255.224
access-list inside_outbound_nat0_acl permit ip any 172.16.1.0 255.255.255.224
access-list outside_cryptomap_dyn_20 permit ip any 172.16.1.0 255.255.255.224
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside xx.xx.xx.115 255.255.255.248
ip address inside 10.0.1.252 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool External_VPN_Pool 172.16.1.1-172.16.1.25 mask 255.255.255.0
pdm location 10.0.2.0 255.255.255.0 inside
pdm location 172.16.1.0 255.255.255.0 inside
pdm location 10.0.1.0 255.255.255.0 inside
pdm location 172.16.1.0 255.255.255.0 outside
pdm location 10.0.1.0 255.255.255.255 inside
pdm location 10.0.2.0 255.255.255.255 inside
pdm location 10.0.0.0 255.0.0.0 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 xx.xx.xx.113 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
aaa authentication http console LOCAL
aaa authentication serial console LOCAL
aaa authentication ssh console LOCAL
aaa authentication telnet console LOCAL
aaa authorization command LOCAL
http server enable
http 10.0.1.0 255.255.255.0 inside
http 10.0.2.0 255.255.255.0 inside
http 172.16.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
sysopt connection permit-l2tp
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set TRANS_ESP_3DES_MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set TRANS_ESP_3DES_MD5 mode transport
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 40 match address outside_cryptomap_dyn_40
crypto dynamic-map outside_dyn_map 40 set transform-set TRANS_ESP_3DES_MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client authentication LOCAL
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup MGICORP_User address-pool External_VPN_Pool
vpngroup MGICORP_User dns-server 10.0.1.5 xx.xx.xx.2
vpngroup MGICORP_User wins-server 10.0.1.5
vpngroup MGICORP_User default-domain MGICORP
vpngroup MGICORP_User split-tunnel MGICORP_User_splitTunnelAcl
vpngroup MGICORP_User split-dns MGICORP.local
vpngroup MGICORP_User idle-time 1800
vpngroup MGICORP_User password ********
telnet 10.0.1.0 255.255.255.0 inside
telnet 10.0.2.0 255.255.255.0 inside
telnet 172.16.1.0 255.255.255.0 inside
telnet timeout 5
ssh 10.0.1.0 255.255.255.0 inside
ssh 10.0.2.0 255.255.255.0 inside
ssh 172.16.1.0 255.255.255.0 inside
ssh timeout 5
management-access inside
console timeout 0
dhcpd dns 10.0.1.5 64.89.70.2
dhcpd wins 10.0.1.5
dhcpd domain MGICORP
dhcpd auto_config outside
username xxxxxxx password xxxxxxxxxx/ encrypted privilege 15
username xxxxxxx password xxxxxxxxxx/W encrypted privilege 15
username xxxxxxx password xxxxxxxxxxxxx encrypted privilege 3
privilege show level 0 command version
privilege show level 0 command curpriv
privilege show level 3 command pdm
privilege show level 3 command blocks
privilege show level 3 command ssh
privilege configure level 3 command who
privilege show level 3 command isakmp
privilege show level 3 command ipsec
privilege show level 3 command vpdn
privilege show level 3 command local-host
privilege show level 3 command interface
privilege show level 3 command ip
privilege configure level 3 command ping
privilege show level 3 command uauth
privilege configure level 5 mode enable command configure
privilege show level 5 command running-config
privilege show level 5 command privilege
privilege show level 5 command clock
privilege show level 5 command ntp
privilege show level 5 mode configure command logging
privilege show level 5 command fragment
terminal width 80
Cryptochecksum:xxxxxxxxxxxxxxxxxxxxxxxxx



Internally from each site they can see each others
0
Comment
Question by:tthayer
  • 5
  • 4
10 Comments
 
LVL 10

Expert Comment

by:naveedb
ID: 16975967
This part is confusing;

-Router (A) site
       Serial connection(10.0.0.1) to AdTran router.

-Pix 501
      Wan side reverse cable to AdTran router

You have connected PIX and Router throught AdTran router and they are also connected via Ethernet on 10.0.1.0 /24 subnet?

The other item missing on PIX is the route for 10.0.2.0 network, you will need to have a statment like following

route outside 10.0.2.0 255.255.255.0 10.0.1.254 1
0
 
LVL 10

Expert Comment

by:naveedb
ID: 16975970
Sorry, it should be

route inside 10.0.2.0 255.255.255.0 10.0.1.254 1

 
 
 
0
 
LVL 3

Author Comment

by:tthayer
ID: 16987751
I put the route in and the change observed is that the users on the 10.0.2.0 network can now ping the inside interface of the pix which is 10.0.1.252.
The users logged in through the VPN on network 172.16.1.0 can still not ping anything on 10.0.2.0 network.
0
 
LVL 11

Expert Comment

by:prueconsulting
ID: 16989140
I think your nat 0 acl needs to be more specific in terms of what can and can't get to and from each network across the VPN
0
 
LVL 10

Expert Comment

by:naveedb
ID: 16989362
Have you resolved the other issues except for VPN?

For VPN, do you have a route on Router A and Router B that point back to 172.16.1.0 network? If so, post your configirutions from both devices.
0
Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 3

Author Comment

by:tthayer
ID: 16990463
All issues except for VPN are now working.  I had to add a static route 10.0.2.0  10.0.1.254 255.255.255.0
Now  the remaining issue is getting the VPN connections to talk to the 10.0.2.0 network.

There are no routes on router A and B pointing 10 the 10.16.1.0 network

As for the Nat 0 acl being more specific could you give me an example please.

Current below
access-list inside_outbound_nat0_acl permit ip any 172.16.1.0 255.255.255.224

My thoughts  ????
access-list inside_outbound_nat0_acl permit ip any 172.16.1.0 255.255.255.0

Thanks to all thus far.  The static route made a diffference in users from 10.0.2.0 to be able to get out to the internet via 10.0.1.252.
0
 
LVL 10

Expert Comment

by:naveedb
ID: 16996885
Can you post your configs from both routers?
0
 
LVL 3

Author Comment

by:tthayer
ID: 16999239
That is controlled by a third party called NuVox.  I will ask them for the configs Wednesday evening.
0
 
LVL 10

Accepted Solution

by:
naveedb earned 500 total points
ID: 17000816
Or you can ask them to do the following;

Have them add static routes point to 10.0.1.252 for 172.16.1.0 network. This needs to be done on both router A and router B. On router B, they will point to the serial interface of router A.

If they already have it in place, and still not working, have them provide you with configuration and the output from show ip route.
0
 
LVL 3

Author Comment

by:tthayer
ID: 17028703
The answer was correctly given and also some additional insight was acquired.  Thanks for the help.  In that I had difficulty with the vendor I went a different route to be successful.  I changed the IP pool on the pix from a 172.16.1.0 network to a 10.0.1.0 network which is that same as the site I am connecting to by using a couple of ip addresses not in use.  I was then able to see the 10.0.2.0 network.
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

When I upgraded my ASA 8.2 to 8.3, I realized that my nonat statement was failing!   The log showed the following error:     %ASA-5-305013: Asymmetric NAT rules matched for forward and reverse flows It was caused by the config upgrade, because t…
Do you have a windows based Checkpoint SmartCenter for centralized Checkpoint management?  Have you ever backed up the firewall policy residing on the SmartCenter?  If you have then you know the hassles of connecting to the server, doing an upgrade_…
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now