Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 273
  • Last Modified:

Internet Explorer blocking second download request

I've got a flash swf file that pings a PHP script to request a file download.

The first time that the request is made to the PHP script, IE will display the "save as" dialog and save the file without a hitch.

However, the second time the request is made, IE blocks the download and displays the Information bar: "To help protect your security, Internet Explorer blocked the site from downloading the file to your computer."

I tried accessing the PHP script directly through the IE address bar, and the first, scond and third requests did not cause the Info bar to issue a warning. The info bar only pops out when the request is made through the SWF file, on the SECOND (or third) attempt -- even if the subsequent attempts use a unique URL.

It's odd because when the ping to the PHP page is made the first time, IE responds correctly, however, on subsequent attempts to download either the same file or a new file using the link in the SWF file, IE issues a warning.

One would think that IE would issue the warning on the first ping, not subsequent pings.

All the PHP header stuff is set up correctly, so it's not a PHP issue.

It's not a firewall issue (that was triple checked).

My gut tells me that IE is checking the actual URL to the PHP script - (sans query string)...

Example:
http://www/path/to/download.php?theFileID=123

... and parsing just:
http://www/path/to/download.php

... and thinking to it's self, "this file [download.php] was already requested through Flash, I'm not going to let this file be requested through Flash again."

What could IE be doing to allow the first request, but block the second (and third) request either to the same file ID or a new file ID?

It doesn't make sense for a completely unique URL to somehow get interpretted or cached.

Help.
0
gieson
Asked:
gieson
1 Solution
 
giesonAuthor Commented:
I've discovered the problem.

The issue is due to the Flash plugin settings.

- Right-click into the Flash object displayed in IE
- Click on "Settings" from the menu
- Click the llittle folder icon
- Set to "Unlimited" ("How much information can [domain] store on your computer.")
0
 
EE_AutoDeleterCommented:
gieson,
Because you have presented a solution to your own problem which may be helpful to future searches, this question is now PAQed and your points have been refunded.

EE_AutoDeleter
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now