Cisco bonded adsl configuration

Please help!

I have purchased a Cisco 1721 router with 2 Adsl wan Cards. The idea is to bond two adsl lines with my service provider Nildram. I have copied a config someone posted previously to help do this but have had no luck.

My external router ip address should be 213.208.117.83 with a subnet of 255.255.255.248

I can test the connections with the Cisco SDM application and this seems to connect them. But when I got to a PC with the correct dns and default gateway, I cannot browse the internet. I think the problem is with routing but I am no expert. I have posted my config below:



Building configuration...

Current configuration : 1888 bytes
!
! Last configuration change at 09:50:39 UTC Sat Jun 24 2006 by admin
! NVRAM config last updated at 09:47:24 UTC Sat Jun 24 2006 by admin
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname router2
!
boot-start-marker
boot-end-marker
!
no logging buffered
enable secret <>
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
ip name-server 213.208.106.212
ip name-server 213.208.106.213
!
username admin privilege 15 secret <>
!
!
!
interface ATM0
 no ip address
 no ip mroute-cache
 no atm ilmi-keepalive
 bundle-enable
 dsl operating-mode auto
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface ATM1
 no ip address
 no ip mroute-cache
 no atm ilmi-keepalive
 bundle-enable
 dsl operating-mode auto
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface FastEthernet0
 description $ETH-LAN$
 ip address 192.168.42.200 255.255.255.0
 ip nat inside
 speed auto
 full-duplex
!
interface Dialer0
 ip address 213.208.117.83 255.255.255.248
 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp reliable-link
 ppp authentication chap callin
 ppp chap hostname <myhostname>
 ppp chap password <mypassword>
 ppp multilink
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 192.168.42.0 255.255.255.0 FastEthernet0
!
ip http server
!
ip access-list extended sdm_dialer0_out
 remark SDM_ACL Category=1
 permit tcp any eq www any eq www
!
!
control-plane
!
!
line con 0
 password <>
 login
line aux 0
line vty 0 4
 password <>
 login
!
ntp clock-period 17179882
ntp server 195.112.4.14
end
Phil CatterallAsked:
Who is Participating?
 
naveedbCommented:
On the router itself, are you able to ping your DNS server?

If you can, then could be a NAT issue.  I do not see NAT configured, can you add the following lines and try again.

access-list 42 permit 192.168.42.0 0.0.0.255
ip nat inside source list 42 interface dialer 0 overload

0
 
lrmooreCommented:
naveedb beat me to it, but the NAT should be all you need to add.
0
 
Phil CatterallAuthor Commented:
Worked first time thanks.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.