Solved

Error returned while creating the volume shadow copy:80042308

Posted on 2006-06-24
19
7,532 Views
Last Modified: 2008-10-08
I have windows XP SP2 with all updates.

One 200 GB SATA disk partitioned into C and D.  One external 250 GB SATA drive as F.

I am trying to do incrimental backups of C and D every night to F with windows backup.  It always works, but almost always has gives me this error:

Error returned while creating the volume shadow copy:80042308
Reverting to non-shadow copy backup mode.

I notice that if I restart the computer, the next time the backup runs it runs succesfully (i.e. using shadow copy).  However, any subsequent backups give me the error.  I have nothing else scheduled to run at the same time the backup is running, so CPU and DISK I/O should be almost nothing.

Every time this fails, my system log contains two entries:

ID 20: The shadow copy of volume D: was aborted because of a failed free space computation.
ID 20: The shadow copy of volume C: was aborted because of a failed free space computation.

C: currently has 77+ GB free
D: currently has 30+ GB free
F: currently has 55+ GB free

Thank you for your help.
0
Comment
Question by:mrtwice
  • 10
  • 8
19 Comments
 
LVL 30

Assisted Solution

by:callrs
callrs earned 150 total points
Comment Utility
0
 
LVL 69

Expert Comment

by:Merete
Comment Utility
I think it may relate to the size of your hdd.
The full capacity of EIDE drives larger than 137GB (128GB binary) is not recognized in Windows 2000/XP.
Are you sure that xp is recognising the full drive partition?

From a fellow EE LucF http://www.experts-exchange.com/Storage/Q_21272116.html

As your system allready recognizes the full size of the disk, means that it's fully supported, all you need to do now is to extend the partition to the unused space which can be done safely with Diskpart which is included in winXP.

How to use Diskpart.exe to extend a data volume
http://support.microsoft.com/kb/325590

1. At a command prompt, type diskpart.exe.
2. Type list volume to display the existing volumes on the computer.
3. Type Select volume volume number where volume number is number of the volume that you want to extend.
4. Type extend [size=n] [disk=n] [noerr] . The following describes the parameters:
    size=n
    The space, in megabytes (MB), to add to the current partition.
    If you do not specify a size, the disk is extended to take up all of the next contiguous unallocated space.

    disk=n
    The dynamic disk on which to extend the volume. Space equal to size=n is allocated on the disk.
    If no disk is specified, the volume is extended on the current disk.

    noerr
    For scripting only.
    When an error is thrown, this parameter specifies that Diskpart continue to process commands as if the error did not occur.
    Without the noerr parameter, an error causes Diskpart to quit with an error code.  
5. Type exit to quit Diskpart.exe.
0
 
LVL 1

Author Comment

by:mrtwice
Comment Utility
callrs,

I had already found the links you pointed me to, but they are for Windows Server 2003, I have XP.

Merete,

Thanks for the info, but I don't think that is the problem.  I am not having a problem with XP recognizing the partition size.  Additionally, shadow copy works sometimes.
0
 
LVL 69

Expert Comment

by:Merete
Comment Utility
only thing I can think of is if your page filing or virtual memory or the lack of locks up momentary, would defragging be a silly suggestion, if the backup is big maybe windows is having a small fit allocating into the spaces on the external drive, hence the boot refreshes ,use the defrag tool and analyze this exteranl drive if there is red maybe just the issue.
Have a look in control panel administrative tools event viewer applications or performance logs .

0
 
LVL 69

Expert Comment

by:Merete
Comment Utility
The System event log should contain a VOLSNAP
entry explaining the reason of why the shadow copy went away.
0
 
LVL 1

Author Comment

by:mrtwice
Comment Utility
I defraged every drive.  Drive F (external) was very fragemented and there is still one large backup file that won'e defragment, but that didn't change my backup situation any.  

Concering the VOLSNAP entries, I included them in my original question:

ID 20: The shadow copy of volume D: was aborted because of a failed free space computation.
ID 20: The shadow copy of volume C: was aborted because of a failed free space computation.
0
 
LVL 69

Expert Comment

by:Merete
Comment Utility
Looking at the Link callrs  provided  and reading thru it I did find this
Software shadow copies do not complete on large volumes that use a small cluster size:
To diagnose the Volume Shadow Copy service writer problem, run the vssadmin command immediately after the backup failure:
1. Click Start, and then click Run.
2. Type vssadmin list writers.
This command lists the Volume Shadow Copy service writers and the current state of each writer. For example, the output might indicate that the Microsoft SQL Server Desktop Engine (MSDE) or the Microsoft Active Directory writer failed. You may experience time-out errors on several writers, including the MSDE writer, the SQL writer, the NT Directory Service (NTDS) writer, the Windows Internet Naming System (WINS) writer, the Dynamic Host Configuration Protocol (DHCP) writer, the Remote Storage writer, the certification authority writer, and the Microsoft Exchange writer. The following is sample output:
http://support.microsoft.com/?kbid=833167
0
 
LVL 69

Expert Comment

by:Merete
Comment Utility
Could it memory related  how much ram do you have, it may even heat issues.
Do you have Outlook or rather are you using Outlook?
BTW are we talking about a server or a stand alone computer?

NTBackup and Shadow Copy question  
http://www.comphelpone.com/new-3903616-3851.html

Here is a bit on Outlook
With outlook I wrote a script to kill any instances of Outlook running on
workstations at midnight so that no .psts were open when the backup started
at 12:30am and ran it using Scheduler.
http://www.webservertalk.com/archive304-2005-1-894204.html

From another forum
Since none of the symptoms seemed to match exactly, what I did was
to increase the volume shadow copy space allocation by 25% and
manually ran the backup using the selections from the script.  THAT
worked.

What's troubling to me is that there were numerous shadow copies on
that volume and none of them was "sacrificed" to accomodate the backup
run
http://groups.google.com/group/microsoft.public.windows.server.sbs/browse_thread/thread/670d09e724465abe/56e0e98fb636e53b?lnk=st&q=Error+returned+while+creating+the+volume+shadow+copy%3A80042308&rnum=1&hl=en#56e0e98fb636e53b

Hope this helps. But hey we are working with windowsxp  from MS anything can happen. Ghosts :)
0
 
LVL 1

Author Comment

by:mrtwice
Comment Utility
I will try the vss admin command to see if that helps.

1GB Ram.

I doubt its a heat issue, I am a developer and use my computer A LOT and i have no other wierd problems.

Almost brand new Acer desktop computer.

Outlook is installed, but I hardly ever use it and it isn't open when the backups run.

I will get back to you on the vss admin thing.
0
Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

 
LVL 1

Author Comment

by:mrtwice
Comment Utility
Well, the problem has suddenly disappeared. And there are only two things that I can think of that might have caused it:

1)  I don't think I ever restarted my machine after I defraged the drives.  Since I defraged and restarted, I have not had any problems (I think).

2)  The only other thing I have done is modify the script that calls the Windows backup program.  I use a PHP script to call the backup and then email me the log report.  I modified the script to run "vssadmin list writers" before and after each backup run.  I did this so that I could compare the entries and see if the writers might be causing the problem.  Even though several of my writers seem to constantly be in the state of "Waiting for completion," the backups are now working properly.

So, problem solved?  I hope so.  Thanks Merete for all your help.  I am going to wait another week or two just to make sure that the problem is really solved, and if so, I will award you the points for your help.

Thanks.
0
 
LVL 69

Expert Comment

by:Merete
Comment Utility
yey sounds good mrtwice  I like to reboot after a defrag as it seems to reset things defragging does move a lot of files from their original positions.
Great to hear.And fingers crossed.
regards Merete
0
 
LVL 1

Author Comment

by:mrtwice
Comment Utility
The problem came back :(

I defraged all my drives again and rebooted.  I then waited until the next scheduled backup and I am still having the problem of the shadow copy going away.

I am really not sure where to go from here.  I am going to put something on the Microsoft Newsgroups to see if I can get an answer there.
0
 
LVL 69

Expert Comment

by:Merete
Comment Utility
mrtwice is this a server?
Just wondering if it could be related to the different sized hard disk?
This id 20 do you have any idaes what it is? Layman here, but if is a file on a client that does not release properly can it cause an issue when backing up?
I dont know the language, but goes something like, while the shadow copy is in progress it is reading ahead and behind then copying over, if the read behind what it is picking up/copying has a problem fitting ahead because of either a fault in a file . Something like that.
Again I dont know the correct language but I see it in my head, does the shadow engine read ahead to the copy to directory of the whole hdd or what amount of HDD space does it read ahead, we aretalking about an electrical current here..as the hdd it is copying from is smaller than the HDD it is copying to, could it create a some kind of  echo? Hence as you reboot it seems to pull it all together tight again.


I had a read of these and found them informative.
There is some suggestions of your problem on MS sites. Butcurrently seem to be down.


PDF] The Evolution of Coda
Each volume is a partial subtree of the total name space, and its point of ... For store records, a shadow copy of the file is created. based on bandwidth. ...
http://portal.acm.org/ft_gateway.cfm?id=507053&type=pdf&coll=GUIDE&dl=ACM&CFID=15151515&CFTOKEN=6184618

[PDF] HP Volume Shadowing for OpenVMS
http://h71000.www7.hp.com/doc/732FINAL/DOCUMENTATION/PDF/aa-pvxmj-te.PDF

[PDF] Introduction StoreGrid
Storage Server, it is possible to use the Volume Shadow Copy feature to support ... backup location because StoreGrid uses the total free space in all  
http://www.vembu.com/storegrid/storegrid-backup-software.pdf
0
 
LVL 1

Author Comment

by:mrtwice
Comment Utility
This is still a problem for me and I have not found a solution.  

No, it is a desktop machine.

What do you mean by "different sized disks."

What MS sites are you referring to?  Might they be back up now?


0
 
LVL 69

Accepted Solution

by:
Merete earned 350 total points
Comment Utility
Hello mrtwice I have some time to dedicate to your problem now,
I was wondering if these large had drives having different sizes could be related.
Have you had a chance to look at  callrs link? I know it is for a server but it is similar.
CAUSE
This problem occurs because of a problem with non-paged pool allocation. This problem may occur if the difference (diff) area volume is not available after startup.
The above are caused by resource problems 0xC000009A STATUS_INSUFFICIENT_RESOURCES = Insufficient system resources exist to complete the API.

Note This problem may be temporarily resolved by restarting the computer.  
• After you restart your Windows Server 2003-based computer, your Volume Shadow Copy service snapshots are lost.  
------------------------------------------------
Now I know you have a xp sp2 desktop not server, no lan no network? jus yourself :)
Is this xphome or pro?
What program are you using to backup?
And yes the MS sites all seem to up and running again.
-----------------------------------------------------------------
I found this similar problem here and its not for a server.A bit lengthy..
--------------------------------------------------
Possible Solution (these instructions are for XP)
Open Control Panel, Administrative Tools, COMPONENT Services
Inside the Console Root folder, goto COMPONENT Services -> Computers -> My Computer -> Com+ Applications.
On the top toolbar, click on View, Status (or click the Status button on the toolbar).

You will see all Com+ applications and their statuses including the Application ID and the PID (if currently running).
Make a note of the Application ID for the MS Software Shadow Copy Provider entry.


Next check the command line used for the SwPrv service. Navigate back to the top root folder. Inside the Console Root folder, goto Services (local). Note, you can also get here from Control Panel, Administrative Tools, Services.

Find the MS Software Shadow Copy Provider Service and double click on it. Notice the Path to Executable field. It will have an entry similar to the following:
C:\WINDOWS\System32\dllhost.exe /Processid:{xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}

Check to make sure that the GUID inside the curly brackets is the exact same as what you found in the Application ID in the first step. If it isn't, then this is what is preventing the service from starting.

To correct, open regedit and navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SwPrv
Double click on the ImagePath value and make the necessary correction.

It is obviously a good idea to export a backup reg file of the above key in case you make a mistake or need to restore the original settings.



0
 
LVL 1

Author Comment

by:mrtwice
Comment Utility
I think you were correct to look at the link that callrs provided.  I had looked at this before, but I didn't figure it would apply b/c it was for Windows Server 2003.  I noticed this line:

"When you try to create shadow copies on large volumes that have a small cluster size (for example, less than 4 kilobytes [KB]), or if you take snapshots of several very large volumes at the same time,"

Now, I figured out that my cluster size is set to 512k and my volumes are about 90 GB each.  I am not sure what they mean by "very large volumes," but it is very likely that this is the cause.  I cofirmed this hypothesis when I read this line from the link MS support link from callrs:

"Note You may receive other events that are not described in this article. A value of 0xc000009a (STATUS_INSUFFICIENT_RESOURCES) in the NTSTATUS part of the event at offset 0x14 indicates a problem with the memory resource allocation."

Both event IDs noted in my original question have the following data attached to them:

0000: 00000000 00580002 00000000 c0060014
0010: 00000000 c000009a 00000003 00000000
0020: 00000000 00000000

Note that the 0x14 offset is indeed indicative of a memory resource allocation problem.

So, I am now questioning how I should fix this problem.

To answer your questions:

XP SP2 Pro that was upgraded from XP home
Desktop computer, but yes I am on a personal LAN with several other computers
I am using the built-in XP backup utility

I checked out the possible solution you provided, but the IDs were the same.

To try and troubleshoot this problem I decided to backup one drive at a time and see if that fixed my problem.  It did not :(.

Suggestions for fixing this?  Any chance the Hotfix by MS would fix this on XP?
0
 
LVL 69

Expert Comment

by:Merete
Comment Utility
Hmm, inch by inch.
 if you have any mind left lol browse the links I provided, just kinda pass over that first one it does seem to put an angle on things with backing up.
ok I'll put here them again, its hard going backup . :)

PDF] The Evolution of Coda
Each volume is a partial subtree of the total name space, and its point of ... For store records, a shadow copy of the file is created. based on bandwidth. ...
http://portal.acm.org/ft_gateway.cfm?id=507053&type=pdf&coll=GUIDE&dl=ACM&CFID=15151515&CFTOKEN=6184618

[PDF] HP Volume Shadowing for OpenVMS
http://h71000.www7.hp.com/doc/732FINAL/DOCUMENTATION/PDF/aa-pvxmj-te.PDF

[PDF] Introduction StoreGrid
Storage Server, it is possible to use the Volume Shadow Copy feature to support ... backup location because StoreGrid uses the total free space in all  
http://www.vembu.com/storegrid/storegrid-backup-software.pdf
0
 
LVL 1

Author Comment

by:mrtwice
Comment Utility
I still have not found the solution to this problem, but I think the diagnosis is accurate.  I went ahead and awarded the points in a way I thought was fair.  The B grade was because the problem was well diagnosed but still not fixed.  I am going to try reformating the drive to have 4 KB clusters and see if that helps.  I will continue to post results.

Thanks for your help.
0
 
LVL 69

Expert Comment

by:Merete
Comment Utility
you are wellcome,and thank you.. sorry i have no solution/ Only the diagnoses. It seems to be a problem mentioned around the ridges so you are not alone but no solution not even from the the great microsoft team/
0

Featured Post

Free Gift Card with Acronis Backup Purchase!

Backup any data in any location: local and remote systems, physical and virtual servers, private and public clouds, Macs and PCs, tablets and mobile devices, & more! For limited time only, buy any Acronis backup products and get a FREE Amazon/Best Buy gift card worth up to $200!

Join & Write a Comment

Most of the time we are in fix when all of sudden our systems behave weirdly.  Such problems cost time and effort... so it's best to take some preventive actions so that we can avoid such issues or overcome such problems more easily. Preventive M…
If your system is showing symptoms of browser hijacks or 'google search redirects' check out my other article (http://rdsrc.us/u3GP7A) first and run the tool TDSSKiller (http://rdsrc.us/GDBBs4) to get rid of the infection. Once done, and if the …
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…
This video explains how to create simple products associated to Magento configurable product and offers fast way of their generation with Store Manager for Magento tool.

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

6 Experts available now in Live!

Get 1:1 Help Now