Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Dtabase object error-

Posted on 2006-06-24
5
Medium Priority
?
588 Views
Last Modified: 2009-08-04
Hello,

I designed a report (Crystal Reports XI) to read a database table and display the contents in a report.  The report uses a database command to query the table.
SELECT  *
FROM    RPTINGDATA.SLDACCTSUM
WHERE   DMNAME NOT IN ('FFFINAL','FFPREFINAL')
AND        SALEBATCHID <> ''
When I run the report "on demand" or "run now" it executes correctly.  When I schedule the report to run under Business Objects Enterprises I get the following error:
Error in File C:\Program Files\Business Objects\BusinessObjects Enterprise 11\Data\procSched\myusswalprv0010.reportjobserver\~tmp49c045a26deae415.rpt: Error in formula <Record Selection>. '{SLDACCTSUM.DMNAME} <> "FFFINAL" and ' This field name is not known. Details: errorKind

Any Idead what my problem is?
   
0
Comment
Question by:BrianMack
  • 3
  • 2
5 Comments
 
LVL 101

Expert Comment

by:mlmcc
ID: 16976984
Does the "userid" the report runs under have database permissions?

mlmcc
0
 

Author Comment

by:BrianMack
ID: 16977141
It's my Id. It should.
0
 
LVL 101

Accepted Solution

by:
mlmcc earned 500 total points
ID: 16977234
Are you sure.  Generally scheduled reports run under a generic id not a specific users.  I don't use BO Enterprise so it may do it that way.  Does it only run when you are logged in?

mlmcc

0
 

Author Comment

by:BrianMack
ID: 16985880
I think that was the problem.  I logged in as administrator and scheduled the job and it worked fine.  Thanks
0
 
LVL 101

Expert Comment

by:mlmcc
ID: 16989485
Glad i could help

mlmcc
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hot fix for .Net Crystal Reports 10.2.3600.0 to fix problems with sub reports running on 64 bit operating systems ISSUE: Reports which contain subreports fail with error "Missing Parameter Value" DEPLOYMENT SERVER OS: Windows 2008 with 64 bi…
Hello everyone, Hope you find this as helpful as we did. We have on the company I work for an application built in Delphi V with Crystal Reports 8. We all know that Crystal & Delphi can be temperamental sometimes and the worst thing is, nearly…
Please read the paragraph below before following the instructions in the video — there are important caveats in the paragraph that I did not mention in the video. If your PaperPort 12 or PaperPort 14 is failing to start, or crashing, or hanging, …
Screencast - Getting to Know the Pipeline
Suggested Courses
Course of the Month10 days, 17 hours left to enroll

885 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question