Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

VSAT Proxy Configuration

Posted on 2006-06-25
5
Medium Priority
?
1,271 Views
Last Modified: 2008-02-01
I am trying to deploy a transparent proxy to a VSAT link and running into some issues with delay.  Latency a side I can't seem to configure squid to work efficently and was looking for some input on anyone who has achieved this without lossing browsing performance.  Currently I have an older poweredge 933 DP 2500 with 1GB RAM and 2 72GB SCSI Drives as my Squid server.  I use the secondary drive to store the cache and I feel these settings are more than ample for good performance out od squid.  My VSAT link is 1024:512 and runs an average latency of about 550ms.  My major concern is that we basically pay for usage and the network is rather busy so a proxy only makes sence to cut down on unnessisary usage.  I have tweaked the config file and network settings for the squid proxy but still i am getting a lets say 1/2 to 1 second delay before the pages begin to load.  I understand the latency issue but if I bypass the proxy the web browsing is much more fluid.  I am lookinf for input into maybe another proxy or examples of ways to overcome this issue with squid.  I have started to look into sockd http://www.inet.no/dante/ as a solution but would like some input from users who have deplyed a working VSAT proxy with effiecent results.

VSAT ISP|{-------}|Cisco 1811 Router|------|VLAN|-------\Transparent Web Proxy/----|_+network
0
Comment
Question by:hexfusion
  • 2
3 Comments
 
LVL 27

Expert Comment

by:Nopius
ID: 16981756
Did you tried NON-TRANSPARENT configuration. That's to be shure, that delays are the same in both cases.
0
 
LVL 27

Accepted Solution

by:
Nopius earned 1000 total points
ID: 16981813
Also please check your squid.conf configuration, like described here: http://www.squid-cache.org/Doc/FAQ/FAQ-17.html
The importent options are httpd_accell_*:

http_port 8080
httpd_accel_host virtual
httpd_accel_port 80
httpd_accel_with_proxy  on
httpd_accel_uses_host_header on
0
 
LVL 5

Assisted Solution

by:ranadastidar
ranadastidar earned 1000 total points
ID: 16990482
just read following article, it ll definitely help u a lot

http://www.linuxsolved.com/forums/ftopic116.html
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Is your data getting by on basic protection measures? In today’s climate of debilitating malware and ransomware—like WannaCry—that may not be enough. You need to establish more than basics, like a recovery plan that protects both data and endpoints.…
Suggested Courses

783 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question