Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 503
  • Last Modified:

It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in

Hi Experts,

i got this error

It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS.

How do I go about resolving this
"This error can be caused by a virtual directory not being configured as an application in IIS."

thanks


0
SirReadAlot
Asked:
SirReadAlot
  • 7
  • 3
1 Solution
 
Swapnil PipariaArchitectCommented:
Hi SirReadAlot,
you can resolve it by going to run start menu->run->type inetmgr->opening internet information services (IIS).
now expand all nodes and go to "default web site" on right side of window. search for your application directory in tree.
right click on your directory and go to properties menu option.
on side of application name textbox press create button.
and its all done.


Regards,
NetSwap
0
 
SirReadAlotAuthor Commented:
will try this

thanks
0
 
SirReadAlotAuthor Commented:

hi
this step
"on side of application name textbox press create button"

does not have the create, it has remove.

I am using winxp
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Swapnil PipariaArchitectCommented:
ok. then click remove it will be changed to create and then press create again.
0
 
SirReadAlotAuthor Commented:
will do this
0
 
SirReadAlotAuthor Commented:
Thanks mate,

But I still have the same error

thanks
0
 
SirReadAlotAuthor Commented:
Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS.


then this is highlighted

<authentication mode="Windows" />
0
 
Swapnil PipariaArchitectCommented:
ok then apply following steps
start menu->run->type inetmgr->opening internet information services (IIS).
now expand all nodes and go to "default web site" on right side of window. search for your application directory in tree.
right click on your directory and go to properties menu option.
go to Directory Security Tab -> press Edit button

and in that screen check "Integrated windows authentication" check box, if it is not.
0
 
SirReadAlotAuthor Commented:
will try this
0
 
SirReadAlotAuthor Commented:
thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 7
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now