Solved

.forward file not working

Posted on 2006-06-26
4
339 Views
Last Modified: 2013-12-27
hello

I am running solaris 8 and my .forward file is not working - any ideas?

thanks
jculkincys
0
Comment
Question by:jculkincys
4 Comments
 
LVL 34

Accepted Solution

by:
PsiCop earned 300 total points
Comment Utility
Is the user's directory group- or world-writable?

Is the .forward file group- or world-writable?

Any error messages in the system log?
0
 
LVL 10

Expert Comment

by:Nukfror
Comment Utility
Well, a little more information would be helpful :)  Like maybe what you .forward file looks like - obviously obfuscated to non-real email address.   Also, have you look in the /var/adm/messages ?  Depending on how your system is configured, sendmail (or whatever SMTP engine your using) may be putting messages into /var/adm/messages.  This could help you figure out where your .forward may be failing.
0
 
LVL 2

Author Comment

by:jculkincys
Comment Utility
sorry for the lack of info

I think PsiCop is on the right path

Computer1 (where .forward does not work)
...
drwxr-xr-x   6 user groupa    2048 Jun 26 09:47 .
drwxrwxr-x   8 root     root         512 Apr  5 11:04 ..
...

Computer2 (where .forward does work)
...
drwxr-xr-x   4 user groupb     2560 Jun 26 09:50 .
drwxr-xr-x   9 root     other        512 Apr  5 11:05 ..
...

Also there was an error on the syslog file:
Jun 22 23:59:20 hostname sendmail[num]: [ID num mail.warning] identifier: forward /e
xport/home/user/.forward.hostname+: Group writable directory


The .forward file are the same on the 2 computers

jculkincys
0
 
LVL 27

Assisted Solution

by:Nopius
Nopius earned 200 total points
Comment Utility
> /export/home/user/.forward.hostname+: Group writable directory
Thats an explaination.  Also this "drwxrwxr-x   8 root     root         512 Apr  5 11:04 .."

You have a group writable directory /export/home/ (root group has a write permission).
If it's not importent, disable group writable flag:
chmod g-w /export/home
chmod g-w /export/home/user

OR

If it's importent to have root group writable user directory disable group writable checks in sendmail.cf (it should be somewhere below /etc or /etc/mail):
Uncomment and change this line:

#O DontBlameSendmail=safe
O DontBlameSendmail=ForwardFileInGroupWritableDirPath,ForwardFileInUnsafeDirPath,ForwardFileInUnsafeDirPathSafe

then restart sendmail
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

Installing FreeBSD… FreeBSD is a darling of an operating system. The stability and usability make it a clear choice for servers and desktops (for the cunning). Savvy?  The Ports collection makes available every popular FOSS application and packag…
Why Shell Scripting? Shell scripting is a powerful method of accessing UNIX systems and it is very flexible. Shell scripts are required when we want to execute a sequence of commands in Unix flavored operating systems. “Shell” is the command line i…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now