Solved

Cisco PIX 515e and VPN Client 4.8.01.0300 - 20/40 Min Connection Dropout, No Reconnection Possible

Posted on 2006-06-26
4
1,118 Views
Last Modified: 2012-05-05
After reading over a couple of solutions for VPN with a PIX 515e I found none that helped with my problem, I hope that someone out there can help me.

I have recently setup a vpn for my company, we are behind a private network which leads to some complications it seems however, i have implemented the following. (see config)

The main problem:-

The external user can connect to the vpn, however after 20-30 minutes of connection, the connection drops out. After the drop out the user is unable to reconnect to the VPN indefinatly, with the following error:-

Unable to establish Phase 1 SA with server "193.238.165.103" because of "DEL_REASON_PEER_NOT_RESPONDING"

PIX 515e Config:

----------------------------------------------------------------------------------------------------------------------------------------

PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password <Cut> encrypted
passwd <Cut> encrypted
hostname test-vpn
domain-name test.local
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 10.1.0.0 LAN
access-list vpnuser_splitTunnelAcl permit ip LAN 255.255.0.0 any
access-list inside_outbound_nat0_acl permit ip LAN 255.255.0.0 10.1.4.0 255.255.255.224
access-list outside_cryptomap_dyn_20 permit ip any 10.1.4.0 255.255.255.224
access-list outside_access_in permit ip any any
access-list 101 permit ip LAN 255.255.0.0 10.1.4.0 255.255.255.224
access-list 101 permit ip any 10.1.4.0 255.255.255.224
access-list inside_cryptomap_dyn_20 permit ip any 10.1.4.0 255.255.255.224
access-list outside_cryptomap_dyn_40 permit ip any 10.1.4.0 255.255.255.224
pager lines 24
logging on
mtu outside 1500
mtu inside 1500
ip address outside 1.1.1.1 255.255.255.0
ip address inside 10.1.0.251 255.255.0.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnpool 10.1.4.1-10.1.4.25 mask 255.255.0.0
no failover
failover timeout 0:00:00
failover poll 15
no failover ip address outside
no failover ip address inside
pdm location LAN 255.255.0.0 inside
pdm location LAN 255.255.255.0 inside
pdm location 10.1.4.0 255.255.255.224 outside
pdm logging debugging 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 0 0.0.0.0 0.0.0.0 0 0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 1.1.1.2 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 0.0.0.0 0.0.0.0 outside
http 0.0.0.0 0.0.0.0 inside
http LAN 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
tftp-server inside 10.1.2.131 /
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 40 match address outside_cryptomap_dyn_40
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5
crypto dynamic-map inside_dyn_map 20 match address inside_cryptomap_dyn_20
crypto dynamic-map inside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto map inside_map 65535 ipsec-isakmp dynamic inside_dyn_map
crypto map inside_map interface inside
isakmp enable outside
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup TestVPN address-pool vpnpool
vpngroup TestVPN dns-server 10.1.0.10 10.1.0.11
vpngroup TestVPN wins-server 10.1.0.10 10.1.0.11
vpngroup TestVPN default-domain TestVPN.com
vpngroup TestVPN idle-time 600
vpngroup TestVPN user-idle-timeout 90
vpngroup TestVPN password <Cut>
telnet LAN 255.255.0.0 inside
telnet timeout 7
ssh timeout 5
console timeout 0
terminal width 80

----------------------------------------------------------------------------------------------------------------------------------------

Error Log:-

----------------------------------------------------------------------------------------------------------------------------------------

Cisco Systems VPN Client Version 4.8.01.0300
Copyright (C) 1998-2005 Cisco Systems, Inc. All Rights Reserved.
Client Type(s): Windows, WinNT
Running on: 5.1.2600 Service Pack 2

62     16:17:00.731  06/26/06  Sev=Info/4      CM/0x63100002
Begin connection process

63     16:17:00.781  06/26/06  Sev=Info/4      CM/0x63100003
Establish secure connection using dialup services

64     16:17:00.851  06/26/06  Sev=Info/4      IPSEC/0x63700008
IPSec driver successfully started

65     16:17:00.851  06/26/06  Sev=Info/4      IPSEC/0x63700014
Deleted all keys

66     16:17:00.851  06/26/06  Sev=Info/4      IPSEC/0x6370000D
Key(s) deleted by Interface (195.40.198.96)

67     16:17:01.090  06/26/06  Sev=Info/4      PPP/0x63200014
Dialing "C:\Documents and Settings\All Users\Application Data\Microsoft\Network\Connections\Pbk\rasphone.pbk" "Eidos".

68     16:17:01.200  06/26/06  Sev=Info/4      PPP/0x63200023
RAS connection entry has 1 subentries

69     16:17:35.185  06/26/06  Sev=Info/4      PPP/0x6320000A
PPP session is up

70     16:17:35.185  06/26/06  Sev=Info/4      CM/0x6310000B
PPP session established

71     16:17:35.185  06/26/06  Sev=Info/4      CM/0x63100024
Attempt connection with server "193.238.165.103"

72     16:17:35.355  06/26/06  Sev=Info/6      IKE/0x6300003B
Attempting to establish a connection with 193.238.165.103.

73     16:17:35.485  06/26/06  Sev=Info/4      IKE/0x63000013
SENDING >>> ISAKMP OAK AG (SA, KE, NON, ID, VID(Xauth), VID(dpd), VID(Frag), VID(Nat-T), VID(Unity)) to 193.238.165.103

74     16:17:40.583  06/26/06  Sev=Info/4      IKE/0x63000021
Retransmitting last packet!

75     16:17:40.583  06/26/06  Sev=Info/4      IKE/0x63000013
SENDING >>> ISAKMP OAK AG (Retransmission) to 193.238.165.103

76     16:17:45.590  06/26/06  Sev=Info/4      IKE/0x63000021
Retransmitting last packet!

77     16:17:45.590  06/26/06  Sev=Info/4      IKE/0x63000013
SENDING >>> ISAKMP OAK AG (Retransmission) to 193.238.165.103

78     16:17:50.597  06/26/06  Sev=Info/4      IKE/0x63000021
Retransmitting last packet!

79     16:17:50.597  06/26/06  Sev=Info/4      IKE/0x63000013
SENDING >>> ISAKMP OAK AG (Retransmission) to 193.238.165.103

80     16:17:55.619  06/26/06  Sev=Info/4      IKE/0x63000017
Marking IKE SA for deletion  (I_Cookie=CE13C46F1F4E46D9 R_Cookie=0000000000000000) reason = DEL_REASON_PEER_NOT_RESPONDING

81     16:17:56.132  06/26/06  Sev=Info/4      IKE/0x6300004B
Discarding IKE SA negotiation (I_Cookie=CE13C46F1F4E46D9 R_Cookie=0000000000000000) reason = DEL_REASON_PEER_NOT_RESPONDING

82     16:17:56.132  06/26/06  Sev=Info/4      CM/0x63100014
Unable to establish Phase 1 SA with server "193.238.165.103" because of "DEL_REASON_PEER_NOT_RESPONDING"

83     16:17:56.132  06/26/06  Sev=Info/5      CM/0x63100025
Initializing CVPNDrv

84     16:17:56.413  06/26/06  Sev=Info/6      CM/0x63100046
Set tunnel established flag in registry to 0.

85     16:17:56.454  06/26/06  Sev=Info/4      IKE/0x63000001
IKE received signal to terminate VPN connection

86     16:17:56.675  06/26/06  Sev=Info/4      IPSEC/0x63700014
Deleted all keys

87     16:17:56.675  06/26/06  Sev=Info/4      IPSEC/0x63700014
Deleted all keys

88     16:17:56.675  06/26/06  Sev=Info/4      IPSEC/0x63700014
Deleted all keys

89     16:17:56.675  06/26/06  Sev=Info/4      IPSEC/0x6370000A
IPSec driver successfully stopped

90     16:17:56.685  06/26/06  Sev=Info/4      PPP/0x63200018
Disconnecting "C:\Documents and Settings\All Users\Application Data\Microsoft\Network\Connections\Pbk\rasphone.pbk" "Eidos". SilentDisconnect: 1

91     16:17:58.158  06/26/06  Sev=Info/4      PPP/0x6320001A
PPP session terminated

----------------------------------------------------------------------------------------------------------------------------------------

I hope someone can see the error in my config, i'm snowblinded by it all now!

Thanks in advance.
0
Comment
Question by:Gravatom
4 Comments
 

Author Comment

by:Gravatom
ID: 16985068
I forgot to mention the only way i have found to allow the vpn user to establish a connection again is to power cycle the pix, clear xlate or a reload doesn't seem to cut it!
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 16988335
//--Yes:
access-list 101 permit ip LAN 255.255.0.0 10.1.4.0 255.255.255.224

//-- NO: Never use "any" in the IPSEC acls
access-list 101 permit ip any 10.1.4.0 255.255.255.224
access-list inside_cryptomap_dyn_20 permit ip any 10.1.4.0 255.255.255.224
access-list outside_cryptomap_dyn_40 permit ip any 10.1.4.0 255.255.255.224

//-- NO: You do not want the VPNpool a subset of your internal LAN
ip address inside 10.1.0.251 255.255.0.0
ip local pool vpnpool 10.1.4.1-10.1.4.25 mask 255.255.0.0

//-- YES (changes) Note the
ip local pool VPNPOOL2 10.4.4.1-10.4.4.25
access-list inside_cryptomap_dyn_20 permit ip LAN 255.255.0.0 10.4.4.0 255.255.255.0

//-- Yes:
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5

//-- NO: These are redundant and need to go away:
crypto dynamic-map outside_dyn_map 40 match address outside_cryptomap_dyn_40
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5
crypto dynamic-map inside_dyn_map 20 match address inside_cryptomap_dyn_20
crypto dynamic-map inside_dyn_map 20 set transform-set ESP-3DES-MD5

//-- YES: Keep
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map

//-- make the above changes, then re-enter this command to re-apply the crymap to the interface
crypto map outside_map interface outside

//-- NO: These need to go away. You don't want the crymap applied to the inside
crypto map inside_map 65535 ipsec-isakmp dynamic inside_dyn_map
crypto map inside_map interface inside

Add the following:
 isakmp identity address

0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
VPN access 5 46
VPN Problems 3 52
Sophos UTM Endpoint VPN 2 28
printer shows as offline while connected to vpn 13 35
One of the Top 10  common Cisco VPN problems are not-matching shared keys. This is an easy one to fix, but not always easy to notice, see the case below. A simple IPsec tunnel between fast Ethernet interfaces of routers SW1 (f1/1) and R1(f0/0). …
For a while, I have wanted to connect my HTC Incredible to my corporate network to take advantage of the phone's powerful capabilities. I searched online and came up with varied answers from "it won't work" to super complicated statements that I did…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now