Solved

Site to Site PIX VPN setup

Posted on 2006-06-26
12
359 Views
Last Modified: 2010-04-12
Hello,

I have been given the job of setting up one end of a VPN tunnel on a Cisco 515E-UR using the following information

"site A" External IP addr - 1.1.1.1
VPN Shared key - verysecure
Encryption method - 3DES-168
Hide NAT at "site B" - 2.2.2.2

I am used to setting up netscreen firewalls and this does not seem like enough information to me. Can anyone advise me if this is possible with the information and what configuration steps i will need to take.

Many Thanks

Rob J
0
Comment
Question by:SmartFix
  • 6
  • 4
  • 2
12 Comments
 
LVL 19

Expert Comment

by:nodisco
ID: 16988081
Hi Rob

Is this a PIX at each end?  If so - what OS is the PIX running on?  6.x or 7.x?
You will need to elaborate on what you mean by "Hide NAT at "site B" - 2.2.2.2"

Here is a URL for configuring a basic PIX>PIX IPSec tunnel using DES - just replace this with 3DES for your tunnel:
http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a0080094761.shtml

hope this helps
0
 

Author Comment

by:SmartFix
ID: 16988623
I will find out the PIX OS and should have result on OS by 10am GMT I think it will be around 3 years old the PDM is 3.0(1) if that helps

THe config is for the remote PIX which we need to match at our end

Hide NAT at remote site - 10.127.**.**  (I only have ideas as to what his is about)

Maybe a diagram can help

Site A    -   PIX   -   WWW   -   PIX   -   DMZ   -   Client PC

Just had a quick look at the link unfortunately I am a child of the Web GUI so it will take a while to translate but i should be able to work out if it is relevant.

0
 

Author Comment

by:SmartFix
ID: 16990952
Pix version 6.3(3)

Licensed Features:
Failover:                    Enabled
VPN-DES:                     Enabled
VPN-3DES-AES:                Enabled
Maximum Physical Interfaces: 6
Maximum Interfaces:          10
Cut-through Proxy:           Enabled
Guards:                      Enabled
URL-filtering:               Enabled
Inside Hosts:                Unlimited
Throughput:                  Unlimited
IKE peers:                   Unlimited
0
 
LVL 19

Expert Comment

by:nodisco
ID: 16991345
Here you go mate - PDM example of how to configure the tunnel with PIX 6.X

This should get you going:
http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a008055bd85.shtml

Again - this uses DES as encryption - just change to 3DES and you're set
hope this helps
0
 

Author Comment

by:SmartFix
ID: 17010932
Plot thickens

PIX to VPN concentrator

Think they want us to NAT all internal to a single IP for the tunnel? IP is not related to anything i know of?

Nothing has worked so far

Concentrator config

Bi directional
Use PSK
Auth -ESP/MD5/HMAC-128
Encrypt 3DES-168
IKE Prop IKE 3DES MD5
0
 
LVL 19

Accepted Solution

by:
nodisco earned 350 total points
ID: 17014410
<<Think they want us to NAT all internal to a single IP for the tunnel?


To me it sounds like they want to nat the internal range to a different range that does not conflict with something on their side - its the only reason i can think of that they would want you to nat it.  Here is a sample config for configuring a PIX 6.(x) to a VPN concentrator where you have to nat the PIX range - it should do exactly what you wish.
Remember that when you are configuring the tunnel, you will need to initiate a connection from inside either the PIX or Concentrator to bring the tunnel up - it won't just come up itself.

http://www.cisco.com/en/US/tech/tk583/tk372/technologies_configuration_example09186a00800949f1.shtml

hope this helpe
0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 

Author Comment

by:SmartFix
ID: 17017335
It gets worse.... my head hurts so near to giving up, I have tried everything my non pix brain can handle


If I add

!--- Defines IPSec interesting traffic.
!--- Note that the host behind PIX communicates
!--- to Private_LAN1 using 192.168.58.0/24.
!--- When the packets arrive at the PIX, they are first  
!--- translated to 192.168.25.0/24 and then encrypted by IPSec.

access-list 101 permit ip 10.**7.*5.0 255.255.255.0 192.168.25.0 255.255.255.0
ip address outside 82.***.***.50 255.255.255.0
ip address inside 192.168.25.1 255.255.255.0

!--- Static translation defined to translate Private_LAN2
!--- from 192.168.25.0/24 to 192.168.58.0/24.

static (outside,inside) 192.168.58.0 192.168.25.0 netmask 255.255.255.0 0 0

!--- Static translation defined to translate Private_LAN1
!--- from 192.168.25.0/24 to 10.**7.*5.0/24.
!--- Note that this translation is used for both
!--- VPN and Internet traffic from Private_LAN1.
!--- A routable global IP address range, or an extra NAT
!--- at the ISP router (in front of PIX), is
!--- required if Private_LAN1 also needs internal access.

static (inside,outside) 10.**7.*5.0 192.168.25.0 netmask 255.255.255.0 0 0
route outside 0.0.0.0 0.0.0.0 129.***.***.78 1
sysopt connection permit-ipsec

!--- Defines IPSec encryption and authentication algorithms.

crypto ipsec transform-set myset esp-3des esp-md5-hmac

!--- Defines crypto map.

crypto map vpn 10 ipsec-isakmp
crypto map vpn 10 match address 101
crypto map vpn 10 set peer 129.***.***.78
crypto map vpn 10 set transform-set myset

!--- Apply crypto map on the outside interface.

crypto map vpn interface outside
isakmp enable outside

!--- Defines pre-shared secret (cisco123) used for IKE authentication.

isakmp key ******* address 129.***.***.78 netmask 255.255.255.255
isakmp identity address

!--- Defines ISAKMP policy.

isakmp policy 1 authentication pre-share
isakmp policy 1 encryption 3des
isakmp policy 1 hash md5
isakmp policy 1 group 1
isakmp policy 1 lifetime 86400

-------------------------------------------------

To the main config

PIX Version 6.3(3)
interface ethernet0 100full
interface ethernet1 100full
interface ethernet2 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 failover security25

hostname PIX
domain-name abc.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip 5061
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69


access-list inside_outbound_nat0_acl permit ip 192.168.25.0 255.255.255.0 192.168.200.0 255.255.255.0

access-list outside_cryptomap_dyn_20 permit ip any 192.168.200.0 255.255.255.0
access-list OUT->IN deny icmp any any echo
access-list OUT->IN deny icmp any any echo-reply

pager lines 24
mtu outside 1500
mtu inside 1500
mtu failover 1500
ip address outside 82.***.***.50 255.255.255.240
ip address inside 192.168.25.1 255.255.255.0
ip address failover 192.168.26.11 255.255.255.0
ip verify reverse-path interface outside
ip audit info action alarm
ip audit attack action alarm drop
ip local pool vpnpool1 192.168.200.1-192.168.200.254
failover
failover timeout 0:00:00
failover poll 15
failover replication http
failover ip address outside 82.***.***.61
failover ip address inside 192.168.25.3
failover ip address failover 192.168.26.12
failover link failover
pdm location 192.168.25.10 255.255.255.255 outside
pdm location 192.168.25.11 255.255.255.255 outside
pdm location 192.168.200.0 255.255.255.0 outside
pdm location 192.168.25.10 255.255.255.255 inside
pdm location 192.168.25.11 255.255.255.255 inside
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 192.168.25.0 255.255.255.0 0 0
static (inside,outside) 82.***.***.52 192.168.25.11 netmask 255.255.255.255 0 0
static (inside,outside) 82.***.***.51 192.168.25.10 netmask 255.255.255.255 0 0
access-group OUT->IN in interface outside
rip inside default version 1
route outside 0.0.0.0 0.0.0.0 82.***.***.49 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server RADIUS (inside) host 192.168.25.11 sharedsecret timeout 10
aaa-server LOCAL protocol local
http server enable
http 192.168.25.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20

crypto map outside_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client authentication RADIUS
crypto map outside_map interface outside
isakmp enable outside
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption aes-256
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400

vpngroup branch_remote address-pool vpnpool1
vpngroup branch_remote dns-server 192.168.25.10
vpngroup branch_remote wins-server 192.168.25.10

vpngroup branch_remote idle-time 1800
vpngroup branch_remote password ********
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 3
ssh timeout 5
management-access inside
console timeout 0

 I loose the dialin VPN or worse, what am i missing, I am working remotely so if i loose the link the pix need a hard reset loosing all changes

The original plan seemed simple allow one PC to connect to a monitoring PC in another (very secure) LAN

Help
0
 
LVL 19

Expert Comment

by:nodisco
ID: 17017422
hi Smartfix

Unfortunately I am about to travel and won't be able to work more on this.  I have requested assistance on your behalf.



0
 

Author Comment

by:SmartFix
ID: 17017433
Many thanks nodisco
0
 
LVL 79

Assisted Solution

by:lrmoore
lrmoore earned 150 total points
ID: 17017551
>crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
>isakmp policy 20 encryption aes-256

Your policy does not match your transform-set
Suggest:
isakmp policy 20 encryption 3des



 
0
 

Author Comment

by:SmartFix
ID: 17019520
Think that one is for the dial-in clients
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17019580
The policy does not match this one either:
>crypto map outside_map 20 set transform-set ESP-3DES-MD5

isakmp policy 20 encryption aes-256
isakmp policy 20 hash sha

Should match the transform set:
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

Suggested Solutions

Sometimes, you want your microsoft VPN to route all the traffic to the remote network. Usually your employer network. This makes it possible to access all the nodes inside this remote LAN, even if they have no "public DNS" entries. To do so, you wo…
Juniper VPN devices are a popular alternative to using Cisco products. Last year I needed to set up an international site-to-site VPN over the Internet, but the client had high security requirements -- FIPS 140. What and Why of FIPS 140 Federa…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now