Solved

How to circumvent message about certificate revocation

Posted on 2006-06-26
14
1,194 Views
Last Modified: 2012-05-05
I'm running Internet Explorer Version 6.0.2800.1106.

My operating system is Windows 98 Second Edition.

Prior to installing Windows updates 911562 and 912812, I had no problem logging in to
a Web site that I frequent. Since I installed those updates, I have't been
able to log in via Internet Explorer (IE). [I am, however, able to log in via Firefox.]

When I attempt to log in to that site via IE, I get a message
to the effect that the security certificate for that site has been revoked,
and that the site should not be trusted.

In seeking help from the technical-support folks who run that site, I have
been assured that their certificate has NOT been revoked, and that THEY are
capable of signing in to the page that I'm unable to sign into, so they've
concluded that there's a problem with "my system."

I've tried changing all kind of settings in IE (including
deletion of cookies and temporary Internet files), and I've declared that Web
site as "trusted."

Nothing works (the problem occurs regardless of whether the "Check for publisher's certificate revocation" box is checked in IE: Tools | Internet Options | Advanced tab), so I'm wondering if the problem could be being caused by some effect of one
of the Windows updates referenced above.

I'd be willing to try deleting the certificate for that site, which is listed in Certificate Manager dialog box (Tools | Internet Options | Content | Certificates button | Other People tab), but I'd like to know how to undo that deletion in case the deletion doesn't solve the problem.

Can anyone provide help that would enable me to use IE to log in to that site (and/or to undo the deletion of that certificate if I decide to get brave and take that step)?
0
Comment
Question by:gamadvice
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 7
14 Comments
 

Author Comment

by:gamadvice
ID: 16985612
Sorry, I made a typo in identifyin one of the Windows updates; I should have typed 911562 rather than 911561.
0
 
LVL 97

Expert Comment

by:war1
ID: 16985666
Greetings, gamadvice !

>>Nothing works (the problem occurs regardless of whether the "Check for publisher's certificate revocation" box is checked in IE: Tools | Internet Options | Advanced tab),

Uncheck "Check for publisher's certificate revocation"
Uncheck "Check for server certificate revocation"

>>I'm wondering if the problem could be being caused by some effect of one of the Windows updates referenced above.

Go to Add/Remove Programs in Control Panel and uninstall the two updates one at a time.  Then test

Best wishes!
0
 

Author Comment

by:gamadvice
ID: 16985717
The problem occurs regardless of whether the "Check for publisher's certificate revocation" box is checked, AND regardless of whether the "Check for server certificate revocation" is checked.

Neither of those two updates is listed in Add/Remove Programs (Control Panel).

Originally, update 912812 WAS listed (but NOT 911562).

I tried uninstalling 912812, but that made no difference, so I reinstalled it.
0
Ready to get started with anonymous questions?

It's easy! Check out this step-by-step guide for asking an anonymous question on Experts Exchange.

 
LVL 97

Accepted Solution

by:
war1 earned 500 total points
ID: 16985769
gamadvice,

Unchecking server certificate requires a reboot of computer to set the setting.

1. If no joy, disable third party extensions. With IE open, go to Tools > Options > Advanced. Uncheck "Third party extensions". Click Ok. Reboot computer.

2. Clear your cache.  Go to Tools > Internet Optins > General tab.  Under Temporary Internet Files, click "Delete Files" button. Click OK.

3. Reset IE settings.  Go to Tools > Internet Options > Programs.  Click on "Reset Web Settings" button. Go to Advanced tab and click "Restore Defaults" button. Go to Security tab and move the bar to Medium or Default. Click OK. Close all browsers. Reboot the computer.

4. Check if a program running in the background is interfering with Internet Explorer. Temporarily disable all Norton programs, including anti-virus, anti-spyware, ad-blocker, win doctor, and recycle bin protect. Disable any firewall or ad-blocker.

5. Perform a repair of Internet Explorer. From Control Panel select Add/Remove Programs. Scroll down to Microsoft Internet Explorer and highlight it. Click on the Add/Remove button. When the IE Tools menu comes up, select Repair. Click OK.

6. If repairing does not work, uninstall and reinstall IE. At the same IE Tools menu, select "Restore the previous Windows configuration". Then reinstall Internet Explore.

You can also access the IE Toolbar by clicking Start > Run and type

rundll32 setupwbv.dll,IE6Maintenance "C:\Program Files\Internet Explorer\Setup\SETUP.EXE" /g "C:\WINDOWS\IE Uninstall Log.Txt"
0
 

Author Comment

by:gamadvice
ID: 16992329
Clearing the "Check for server certificate revocation" box (and then rebooting) did not work. I had tried that (and rebooted, per the instructions in IE) before approaching EE for help. Regardless of how I had set that check box ("checked" or "cleared"), I got the message about certificate revocation (and the accompanying warning to the effect that the Web site in question was not to be trusted).

Then I took steps 1 through 6, as you suggested (step 5, trying a "repair" of IE, did not work, as I had found on my own before approaching EE for help).

After step 6 (reinstalling IE), I rebooted. Then I installed the Windows updates that were available to me (and again rebooted).

After all that was done, I was able to log in to the Web site in question (without getting the message about the certificate revocation, and without getting the accompanying message to the effect that the site in question was not to be trusted).

Then I tried CHECKING the "check for server certificate revocation" box (and rebooted). On attempting to log in to the site in question, I DID get the message about the certificate revocation (and accompanying warning), so I was unable to log in.

After again clearing that check box (and rebooting), I was  able to log in to the site (without the dreaded message about the certificate revocation, and without the warning to the effect that the site is not to be trusted).

-----------------------------------------------------------------------------

In a sense, the problem has been solved, in that all I need to do is leave the "check for server certificate revocation" check box CLEARED. However, for security reasons, I feel uneasy about doing that.

One thing I'm not 100% sure of is whether the certificate in question absolutely HAS to be listed in IE in order for me to log in to that site. (It's currently listed at Tools | Internet Options | Content tab | Certificate Manager | Other People tab.)

Is there any way that I can delete that certificate, and then (if I find that I absolutely DO need it) reinstate the certificate (including all the data and settings associated with it)?
0
 
LVL 97

Expert Comment

by:war1
ID: 16994264
Glad reinstalling IE fix the problem.  Unchecking sever revocation is not a big security issue.  Many users have this option unchecked to avoid the warning.

>> Is there any way that I can delete that certificate, and then (if I find that I absolutely DO need it) reinstate the certificate (including all the data and settings associated with it)?

There is nothing natively to IE that can save the certificate, so that you can use it again.  You need to find the original source of the certificate and get a copy.
0
 

Author Comment

by:gamadvice
ID: 17001982
Before I approached EE for help with this problem, I asked the people who RUN that Web site whether certain browser settings of mine were correct AND what would happen if I deleted the certificate in question.

Their indirect reply was as follows:

------------------------------------------------------

The settings you have provided look to be fine. Try clearing SSL state in your browser to clear the cached information and then try logging in again. In IE click Tools -> Internet Options -> Content -> Clear SSL State. This will erase any cached SSL information from your browser.

----------------------------------------------------


There is NO SUCH CHOICE as clicking "Clear SSL State" (i.e., there is no toolbar button, radio button, check box, or whatever that's labeled with the phrase "Clear SSL State"). When I replied and informed them of the lack of such a choice, I asked if there's some action I could take that would be the EQUIVALENT of "clearing the SSL state", but I got no reply from them.

My question to YOU is: Do you think that choosing "Clear SSL state" would have (perhaps among other things) caused that certificate to be deleted?
0
 
LVL 97

Expert Comment

by:war1
ID: 17002533
>> Do you think that choosing "Clear SSL state" would have (perhaps among other things) caused that certificate to be deleted?

No, clear the SSL state clears only the SSL cache, not the certificate.

IE, Tools, Internet Options, Content tab. Under Certificates, click Clear SSL State.
0
 

Author Comment

by:gamadvice
ID: 17002645
There is no "Clear SSL State" button.

Under Certificates (Tools, Internet Options, Content tab), there are only two buttons: "Certificates" and "Publishers".

If I click the "Certificates" button, I get the Certificate Manager dialog box. If I click the "Publishers" button, I get the Authenticode(tm) Security Technology dialog box. Neither dialog box has a "Clear SSL State" button.
0
 
LVL 97

Expert Comment

by:war1
ID: 17002737
Then your Internet Explorer version does not have a Clear SSL State option.
0
 

Author Comment

by:gamadvice
ID: 17002786
Do you have any idea as to why the certificate for that Web site (which is a BUSINESS site) would be listed on the Other People tab of the Certificate Manager dialog box? Does that make any sense to you?
0
 
LVL 97

Expert Comment

by:war1
ID: 17002827
gamadvice,

The decision where the certificate is stored is automatically set by Internet Explorer.  I am not familiar with IE criterion for storing certificate.
0
 
LVL 97

Expert Comment

by:war1
ID: 17018796
gamadvice,

We have not heard from you in awhile. Did any comment help you solve your problem? Do you have any more question? If an Expert helped you, please accept his/her answer above with an excellent or good grade.

Thanks, war1
0
 

Author Comment

by:gamadvice
ID: 17020324
Thanks mucho, war1. The reason why I didn't immediately respond to the most recent message you posted on 6/28 is that I had posted another query to the folks who run that Web site (about what would happen if I did indeed delete the certificate, and how I could go about reinstating it if I needed it).

I was hoping they would respond soon. Thus far, however, I've received no word from them (such delays are not uncommon), so I've decided to go ahead and accept the comment in which you laid out the series of steps to take to get the login to that Web site working again. You've been a much bigger help than anyone else I've approached about the problem at hand.
0

Featured Post

[Webinar] How Hackers Steal Your Credentials

Do You Know How Hackers Steal Your Credentials? Join us and Skyport Systems to learn how hackers steal your credentials and why Active Directory must be secure to stop them. Thursday, July 13, 2017 10:00 A.M. PDT

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I spend far too much time on the web keeping up with the news: politics, the environment, computer stuff, the Experts Exchange. It's never-ending. But many of the most informative web pages are overwhelmed with noise: scrolling banners, flashing tex…
It's here again; Microsoft is launching a new version of Internet Explorer: Internet Explorer 9, with noticeable changes on its interface, functions and new tools. As they say on its promotional video: "It's time to play, on a more beautiful web", f…
This Micro Tutorial will demonstrate how to add subdomains to your content reports. This can be very importing in having a site with multiple subdomains.
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…

628 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question