Solved

Gentoo Linux Freezing

Posted on 2006-06-26
10
846 Views
Last Modified: 2008-01-09
I had gentoo 2005.0 on an old duron 1000Mhz and it worked fine. It was connected to my local network through a Wireless Netgear WG311v2 using the acx driver.
I needed to reinstall the system from scratch but the new system behaves strangely. It seems that it hungs sometimes when I am using emerge. The way it hungs is totally random but it eventually occurs after 10-15 mins. If I am not working online it might go on for hours. I tried the newer version of Gentoo with no luck. I tried using ndiswrapper instead of acx. Ndis with WinXP inf file produced random kernel panics & with win2000 inf file it behaved exactly like acx (random freezes).

By freezing I mean not being able to do anything on the system. I tried to use top and wait for a freeze. I noticed high load average, but not a process occuping lot % cpu. I also noticed that while frozen there were processes that were swaping in my top list. Finally I noticed that the swap was not used at all.

My guess is that I am doing something different since the original install (though I cant remember what), or the my hardware has problems. Possible memory problem (currently doing a memtest86) or cpu failures. It is definantly not a temperature issue.

Any ideas?
0
Comment
Question by:Nellios
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 3
10 Comments
 
LVL 22

Expert Comment

by:pjedmond
ID: 16987929
IS the whole system freezing?

Alt-F1 to F7     Do you get access to a console?

When it freezes, can you connect to a sshd, or any other daemon.

Overall, I suspect from your comments that you are looking in the correct area, and I expect the problem will prove to be hardware related.

(   (()
(`-' _\
 ''  ''
0
 
LVL 10

Author Comment

by:Nellios
ID: 16988194
Well, I get a login prompt but as soon as I give username I nver get prompt for passwrd.
If I login to Alt-F2 before the freeze I can switch back to it after the freze and type a command which takes forever to execute. I tired to have top running on ALT-F2 and the results were described aobve (I could see processes swaping but I could do noting else).
0
 
LVL 10

Author Comment

by:Nellios
ID: 16988244
The results of memtest86 were 2 Errors. It seems that I have 2 failing adresses ( and I am currently at 60% of the test).

I don't know why but it still seems to me that a few memory adresses are not enough to cause a problem appearing in such high frequency. And why does it always happen when I am using my wireless. Moreover why didnt it happen on the original installation? Is there a rational explanation?


1 more clue:
----------------
Yes I have disabled SMP which is a recuriment for using ndis & acx.
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
LVL 88

Accepted Solution

by:
rindi earned 500 total points
ID: 16990493
If memtest shows errors, there is a RAM problem. You can try only one module in different slots to find the bad module / slot.
0
 
LVL 10

Author Comment

by:Nellios
ID: 16990775
Sounds interesting. I'll give a little search on how this can be done. Of course any guidelines would be appriciated.
0
 
LVL 10

Author Comment

by:Nellios
ID: 16990834
Errrm, maybe I got a bit confused. What do you actually mean module / slot ?
a) Memory slot on my motherboard?
b) The sdram module which I attach on my motherboard?
c) Memory slot as an area of my memory which I could isolate?

I guess that you prolly mean a/b :-(
0
 
LVL 88

Expert Comment

by:rindi
ID: 16990889
The memory modules usually can be inserted into different slots (or sockets) on the mainboard. These losts can make bad contact with the RAM. Also usually there are more than one ram module in the system ,so you can try each of them alone and in the different slots on the mainboard.
0
 
LVL 10

Author Comment

by:Nellios
ID: 16991319
I have only one memory module. I will try adding it to different slots and see if it makes any difference. I think I will also try buying a new one.
0
 
LVL 10

Author Comment

by:Nellios
ID: 17016588
Changing the slot of the memory module produced no errors. However I had one more freeze after that. Its been working now for a couple of days.

For future readers: I am convienced that there was a combination of reasons, which I will name here:
a) Crappy Hardware
b) Crappy Kernel Configuration
c) Both acx & ndwis still have unsolved issues. Combined with the issues above can cause further problems.
Finally if u have simillar problems ... make sure your memory is ok & then configure your kernel from scratch. Keep in mind not to change anything in the configuration unless you pretty sure what u are doing.

I will give the points to rindi!
0
 
LVL 88

Expert Comment

by:rindi
ID: 17016745
thanks.
0

Featured Post

Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

In my business, I use the LTS (Long Term Support) versions of Linux. My workstations do real work, and so I rarely have the patience to deal with silly problems caused by an upgraded kernel that had experimental software on it to begin with from a r…
Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will give…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question