• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 6750
  • Last Modified:

Setting JMS Queue size for WebSphere Embedded JMS Provider (version 5.1) [exception: com.ibm.mq.MQException: MQJE001: Completion Code 2, Reason 2053]

we are thinking of using WebSphere's JMS embedded server for asynchronous processing but during performance testing it, we ran into the following exception being thrown which be believe is associated with the Message Queue being full.

com.ibm.mq.MQException: MQJE001: Completion Code 2, Reason 2053

How can we set the queue size using the embedded JMS server??

Thanks in advance
  • 3
1 Solution
We are using WSND V6 and Default Messaging ( JMS Provider ).

From WebSphere (WAS) console,

Resources > JMS Providers > Default messaging > JMS Queue > Your JMS queue > Buses > Your JMS bus > Messaging engines > your message engine > 

High Message Threadhold => The Maximum total number of messages that the messaging engine can place on its message points.

Andy K.
pbarry30Author Commented:
Thanks Andy

any ideas about 5.1? Under Queue mgmt there are no such options!!

I don't have running WAS 5.1 environment. Let me check some history information
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now