unable to mount CD drive

Posted on 2006-06-26
Medium Priority
Last Modified: 2013-12-15
This is an unsual puzzle for me. Using  Enterprise v3.5 I'm unable to automount a CD.  Tried the following and it worked at first but upon reboot using the same commands as before (listed below) now return the error, mount: you must specify the file type system. CD Properties dialog has 'Mount when CD inserted' selected. Thanks in advance for any suggestions?

ls -s /dev/scd0 cdrom
mount /dev/cdrom /mnt/cdrom

Here is the fstab information.

/dev/md0                /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /proc                   proc    defaults        0 0
none                    /dev/shm                tmpfs   defaults        0 0
/dev/sda5               swap                    swap    defaults        0 0
/dev/fd0                /mnt/floppy             auto    noauto,owner,kudzu 0 0
/dev/cdrom              /mnt/cdrom              udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/cdrom1             /mnt/cdrom1             udf,iso9660 noauto,owner,kudzu,ro 0 0
Question by:rgordon2
  • 2
LVL 24

Expert Comment

ID: 16988927
Can you cut and paste your /etc/auto.misc file here?
LVL 43

Accepted Solution

ravenpl earned 1500 total points
ID: 16990272
Why will not You try
mount /dev/scd0 /mnt/cdrom # what's happens now?

Do You execute the "ls -s /dev/scd0 cdrom" in /dev directory? Also, it should real like: ls -sf /dev/scd0 /dev/cdrom

Author Comment

ID: 16994270
Thanks folks. I'm working remotely with a site in China from North America so it'll take a day or so to get back to you.

Author Comment

ID: 16995042
Here is the auto.misc information:

# $Id: auto.misc,v 1.2 2003/09/29 08:22:35 raven Exp $
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# Details may be found in the autofs(5) manpage
cd              -fstype=iso9660,ro,nosuid,nodev :/dev/cdrom
# the following entries are samples to pique your imagination
#linux          -ro,soft,intr           ftp.example.org:/pub/linux
#boot           -fstype=ext2            :/dev/hda1
#floppy         -fstype=auto            :/dev/fd0
#floppy         -fstype=ext2            :/dev/fd0
#e2floppy       -fstype=ext2            :/dev/fd0
#jaz            -fstype=ext2            :/dev/sdc1
#removable      -fstype=ext2            :/dev/hdd

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

In the first part of this tutorial we will cover the prerequisites for installing SQL Server vNext on Linux.
Can you run Linux on a Windows system?  Yep.  Here's how.
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

624 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question