[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 308
  • Last Modified:

Cant browse network after VPN connection

Hi

After a long day setting up RRas on 2003 server and finally logging in from home I am unable to browse for any shares on the server. When the tunnel is active I can ping ok. I have looked at a few posts and have set up Wins but this has not solved the problem.

Client PC is Windows XP Pro SP2

Any help welcome

Regards

TD
0
daly29
Asked:
daly29
1 Solution
 
aucklandnzCommented:
can you RDC to your server ?
0
 
Sam PanwarSr. Server AdministratorCommented:
Hi,

When we configure vpn connection then window default firewall on or enable so you can't browse network so disable the window default firewall and check it.
0
 
Rob WilliamsCommented:
First make sure the remote and local subnets are different.  If the same you will not be able to connect to resources. For example if the server network is 192.168.1.0 then the remote network needs to be 192.168.2.0 or similar.
Then as suggested by Abs_jaipur , make sure the Windows, or any other software firewall is at least disabled for testing. Also if using Symantec anti-virus disable "Internet Worm Protection".
Next, NetBIOS names  (computer names) are not broadcast over most VPN's.
Try to resolve by using option 1 below. If successful you can try the other options for name resolution.
1) Use the IP address (of the computer you are connecting to) when connecting to devices such as;   \\123.123.123.123\ShareName   or map a drive at a  command prompt using  
 Net  Use  U:  \\123.123.123.123\ShareName
2) An option is to use the LMHosts file which creates a table of IP's and computer names. LMHosts is located in the Windows directory under c:\Windows (or WINNT)\System32\Drivers\Etc\LMHosts.sam , instructions are included within the file. Any line starting with # is just a comment and is ignored. Open the file with Notepad and add entries for your computers as below;
192.168.0.101      CompName       #PRE
Hit enter when each line is complete (important), then save the file without a file extension. To be sure there is no extension ,when saving enclose in quotations like "LMHosts". Now when you try to connect to a computer name it should find it as it will search the LMHosts file for the record before connecting.
More details regarding LMHosts file:
http://www.microsoft.com/resources/documentation/Windows/2000/server/reskit/en-us/Default.asp?url=/resources/documentation/windows/2000/server/reskit/en-us/cnet/cnfd_lmh_QXQQ.asp
The drawback of the LMHosts file is you have to maintain a static list of computernames and IP addresses. Also if the remote end uses DHCP assigned IP's it is not a feasible option. Thus in order to be able to use computer names dynamically try to enable with some of the following options:
3) if you have a WINS server add that to the network cards configuration
4) also under the WINS configuration on the network adapter make sure NetBIOS over TCP/IP is selected
5) try adding the remote DNS server to your local DNS servers in your network card's TCP/IP configuration
6) verify your router does not have a "block NetBIOS broadcast" option enabled
7) test if you can connect with the full computer and domain name as  \\ComputerName.domain.local  If so, add the suffix DomainName.local to the DNS configuration of the virtual private adapter/connection [ right click virtual adapter | properties | TCP/IP properties | Advanced | DNS | "Append these DNS suffixes (in order)" | Add ]

0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
Redwulf__53Commented:
Quote: "Hi,

When we configure vpn connection then window default firewall on or enable so you can't browse network so disable the window default firewall and check it."

J-E-ZZZZ Abs_jaipur, how the $&^& can you advise anyone to disable their firewall????????? Can you sleep at night?
0
 
daly29Author Commented:
Hi Rob

Thanks for getting back to me Good to have you back on board.

Ok I have changed my subnet at home and followed your instructions.

When I open my computer and use \\192.168.0.1\sharename i can find and browse my share, same applies when I use FQDN\share first time it asks for username password but seems to remember it after that. No problems there.

If i use net use with the ip address\sharename i get the network cant be found error, I can map in my computer though by entering the network path so i think that is it
0
 
daly29Author Commented:
Hi Rob

well deserved points to you thanks again you are a star
0
 
Rob WilliamsCommented:
Thanks daly29.
As for net use, try
\\192.168.123.123\sharesame  z:  password  /user:domain.local\username
just leave "user" as is it is not a variable.
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now