• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 799
  • Last Modified:

Internet Connection Sharing, client can ping both nic's in host but not get pages..


Main computer is windows XP Pro.

Nic to the inter net is an CISCO 350 Wireless adapter.  ISP provides an WIFI 11MB connection to this pc.

2nd nic in this computer is an PCI 3com 10/100 nic.

On the Cisco card we have enabled ICS.

On the 3com,  the ONLY thing showing is an static ip of 192.168.0.1 and subnet mask of 255.0.0.0

On the clinet (also windows xp pro) we told it to obtain an IP automaticly but it is not obtaining the ip.
I have tried to staticly set the ip to
192.168.0.2
gateway 192.168.0.1
subnet 255.0.0.0

DNS is server IP's provided by ISP.

The client can ping both the WIFI and the 3com NICS on the main computer.  But we cannot get any pages to come up.  nor can we ping past...

any ideas?
0
mrchaos101
Asked:
mrchaos101
  • 8
  • 8
  • 6
  • +3
5 Solutions
 
Rob WilliamsCommented:
Verify the Windows firewall is at least temporarily disabled on the "main computer" for testing.
Ty connecting from the secondary computer to an IP rather than name such as:
http://64.233.187.99/        (Google)
If you can connect to this please advise. It is a DNS issue which we can then try to resolve.
0
 
mrchaos101Author Commented:
we tried to ping 64.233.187.99 but no go.

I cannot ping the ISP gateway either.  Seems the main computer is not "sharing".  

Ideas?
0
 
Rob WilliamsCommented:
64.233.187.99 will not respond to a ping, and good chance your ISP's gateway may not either. That is a security feature, however can you click on the  http://64.233.187.99/   link and connect?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
abarneslouorthoCommented:
yeah, you're not on the same subnet.... the default subnet mask for a class c network is 255.255.255.0
0
 
abarneslouorthoCommented:
actually, the thing i would also try is to setup your gateway as the ip of your cisco card... since the two nics are on the same network already (excuse me for not seeing that your main computer subet was also 255.0.0.0) its trying to make the 3com get pages... but since you have ICS setup on the cisco card, it can tell it to do that.... i think.. can't hurt to try!
0
 
mrchaos101Author Commented:
Once I put the cisco ip as gateway on the 3com I loose net connection on the main computer.  I am guessing that the pc is starts trying to use the 3com to get on the net.

Every thing I have read on net on ICS says not put anything in the gateway.

Recap:

Main pc can get on the net. Main PC  CAN ping ISP gateway.
Client PC can ping both nic cards on the MAIN PC but no further out.
Client PC will not obtain DHCP information, all IP info must be set up static.
Main PC can ping the clinet PC.
0
 
Rob WilliamsCommented:
Cisco NIC
IP  assigned by ISP
Subnet mask   assigned by ISP
Gateway   assigned by ISP

3COM NIC (do not manually configure)
IP 192.168.0.1  assigned by ICS
Subnet mask 255.0.0.0 assigned by ICS
Gateway  blank    assigned by ICS

2nd computer (may be assigned manually or automatically through DHCP)
IP  192.168.0.2 default - can be 192.168.0.2 to 192.168.0.254
Subnet mask  255.0.0.0 must be the same as computer #1
Gateway  must be 192.168.0.1

ICS, when configured, automatically sets up NAT (Network Address Translation) and a DHCP like server. The fact that DHCP is not working, and NAT does not appear to work, since you cannot ping beyond computer #1, seems to indicate ICS is not working properly. Perhaps try re-running the configuration wizard.
Is there a 3rd network adapter in computer #1? If so disable it while configuring ICS.
0
 
mrchaos101Author Commented:

There is NO third adaptor.

We have uninstalled both NIC and placed them in diff PCI slots even.  Then allowed them to be set back up again.
I have re configured ICS again with the wizard and it comes up the same.
0
 
abarneslouorthoCommented:
umm... do you have a direct cable going from one computer to another? if you do, it is a crossover cable right?
0
 
Rob WilliamsCommented:
I am stumped.
There is an ICS troubleshooter built-in to Windows XP which you can run by clicking on the following link:
hcp://help/tshoot/tsics.htm

And a couple of good sites for troubleshooting:
http://support.microsoft.com/?scid=kb;EN-US;Q238135
http://www.practicallynetworked.com/sharing/ics/ics_troubleshoot.htm

See if any of those bring anything to light.
0
 
mrchaos101Author Commented:

I am runing out of ideas as well. =(

Have swaped cards around.  Reinstalled ICS.... DHCP is not working for sure.  Only way to get any thing on clinet is to set up IP static.  Then can ping both nic's on the host.
0
 
abarneslouorthoCommented:
once again, if you are connecting computers to eachother directly you must have a crossover network cable... you never stated whether you were connecting through a hub or computer to computer
0
 
Psyco_666Commented:
Are there any proxy settings configured in IE under the client?
Are there any security products installed? try disabling them?

Try running the command 'TRACERT 64.233.187.99' and post the output

also can you post the output of 'ROUTE PRINT' and 'IPCONFIG /ALL' on the main PC
0
 
mrchaos101Author Commented:

hmm....

I think it is a direct cable that is crossover.....
I will have to check on that...

if it is a straight cable.... then they should not ping though right?  I mean if the the recevie lines are touching recvie lines on the hoste then there should be no reply to the ping on the nic cards?
0
 
abarneslouorthoCommented:
actually, i think you can still ping but thats it, which is why i was so pertinent in asking
0
 
abarneslouorthoCommented:
oh yes, you do have the computers on the same workgroup correct?
0
 
Psyco_666Commented:
abarneslouortho, he can ping the main PC from the client but not the internet. I assume the connectionbetween client and main is all ok.
0
 
Rob WilliamsCommented:
If it is a direct cable (i.e. without a hub/switch) you normally need a crossover cable, however, you are right, if you can ping you have a connection, and appropriate cabling. Most switches today are auto-detect for cross-over, and some new network adapters as well. So that is a possibility.
Does windows show the adapter as "connected" that will verify.
0
 
Rob WilliamsCommented:
Sorry Psyco_666 , I didn't refresh.
0
 
mrchaos101Author Commented:
yes all the adaptors say connected.

I can ping the clint from the host and I can ping the host from the client.
I have to check on the work group name still.... cant do that yet.
0
 
Kumar_Jayant123Commented:
Hi,

What is the IP address of the network card connected to the Cisco device?

From the XP computer where you have configured the ICS are you able to access the Internet?

0
 
Steve KnightIT ConsultancyCommented:
Just an idea but what IP gets assigned by the ISP as you say it is a wireless ISP solution.  Could it be your 'outside' address is already NAtted and is another 192.168.0.x range and therefore giving routing issues?  ipconfig on the server should tell you of course.  

ROUTE PRINT on the  XP machine should show one default gateay (0.0.0.0) to the wireless port etc.  Can I suggest you post the results of ipconfig /all on the XP machine and ROUTE PRINT on the XP machine.

thanks
0
 
mrchaos101Author Commented:
We ended up reformatting and reinstallin the OS.

Have no clue what or why it would not work.. but it is working now =(
0
 
Rob WilliamsCommented:
Thanks for the update mrchaos101. Very odd indeed.
Glad to hear it is at least working now.
--Rob
0
 
mrchaos101Author Commented:

Going to SPLIT the points to the 5 guys that tried to help.  Figure they should have points for trying to help.

Thanks again all.
0
 
Rob WilliamsCommented:
Thanks mrchaos101. Appreciate that.
--Rob
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

WEBINAR: 10 Easy Ways to Lose a Password

Join us on June 27th at 8 am PDT to learn about the methods that hackers use to lift real, working credentials from even the most security-savvy employees. We'll cover the importance of multi-factor authentication and how these solutions can better protect your business!

  • 8
  • 8
  • 6
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now