• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 709
  • Last Modified:

Military Time .adm file for group policy. Is there anyway to apply it to machine rather than user?

I found the following adm file on ee;
CLASS USER
CATEGORY "Time settings"
  POLICY "Use military time"
  KEYNAME "Control Panel\International"
  ACTIONLISTON
    VALUENAME "iTime"
    VALUE "1"
    VALUENAME "iTLZero"
    VALUE "1"
    VALUENAME "s1159"
    VALUE ""
    VALUENAME "s2359"
    VALUE ""
    VALUENAME "sTime"
    VALUE ":"
    VALUENAME "sTimeFormat"
    VALUE "HH:mm:ss"
    VALUENAME "iTimePrefix"
    VALUE "0"
  END ACTIONLISTON
  ACTIONLISTOFF
    VALUENAME "iTime"
    VALUE "0"
    VALUENAME "iTLZero"
    VALUE "0"
    VALUENAME "s1159"
    VALUE "am"
    VALUENAME "s2359"
    VALUE "pm"
    VALUENAME "sTime"
    VALUE ":"
    VALUENAME "sTimeFormat"
    VALUE "h:mm"
    VALUENAME "iTimePrefix"
    VALUE "0"
  END ACTIONLISTOFF
  END POLICY
END CATEGORY

Which works well for users but I need to apply to computers. I tried changing the "CLASS USER" to CLASS MACHINE but I get a Event ID 1096 on the client workstation "windows cannot access the registry policy file, \\domain\sysvol\domain\policies\{GUID}\Machine\registry.pol (the parameter is incorrect.)"

Thanks in advance
0
sweetaz
Asked:
sweetaz
1 Solution
 
Michael PfisterCommented:
The time settings are user specific, therefore they cannot be set on a machine level. Changing the CLASS won't work.
Why can't you use the policy applied to all users? Probably you don't want all computers set up in that way ...

Depending on what you have and want to achive you can either 1) import these default settings on any number of computers into the default registry hive or 2) put a registry hack into the login script.

1) won't work if you have roaming users
2) obviousliy can't work if you do not have a logon script

How to do it:
1) Make sure hidden files and directories are visible in explorer. Start regedit (Win XP) or regedt32 (Win 2000). Click on HKEY_LOCAL_MACHINE, then File -> load hive. Navigate to \Documents and Settings\Default User and click NTUSER.DAT. Give the hive a name like TEMP. Navigate to
HKEY_LOCAL_MACHINE\TEMP\Control Panel\International and make your settings. IMPORTANT! When finished, klick on HKEY_LOCAL_MACHINE\TEMP and select Unload hive from the File menu.

2) Add the following lines to your logon script
Create a reg file with your settings and export it to miltime.reg like this one:
------- snip ------------
REGEDIT4

[HKEY_CURRENT_USER\Control Panel\International]
"iTime"="1"
"iTLZero"="1"
"s1159"=""
"s2359"=""
"sTime"=":"
"sTimeFormat"="HH:mm:ss"
"iTimePrefix"="0"
------- snip ------------
Put the reg file into your NETLOGON directory.

Add this line to your logon script

If %COMPUTERNAME% == <computer name goes here> regedit /s %0\..\miltime.reg


Hope it helps,

Michael
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now