Bios update needed for a HP Pavilion 7915 with a motherboard model number FW37E

I am in the process of sorting someones HP Pavilion 7915 pc which is running Windows XP Home which is booting slowly and shutting down slowly. I have upgraded it to service pack 2 with very little difference and upon looging in the event log discovered this recuring problem.

AMLI: ACPI BIOS is attempting to write to an illegal IO port address (0x70), which lies in the 0x70 - 0x71 protected address range. This could lead to system instability. Please contact your system vendor for technical assistance.

I have clicked the link to go to microsoft support which tells me i need to obtain bios updates. I have looked on HP's site but been unable to find a bios update for this machine.

Can anyone help?
Who is Participating?
A repair install wont work. You need to do a fresh install and then try. Unless its an old pc which doesnt support ACPI all shud be well. The amount of time spent reloading software and stuff will be much less and worthwhile than trying to get this fixed with repair installs. If th Bios is not ACPI compliant then u need to do what Norwegiancoder above said about holding the F7 key when asked to install RAID drivers right in the beginning of the install process.

Updating the BIOS is reccomended cause some of the BIOS did not have proper ACPI management causing similar problems and then subsquently BIOS upgrades reduced or eliminated the problems. How old is the system?? You might have a problem if its more than 5-6 years old.

This issue is not related to the BIOS. Updating the BIOS will not help you by much, with the exception of possibly a little better experience and support for more features.

The point is that you need to disable something called ACPI, which stands for Advanced Configuration and Power Interface.

There are several ways you can disable ACPI. The first way is to do this when you install/reinstall Windows XP. The second way is to do this while XP is running. Here is the way to disable it when you do a reinstall of Windows XP:

Fresh Install with no ACPI. When setup is loading, the blue screen will ask if you have any raid devices, and to press F6. When it does that, press and hold F7. No ACPI will be installed.


Press F5 after the first screen asking if you have raid devices to install (will ask at
bottom of screen to press F6) keep pressing F5 to second screen where it will ask to press F2 for recovery console. Keep holding F5 and should get another screen where it will say that it cannot recognize type of pc. There you have two choices: standard pc and other. Select standard and no ACPI will be installed.

And while XP is running:
Click [Start] [Control Panel] [Performance and Maintenance] [Power Options]
The Power Options Properties Property Sheet will open.
Click the APM tab and uncheck the box to [Enable Advanced Power Management Support]

CAUTION: I do not guarantee that these solutions will work, as I have not tested them myself. Do so at your own risk, but I can confirm that disabling ACPI when installing XP have worked for others who have experienced the same issue (slowness).

Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

mendmycomputerAuthor Commented:
Will try to do the change from within XP first and if it fails i will attempt a repair install to make the change, failing that i'll try the bios and get back to you
Why not try and disable Power management from the BIOS?? Usually that sets things right. Upgrading the BIOS shud also help IMHO. Also from inside windows turning of power management features can also make things better. Usually with an updated BIOS unless the system is an old one you should have no problems getting rid of this problem with a fresh install of windows. Not a repair install but a fresh install from scratch. Take a backup first.

mendmycomputerAuthor Commented:
we have tried repair install and set it to a standard pc and it has had no effect we have looked in the BIOS but theres no options for power managment is there anything else we can try befor updateing the BIOS

reset the bios setting by shorting jumper setting in cmos or remove the cmos cell and wait for 3 hours or 1 full day so that the full motherboard power is discharged.
After that place back the cell wait for 15 minutes and power on the pc.

This is the only thing you can try if you dont want to update bios


mendmycomputerAuthor Commented:
couldn't fix the problem in the end so will need to do fresh install
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.