Solved

Windows Server 2003 Active Directory not available on domain controller after power failure

Posted on 2006-06-27
10
6,404 Views
Last Modified: 2012-06-27
Windows Server 2003 (Small Business), all current patches applied
Server is domain controller for small business network.

Recent tornado and high wind events caused sudden power failure on the server.  When restarted, the server would hang at "applying computer settings".  Experts-Exchange information (from existing "server hangs... computer settings") told us to start the server in safe mode, disable all MS Exchange services, etc.  This enabled us to start the server quickly.  (EE suggestions to disable APC PowerChute did not apply, PowerChute is not installed on this server.)

Now that the server is up and running, we can not manually start MS Exchange services.  Further investigation shows that Active Directory Users and Computers only shows saved queries, and we are not connected to the domain.  Attempting to connect to the domain prod.local produces the Active Directory error "Windows cannot connect to the new domain because:  The logon attempt failed".  

Event log errors indicated data corruption on drive C:, running chkdsk on drives C: and D: fixed indexes, recovered orphan files, etc.  A second chkdsk pass showed no errors.

Everything appears to be working well, except for Active Directory.  This server is the only domain controller.  How do we get AD working again?
0
Comment
Question by:4RunnerBob
  • 4
  • 3
  • 3
10 Comments
 
LVL 13

Assisted Solution

by:Kini pradeep
Kini pradeep earned 400 total points
ID: 16992546
hey did you try running Dcdiag /v first to check whats wrong with the Directory services ?
also post any events or errors.
0
 

Author Comment

by:4RunnerBob
ID: 16992593
Attempted to run "dcdiag /v" but received error message:

Windows cannot find'dcdiag'.  Make sure you typed the name correctly, and then try again.
0
 
LVL 13

Assisted Solution

by:Kini pradeep
Kini pradeep earned 400 total points
ID: 16992719
probably you need to install support tools. its in the win2k3 Cd.
install them and run dcdiag.
0
 
LVL 48

Assisted Solution

by:Jay_Jay70
Jay_Jay70 earned 100 total points
ID: 16993034
what happens if you try and access AD?
0
 

Author Comment

by:4RunnerBob
ID: 16993426
(responding to "what happens if you try and access AD?")

Attempting to start Active Directory Domains and Trusts, error:
   The configuration information describing this enterprise is not available.  The login attempt failed.

Attempting to start Active Directory Sites and Services:
   Naming information cannot be located because:  The login attempt failed  Contact your system administrator to verify that your domain is properly configured and is currently online.

(same error as above, when attempting to start Active Directory Users and Computers)

Event log shows:
ID 1168     Internal error:  An Active Directory Error has occurred.
                Additional data  error value 1053

ID 1913     Internal error:  The Active Directory backup and restore operation encountered an unexpected error.  
                Backup or restore will not succeed until this is corrected
                Additional data  Error value 1084

ID 1238     Internal error:  Active Directory was unable to initialize network connections for incoming LDAP requests
                Additional data  Error value 0

ID 1168     Internal error:  An Active Directory error has occurred
                Additional data  Error value (decimal):  -1073741823

NOTE:  The original NIC in this machine was not working reliably, so a second NIC was installed with the same settings (and we disabled the original NIC).
0
VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

 

Author Comment

by:4RunnerBob
ID: 16997348
Support Tools were installed, we tried to run "dcdiag /v" but received an error saying "LDAP bind failed with error 1323", "unable to update the password".

ran "dcdiag /u:username /p:password /v" same error.

Any attempt to connect to the domain (on the domain controller) failes the LDAP password authentication.  What are our options?
0
 
LVL 48

Expert Comment

by:Jay_Jay70
ID: 17016683
sorry about late response.....status still the same as above?
0
 
LVL 13

Accepted Solution

by:
Kini pradeep earned 400 total points
ID: 17017927
http://support.microsoft.com/?id=267553
can you check the senetworklogon in the gpttmpl file.
0
 

Author Comment

by:4RunnerBob
ID: 17031041
Thanks to kprad and Jay_Jay70 for helping lead us in the right direction.  We ended up contacting Microsoft tech support, who worked for about seven hours to help us correct the problem.
0
 
LVL 48

Expert Comment

by:Jay_Jay70
ID: 17033258
no problem mate, glad all is well
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Organizations create, modify, and maintain huge amounts of data to help their businesses earn money and generally function.  Typically every network user within an organization has a bit of disk space to store in process items and personal files.   …
I guess it is not common knowledge to most Wintel engineers/administrators: If you have an SNMP-based monitoring system in your environment (and it's common to have SNMP or Syslog) it's reasonably easy to enable monitoring of the Windows Event logs,…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
Concerto provides fully managed cloud services and the expertise to provide an easy and reliable route to the cloud. Our best-in-class solutions help you address the toughest IT challenges, find new efficiencies and deliver the best application expe…

930 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now