Solved

Exchange 2003 bounces internal mail in one direction between two sites.

Posted on 2006-06-27
12
260 Views
Last Modified: 2012-06-27
Good day,

We native Exch2003 environment, three sites, one server per site.

Site-A
Site-B
Site-C

Site-A is bridgehead to internet.

Mail delivery is fine when sent from:

- A to B
- A to C and C to A
- B to C and C to B
- from the internet to A,B,C and from A,B,C to the internet

However not from B to A!!  The mail is bounced and ends up with NDR.

question:

Is internal mail possible with any connectors, so based on X.400? If so, above mentioned communication is only possible with routing connectors between the sites and a SMTP connector to the internet.

A message track show transport using SMTPT most of the time. Sometimes is X.400 used. A failing message is ccording to the log deliverd at the apprpriat mailbox however it starts its way over again with 'store driver submitted to MTA'.

I have to mention that server A is a DC and had a crash last weekend. The system has been rebuild after cleaning AD.

DCDIAG and NETDIAG show no problems.

Spent many days in resolving the problem but unfortunatly without succes

Pls advice

Thank you
0
Comment
Question by:maasdelta
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 5
12 Comments
 
LVL 9

Expert Comment

by:Exchgen
ID: 16996180
hmmm....

Can we try and telnet from B to A using IP and FQDN?

Are we able to drop an email via telnet?

Is there any kind of SMTP service running over firewall / SMTP server which comes in path between them?

When we do telnet localhost 25 and then EHLO do we get all 18 verbs related to SMTP and exchang on B?

Raghu
0
 

Author Comment

by:maasdelta
ID: 16996363
Can we try and telnet from B to A using IP and FQDN?
**** Yes
Are we able to drop an email via telnet?
***** No
Is there any kind of SMTP service running over firewall / SMTP server which comes in path between them?
**** No, rember A to B works fine, B to A not.
When we do telnet localhost 25 and then EHLO do we get all 18 verbs related to SMTP and exchang on B?
***********
Site A:
250-mail.maasdelta.nl Hello [10.116.13.15]
250-TURN
250-SIZE
250-ETRN
250-PIPELINING
250-DSN
250-ENHANCEDSTATUSCODES
250-8bitmime
250-BINARYMIME
250-CHUNKING
250-VRFY
250-X-EXPS GSSAPI NTLM LOGIN
250-X-EXPS=LOGIN
250-AUTH GSSAPI NTLM LOGIN
250-AUTH=LOGIN
250-X-LINK2STATE
250-XEXCH50
250 OK

Site B:

ehlo
250-wtmh-ms01.maasdelta.local Hello [10.116.13.15]
250-TURN
250-SIZE
250-ETRN
250-PIPELINING
250-DSN
250-ENHANCEDSTATUSCODES
250-8bitmime
250-BINARYMIME
250-CHUNKING
250-VRFY
250-X-EXPS GSSAPI NTLM
250-AUTH GSSAPI NTLM
250-X-LINK2STATE
250-XEXCH50
250 OK

I also noticed the difference however I upgraded SVR2003 with SP1 and reinstalled Exch 2003 with SP2. So I don't know how to change this??

Regards Jan
0
 
LVL 9

Expert Comment

by:Exchgen
ID: 16996399
Can we get in to properties of server on site A and under securities/advanced confirm that "inheritance" is checked.

Raghu
0
Comparison of Amazon Drive, Google Drive, OneDrive

What is Best for Backup: Amazon Drive, Google Drive or MS OneDrive? In this free whitepaper we look at their performance, pricing, and platform availability to help you decide which cloud drive is right for your situation. Download and read the results of our testing for free!

 

Author Comment

by:maasdelta
ID: 16996412
Forgot:

When we do telnet localhost 25 and then EHLO do we get all 18 verbs related to SMTP and exchang on B?

**** Also site C shows a differend verbs but does work fine.

Problems must be in AD / MTA routing.
0
 
LVL 9

Expert Comment

by:Exchgen
ID: 16996452
In pure exchange 2003 native mode (as you mentioned) you can stop and disable the MTA service.

All email flow between exchange servers in your case would happen via SMTP.

If all sites are connected via routing group connector you may want to delete the connector between B to A and let the email get routed from B to C and from there to A.

If the above also fails then we may want to have a look at B site server.

You may alo want to check a winroute connecting to each server in different site and find out if we have stale connectors or connector marked down.

Raghu
0
 

Author Comment

by:maasdelta
ID: 16996614
Hello Exchgen,

No the 'inheritance' was not checked!! Do I have to reboot the A- server ??
0
 
LVL 9

Expert Comment

by:Exchgen
ID: 16996660
Just restart the IS service....

Raghu
0
 

Author Comment

by:maasdelta
ID: 16996687
Exchgen,

When you create a connector, its counter part is created at the other site. Does one need to creat a connector at both sides??

Suppose your idea works, so routing via C. What does that tell us??

I wil try this in the morning, it is getting late.

Regards
0
 
LVL 9

Expert Comment

by:Exchgen
ID: 16997060
Your are right... the connector is created both ways....

If you have already tried deleting the connector.... and the mail flow works this does give me an indication that this is possibly a linkstate issue...

I am not sure but is it possible for us to restart the routing engine service on all the 2 sites?

If we have multiple servers in each site then you need to restart the routing engine service of the ROUTING MASTER server.

Raghu

0
 

Author Comment

by:maasdelta
ID: 17016310
Hello all,

The problem has been solved!

After deleting the complete routing group on server B and recreating it the mail is deliverd correctly on server A.

So deleleting and/or recreating the connectors was not enough. I suppose some objects had to be replaced in order to solve the problem.

Any comment or additional technical inside view is welcome.

Thanks to you,

Regards JAn
0
 

Accepted Solution

by:
CetusMOD earned 0 total points
ID: 17258247
PAQed with points refunded (500)

CetusMOD
Community Support Moderator
0

Featured Post

Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Lotus Notes – formerly IBM Notes – is an email client application, while IBM Domino (earlier Lotus Domino) is an email server. The client possesses a set of features that are even more advanced as compared to that of Outlook. Likewise, IBM Domino is…
After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question