• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 708
  • Last Modified:

Setting MX record preference in Exchange

I have a customer that regularly sends mail to adventurecenter.org.  Messages are bouncing back saying is a routing error with two servers and to contact the administrator (me).  I've looked at the MX record for adventure center and get the following from MXtoolbox:

10 <blank> 192.168.75.11
10 mail.adventurecenter.org 4.79.191.18

I went in to nslookup on my server and did a set q=mx to see what my server is seeing, which is:

MX preference  = 10, mail exchanger = <root>
MX preference  = 10, mail exchanger = mail.adventurecenter.org

I believe the dual entries in the MX record are causing the mail problems.  Is there a way in Exchange or DNS to hardwire to the correct hostname?

Jason


0
jtcomstock
Asked:
jtcomstock
1 Solution
 
wingateslCommented:
In DNS you can make a forward lookup zone for that name, however you will have to put entries in for all of their other hosts as well.
0
 
ExchgenCommented:
Exchange should failover to an alternate MX by default...

If this is not happening a workaround would be to create an SMTP connector with the address space as problem domain and insted of using DNS use smart host and add the MX IP.

Restart the SMTP service and check what happens.

Raghu
0
 
jtcomstockAuthor Commented:
I have the exact message that gets return in the domain.

"A configuration error in the e-mail system caused the message to bounce between two servers or to be forwarded between two recipients.  Contact your administrator"

Any ideas?
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
SembeeCommented:
This is not your problem.
The problem is whoever admins that domain name hasn't set the MX records correctly.

If you look at the DNS Report for this domain, you will find that there is a blank MX record for this domain.

http://www.dnsreport.com/tools/dnsreport.ch?domain=adventurecenter.org

Your server is seeing that blank MX record and cannot cope with it.

There is very little you can do, because the Internet information is incorrect. Setting the DNS zone on your own servers is not something that you should be doing, any changes that they make will not be reflected in your copy of their DNS.

Simon.

0
 
jtcomstockAuthor Commented:
Simon,

That was my initial thought, but my customer is telling me that email from Gmail (Google) works fine.  Somehow Google is able to deal with the MX record issue, but Exchange cannot.  

Jason
0
 
SembeeCommented:
They are two different email systems. Gmail might have been built to be more forgiving.
Working on Gmail or not doesn't really help - the DNS records are just plain wrong.

Simon.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now