Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Exchange ActiveSync Unexpected Exchange mailbox Server error Error 501

Posted on 2006-06-27
7
Medium Priority
?
10,359 Views
Last Modified: 2010-08-05
I am trying to sync my Treo 700 with my Exchange Server. I am running SBS 2003 and it is the only server. Therefore it does everything and a front end/back end setup is not an option (I believe). Whenever I try to sync my Treo I receive the following error in the event log on the server:

Type: Error
Event ID: 3005
User: internal_domain_name\my_name
Computer: server_netbios_name

Unexpected Exchange mailbox Server error: Server: [server_netbios_name.internal_domain_name.lan] User: [my_name@external_domain_name.com] HTTP status code: [501]. Verify that the Exchange mailbox Server is working correctly.

This corresponds to the error on the Treo:

ActiveSync encountered a problem on the server.

Support Code: 0x85010014

I have the Treo set to sync as follows:

Server address: mail.external_domain_name.com
SSL is unchecked

Username: my_name
Password: ********
Domain: internal_domain_name

I have gone through all of the online helps I could find and have not been able to solve this problem. In particular I have done everything recommended in the article  http://support.microsoft.com/?id=817379  and it has not overcome this problem.

Thank you for your help.

Joe

0
Comment
Question by:dekroon
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
7 Comments
 
LVL 104

Expert Comment

by:Sembee
ID: 17002918
Do you have multiple SMTP addresses on the server?

domain.local
and
domain.com

for example?

Simon.
0
 

Author Comment

by:dekroon
ID: 17004102
Yes, I have three:

external_domain_name1.com  (registered with Network Solutions)
external_domain_name2.com  (registered with Network Solutions)
internal_domain_name.lan

So my email addresses are:

my_name@external_domain_name1.com
my_name@external_domain_name2.com
my_name@internal_domain_name.lan

Unexpected Exchange mailbox Server error: Server: [server_netbios_name.internal_domain_name.lan] User: [my_name@external_domain_name1.com] HTTP status code: [501]. Verify that the Exchange mailbox Server is working correctly.

Thanks,
Joe
0
 
LVL 104

Expert Comment

by:Sembee
ID: 17004185
The usual cause I see for this is the lack of an email address on the default domain.
On sites that have multiple domains it isn't unusual to see that a user has only one email address - the one that they need - not one in the default domain. It doesn't have to be the default email address, just present as Exchange uses it internally.

While you are not using SSL on the device, are you using SSL on the machine itself? To protect OWA for example?

Check the authentication and application pool settings are the same that I have on my web site: http://www.amset.info/exchange/mobile-eastrouble.asp

Simon.
0
 

Author Comment

by:dekroon
ID: 17005361
When I browse to http://servername/oma as is explained on your website:

"Then browse to http://servername/oma and login using the credentials in the format of domain\username and the password.
You should get a folder list in a plain text format. If you get anything else, then it isn't working properly.
If you are using SSL, then you will need to browse to the SSL URL."

my credentials are not accepted and I recieve the following error:

You are not authorized to view this page
You do not have permission to view this directory or page using the credentials that you supplied.
--------------------------------------------------------------------------------
Please try the following:
Contact the Web site administrator if you believe you should be able to view this directory or page.
Click the Refresh button to try again with different credentials.
HTTP Error 401.1 - Unauthorized: Access is denied due to invalid credentials.
Internet Information Services (IIS)
--------------------------------------------------------------------------------
Technical Information (for support personnel)
Go to Microsoft Product Support Services and perform a title search for the words HTTP and 401.
Open IIS Help, which is accessible in IIS Manager (inetmgr), and search for topics titled Authentication, Access Control, and About Custom Error Messages.

As far as using SSL, I would like to use it to protect OWA but I am hosting my company's website on this server. Therefore, I need the Default Web Site to be open so that the company's website is not being hosted on https but rather http. Port 80 is open to the internet for this hosting. Is there any way to protect OWA using SSL without closing the Default Web Site to non-SSL traffic? I currently have a certificate on the machine itself. I have tried making them myself but this one was created by the SBS CEICW (Configure E-mail and Internet Connection Wizard) (at least I think it was: you never quite know what those wizards are really doing).

Joe
0
 
LVL 104

Accepted Solution

by:
Sembee earned 2000 total points
ID: 17012621
For the SSL, don't confuse the settings to require SSL with the ability to use SSL. You can have one without the other.
All you need to do is ensure that https (443) is pointed to the right location.

Furthermore, you don't have to have port 80 (http) open to the web site holding OWA/OMA/EAS. It is perfectly acceptable to have just port 443 open. As long as the calls can be made on port 80 then all will be well.

If I was hosting the web site on the same server as Exchange (which I don't do as a rule - I usually throw hosting out to a web host) then I would have the http web site on a different virtual server on the machine - probably with its own internal IP address. Exchange would be left on the default.
Then on the firewall I would port forward 80 to the new VS with its own IP address and 443 and 25 to the default IP address of the Exchange server.
If you wanted to allow access to Exchange through port 80, then simply create a redirect page so that http://www.domain.com/exchange/ redirected to https://mail.domain.com/exchange/ 

With the SSL certificates, ideally you should purchase one. It makes life so much easier than trying to use the home grown ones. Use a different host name to the web site - like I have used in my example above.

Did you check the authentication settings in IIS Manager were the same as what I had posted on to my web site?

Simon.
0

Featured Post

NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

New style of hardware planning for Microsoft Exchange server.
How to deal with a specific error when using the Enable-RemoteMailbox cmdlet to create a mailbox in the cloud-based service, for an existing user in an on-premises Active Directory.
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…
Suggested Courses

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question