Solved

ASA 5510 internet on VPN doesn't work

Posted on 2006-06-28
2
289 Views
Last Modified: 2010-04-08
Hi,
I have configured the VPN on the ASA 5510 and the VPN itself works well. However you can not connect to the internet while the VPN i active. I figuer I have missed something in the config. Can someone please help me out? Here is the current config:

ASA Version 7.0(4)
!
hostname fw01
domain-name sargem.office
enable password IfsTwrsRylpv1cmS encrypted
names
!
interface Ethernet0/0
 nameif outside
 security-level 0
 ip address 194.16.166.203 255.255.255.240
!
interface Ethernet0/1
 nameif inside
 security-level 100
 ip address 172.16.1.1 255.255.255.0
!
interface Ethernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0
 management-only
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
clock timezone CEST 1
clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
same-security-traffic permit intra-interface
object-group service webmail tcp
 port-object eq www
 port-object eq 480
 port-object eq 8080
 port-object eq https
access-list outside_access_in extended permit icmp 194.16.166.192 255.255.255.240 any
access-list outside_access_in extended permit tcp any interface outside eq smtp
access-list outside_access_in extended permit tcp host 213.136.36.93 interface outside eq pop3
access-list outside_access_in extended permit tcp any interface outside object-group webmail
access-list inside_nat0_outbound extended permit ip any 172.16.1.192 255.255.255.192
access-list inside_nat0_outbound extended permit ip any 172.16.1.128 255.255.255.128
access-list sargem_VPN_splitTunnelAcl standard permit any
access-list outside_cryptomap_dyn_20 extended permit ip any 172.16.1.192 255.255.255.192
access-list sargem_Office_splitTunnelAcl standard permit any
access-list outside_cryptomap_dyn_40 extended permit ip any 172.16.1.128 255.255.255.128
access-list RAsargem_splitTunnelAcl standard permit any
access-list inside_cryptomap_dyn_20 extended permit ip any 172.16.1.128 255.255.255.128
pager lines 24
logging enable
logging asdm debugging
mtu outside 1500
mtu inside 1500
mtu management 1500
ip local pool bVPN 172.16.1.200-172.16.1.250 mask 255.255.255.0
ip local pool OfficeVPN 172.16.1.180-172.16.1.199 mask 255.255.255.0
ERROR: Command requires failover license
ERROR: Command requires failover license
asdm image disk0:/asdm504.bin
no asdm history enable
arp timeout 14400
global (outside) 10 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 10 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface smtp 172.16.1.10 smtp netmask 255.255.255.255
static (inside,outside) tcp interface pop3 172.16.1.10 pop3 netmask 255.255.255.255
static (inside,outside) tcp interface www 172.16.1.10 www netmask 255.255.255.255
static (inside,outside) tcp interface https 172.16.1.10 https netmask 255.255.255.255
static (inside,outside) tcp interface 8080 172.16.1.10 8080 netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 194.16.166.193 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00
timeout mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
group-policy DfltGrpPolicy attributes
 banner none
 wins-server none
 dns-server value 172.16.1.10 194.16.248.7
 dhcp-network-scope none
 vpn-access-hours none
 vpn-simultaneous-logins 3
 vpn-idle-timeout 30
 vpn-session-timeout none
 vpn-filter none
 vpn-tunnel-protocol IPSec webvpn
 password-storage disable
 ip-comp disable
 re-xauth disable
 group-lock none
 pfs disable
 ipsec-udp disable
 ipsec-udp-port 10000
 split-tunnel-policy tunnelall
 split-tunnel-network-list none
 default-domain value sargem.Office
 split-dns none
 secure-unit-authentication disable
 user-authentication disable
 user-authentication-idle-timeout 30
 ip-phone-bypass disable
 leap-bypass disable
 nem disable
 backup-servers keep-client-config
 client-firewall none
 client-access-rule none
 webvpn
  functions url-entry
  port-forward-name value Application Access
group-policy RAsargem internal
group-policy RAsargem attributes
 dns-server value 172.16.1.10 194.16.248.7
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value RAsargem_splitTunnelAcl
 default-domain value sargem.office
 webvpn
group-policy sargem_VPN internal
group-policy sargem_VPN attributes
 dns-server value 172.16.1.10 194.16.248.7
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value sargem_VPN_splitTunnelAcl
 default-domain value sargem.office
 webvpn
username johnny.kola password eMRIIbNRESWsQuPt encrypted privilege 15
username johnny.kola attributes
 vpn-group-policy sargem_VPN
 webvpn
http server enable
http 172.16.1.0 255.255.255.0 inside
http 192.168.1.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 40 match address outside_cryptomap_dyn_40
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-SHA
crypto dynamic-map inside_dyn_map 20 match address inside_cryptomap_dyn_20
crypto dynamic-map inside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto map inside_map 65535 ipsec-isakmp dynamic inside_dyn_map
crypto map inside_map interface inside
isakmp enable outside
isakmp enable inside
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
tunnel-group sargem_VPN type ipsec-ra
tunnel-group sargem_VPN general-attributes
 address-pool bVPN
 default-group-policy sargem_VPN
tunnel-group sargem_VPN ipsec-attributes
 pre-shared-key *
tunnel-group RAsargem type ipsec-ra
tunnel-group RAsargem general-attributes
 address-pool OfficeVPN
 default-group-policy RAsargem
tunnel-group RAsargem ipsec-attributes
 pre-shared-key *
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 172.16.1.100-172.16.1.180 inside
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd dns 172.16.1.10 193.16.48.7
dhcpd lease 3600
dhcpd ping_timeout 50
dhcpd domain sargem.office
dhcpd enable inside
dhcpd enable management
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map global_policy
 class inspection_default
  inspect dns maximum-length 512
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect pptp
!
service-policy global_policy global
Cryptochecksum:e4d8e09d951af727ae5b98bd4ca4ef5b
: end
0
Comment
Question by:matthh
2 Comments
 
LVL 9

Accepted Solution

by:
stressedout2004 earned 500 total points
ID: 17005666
I am not sure which group is active, but regardless make the following modification:

access-list sargem_VPN_splitTunnelAcl standard permit 172.16.1.0 255.255.255.0
no access-list sargem_VPN_splitTunnelAcl standard permit any
access-list  RAsargem_splitTunnelAcl standard permit 172.16.1.0 255.255.255.0
no access-list RAsargem_splitTunnelAcl standard permit any

If you still have difficulty accessing the internet once connected to the VPN after making the changes, I would suggest changing the VPN pool to a totally different subnet. 172.16.1.128 and 172.16.1.192 still overlaps with 172.16.1.0/24 which is the internal network.

0
 

Author Comment

by:matthh
ID: 17014519
Thank you stressedout! Worked like a charm!
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

To setup a SonicWALL for policy based routing to be used with the Websense Content Gateway there are several steps that need to be completed. Below is a rough guide for accomplishing this. One thing of note is this guide is intended to assist in the…
The DROP (Spamhaus Don't Route Or Peer List) is a small list of IP address ranges that have been stolen or hijacked from their rightful owners. The DROP list is not a DNS based list.  It is designed to be downloaded as a file, with primary intention…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now