Solved

3000 Concentrator & 506e PIX: AES Tunnels

Posted on 2006-06-28
5
362 Views
Last Modified: 2010-04-12
Up until this point, my company has been doing our VPN by the "leave it at the defaults and it just works" method.  We have a number of remote sites that tunnel all traffic to our central site.  At each remote site is a PIX 506e and at the central site, a 3005 Concentrator.

Needless to say, I'm pretty inexperienced at any kind of more advanced setups and am probably just missing something simple.

For performance reasons, we want to go to AES tunnels from 3DES and to learn what I'm actually doing, I'm doing this using the CLI of the PIX.

I've gotten everything configured to the best of my abilities and it's still not working.  Please help!

I'm doing this in a lab network.  Here's what it looks like, roughly:
http://www.armedbear.net/ee/lab_network.png

Here are the relevant config screens off of my Concentrator:
  The L2L Tunnel Config Page:
  http://www.armedbear.net/ee/L2L_Tunnel_Page1.png
  http://www.armedbear.net/ee/L2L_Tunnel_Page2.png

  The IKE Config Page:
  http://www.armedbear.net/ee/ike.png

  The SA Config Page:
  http://www.armedbear.net/ee/SA.png

Last, but certainly not least, the PIX config is attached at the bottom.

Please help!


PIX Version 6.3(1)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password gigu2cdr1NrbpYtD encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname PIX
domain-name mycompany.com
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
names
access-list TUNNEL permit ip 10.225.0.0 255.255.0.0 any
pager lines 24
logging on
logging buffered warnings
mtu outside 1500
mtu inside 1500
ip address outside 192.168.1.25 255.255.255.0
ip address inside 10.225.1.1 255.255.0.0
ip audit info action alarm
ip audit attack action alarm
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list TUNNEL
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 192.168.1.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 outside
http 10.225.1.1 255.255.255.255 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set sits_transform_set esp-aes-256 esp-sha-hmac
crypto map test_map 10 ipsec-isakmp
crypto map test_map 10 match address TUNNEL
crypto map test_map 10 set peer 192.168.1.30
crypto map test_map 10 set transform-set sits_transform_set
crypto map test_map interface outside
isakmp enable outside
isakmp key ******** address 192.168.1.30 netmask 255.255.255.255
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption aes-256
isakmp policy 10 hash sha
isakmp policy 10 group 5
isakmp policy 10 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:2e6636d457796c4a1df1929b6f959745
: end
0
Comment
Question by:titan6400
  • 3
  • 2
5 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 300 total points
ID: 17008277
>PIX Version 6.3(1)
Very buggy version of OS. Suggest you get the latest 6.3(5)
Can you post result of 'show cry is sa' from the PIX?
Also result of 'show cry ip sa'

It may be a routing issue on the 3005.
PIX points to 192.168.1.1 as its default gateway
3005 points someplace else as its gateway?

>access-list TUNNEL permit ip 10.225.0.0 255.255.0.0 any
You want the tunnel acl to match the concentrator's tunnel list and you don't want to use 'any' on either the concentrator or the pix.
access-list TUNNEL permit ip <local lan subnet> <mask> <remote lan subnet> <mask>

Looking at your Tunnel_Page2.png - You have 10.225.0.0 as the Local Network and "any" as the remote network. You also have 10.225.0.0 assigned to the inside of the PIX.
The Remote network (behind the PIX) is 10.225.0.0 0.0.255.255
0
 

Author Comment

by:titan6400
ID: 17012252
Yes, I actually figured this one out last night and was going to have the question closed this AM.  Anyway, it was an issue of having the local and remote networks reversed as well as a couple other little nitpicky things that I figured out with debug crypto isakmp.

Why do you recommend against having the "any" keyword at the end of the TUNNEL ACL?  I am trying to use this tunnel to route all traffic from the 10.225.0.0 network to anywhere else to the concentrator (Internet traffic, the whole deal), so I put in 0.0.0.0 0.0.0.0 as the remote network on that ACL.  The PIX automatically translated this to "any".

Is there a problem with that?
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17013741
If you want all traffic encrypted and force Internet access through this same tunnel then you really must use "any". This is just not typical of any setup. Most companies with this desire to control Internet access from a central location just use a proxy server..
IPSEC VPN's want to be as precise as possible and "any" is difficult to troubleshoot.
0
 

Author Comment

by:titan6400
ID: 17013792
Well, with our setup we literally want any traffic that isn't destined for that local office's subnet to be tunneled to our primary office.

It's got nothing to do with controlling Internet acess or anything like that, it's more to do corporate policies and crap like that which I'm really not inclined to get into.

Anyway, it's the way it's got to be and I appreciate your help in troubleshooting the actual technical problem.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17013824
You have to do what you have to do sometimes. I understand.
- Cheers!
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

One of the Top 10  common Cisco VPN problems are not-matching shared keys. This is an easy one to fix, but not always easy to notice, see the case below. A simple IPsec tunnel between fast Ethernet interfaces of routers SW1 (f1/1) and R1(f0/0). …
When you connect to your workplace's VPN, you may not notice that you are using your workplace's servers to serve up webpages.  This might be undesirable since the workplace can log all the places you've been.  It also might be very slow to load pag…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now