error trying to bind (Invalid credentials) WSFU Windows Services for Unix 3.5 not working

I followed this document: http://enterprise.linux.com/enterprise/04/12/09/2318244.shtml?tid=102&tid=101&tid=100 and its not working. When I try to log into my Linux box using a username that is in Active Directory, it tells me to type the correct user name/password. I have followed the procedure step by step and confirmed that each setting was typed correctly.

/var/log/messages records this:

Jun 28 14:31:57 linuxbox gdm(pam_unix)[7124]: check pass; user unknown
Jun 28 14:31:57 linuxbox gdm(pam_unix)[7124]: authentication failure; logname= uid=0 euid=0 tty=:0 ruser= rhost=
Jun 28 14:31:57 linuxbox gdm-binary[7124]: pam_ldap: error trying to bind (Invalid credentials)
Jun 28 14:31:57 linuxbox gdm-binary[7124]: Couldn't authenticate user

The local accounts are still working fine and I can use them to log into the Linux box. What am I doing wrong?

ps I have to use WSFU because I need to use the "user name mapping" feature. Samba/winbind will not work for me.

Thanks.
bfilipekAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
NopiusConnect With a Mentor Commented:
Probably these lines are incorrect either because you don't have such user (you should have already user dirsearch with a password in your AD) or you configured incorrect binddn and nindpw:

binddn cn=dirsearch,cn=Users, dc=lanrx,dc=com
bindpw D1rectory


ldap is quiet verbose if you enable 'debug' level in syslog

/etc/syslog.conf:

*.debug  <TAB>   /var/log/messages

then restart syslog and see again what happenes.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.