Final Cut Express HD Compatability with the new Imac Intel

I bought a new 20" imac. OSX10.4 I've got a legit version of Final Cut Express HD and after the install is complete I get an error to something like I dont have the proper grafics card. Any seen this yet
itresourceAsked:
Who is Participating?
 
slyongCommented:
I am not sure if this is related to your issue but there is a KB article here for Final Cut Express HD v3.0 and iMac G5 (iSight).  You need to download the upgrade to 3.0.1 http://docs.info.apple.com/article.html?artnum=302553
0
 
slyongCommented:
Can you go to Apple System Profiler and check what's your graphics card?
0
 
slyongCommented:
btw what is your Final Cut Express version?
0
 
rtalkovCommented:
You need to upgrade your version of FCE to 3.5, which is a universal binary. previous versions won't work properly on intel macs.

-perry
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.