Solved

CDs playing slow

Posted on 2006-06-29
12
285 Views
Last Modified: 2010-04-26
OK let me see if I can explain this. I have a dvd/cd rom in one bay and a cd-rom in the other bay. About 6 months ago the cd-rom started to play audio cds very very very slow... It slows them down to where they sound really bad. They seem to read data and MP3 disk just fine, just not audio, burnt or original. At first I thought it was probably just a software issue so I ran it in itunes instead of media player, but it did the same thing in itunes as well. I thought well ok - I can just use the top bay not a big deal. Well yesterday my top bay dvd/cd started doing the exact same thing.

Anyone have any idea as to why this might be doing this and have any idea as to how I might fix it?

Thanks,
Katie
0
Comment
Question by:apaddle
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
  • +2
12 Comments
 
LVL 69

Expert Comment

by:Callandor
ID: 17012153
I would try reinstalling the drivers for your sound card.  This is the solution for voices and music being too fast, so I think it may be applicable when it's too slow as well.
0
 

Author Comment

by:apaddle
ID: 17012265
yea - I tried that as well... it makes a poping and a cracking sounds in the music as well...

Katie
0
 
LVL 69

Expert Comment

by:Callandor
ID: 17012312
Have you tried removing the IDE drivers in Device Manager and letting them reinstall?
0
PeopleSoft Has Never Been Easier

PeopleSoft Adoption Made Smooth & Simple!

On-The-Job Training Is made Intuitive & Easy With WalkMe's On-Screen Guidance Tool.  Claim Your Free WalkMe Account Now

 
LVL 32

Expert Comment

by:willcomp
ID: 17012387
Digital or analog audio from CD/DVD drives?  Properties for drives in Device Manager should have a check box for Digital Audio.  Try analog output if digital or vice versa if now analog.  A cable from drive audio output to sound card CD input is required for analog audio.

Apparently problem only occurs with CD audio (wav) files.

Try playing some of the wav files in My Music folder to see if they play properly.
0
 

Author Comment

by:apaddle
ID: 17012490
Yes I have reinstalled the IDE drivers and I have also tried to play a wave file from my hard drive and it plays fine.  I have also turned the analog/digital feature off and on and it makes no difference...
0
 
LVL 32

Expert Comment

by:willcomp
ID: 17012541
Appears sound card is OK (plays wav files properly).

Same behavior with both digital and analog output from drives.

The only other thing that comes to mind is rotational speed of drives.  Try completely disconnecting (IDE and power connectors) one of the drives and see if that makes a difference.
0
 
LVL 70

Accepted Solution

by:
garycase earned 500 total points
ID: 17012637
"... a poping and a cracking sounds in the music ..." ==>  Okay, this indicates your drives may have reverted to PIO transfers.   That shouldn't normally cause the music to play slow; but popping and cracking sounds are typical of what that would cause.

Try this (this is a harmless registry modification -- it just forces redetection of the transfer modes):


Load RegEdit (Start - Run - Regedit)

Go to the following keys:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\000x

The last four digits will be 0000, 0001, 0002, 0003, and so on.

Under each key, delete all occurences of the following values:

     MasterIdDataChecksum
     SlaveIdDataChecksum

Now reboot your system and see if the problem disappears.
0
 
LVL 1

Expert Comment

by:Amaury Lopez
ID: 17012686
Check to see weather the optical drives are set to read in PIO (Programmed Input Output) or DMA (Direct Media Access), becuse PIO is much slower than DMA the drive might not read fast enought to play the sone properly.
To do this go to the device manager,
Right click the IDE controller(s) that the optical drives are on,
Click properties,
Then go to the advanced settings tab
Under transfer mode mode make sure it says Use DMA if available, under current transfer mode it will say what it is using.

If by chance it says PIO Only then you will have to uninstall the controller and put it back on and before you do anything else change the setting to DMA.

Good Luck
-Alopez426
0
 

Author Comment

by:apaddle
ID: 17012766
Graycase - you are the best.... That so fixed the problem... now in perfect working condition... do we know what causes this to occur?

Thanks,
Katie
0
 
LVL 32

Expert Comment

by:willcomp
ID: 17012896
Geezer Gary got it right after we narrowed it down for him :)  

To be honest, wouldn't have suspected PIO mode as culprit.  CD/DVD drives used PIO mode for years without similar problems (at least I never saw any).

Here's a good writeup on PIO mode reversion.  May be more details than you need.  Most probable cause in your case is scratched or poor quality CDs.  It may very well recur.
0
 
LVL 70

Expert Comment

by:garycase
ID: 17013125
... Actually Katie provided two clues that pointed to the problem:  (1)  the fact it happened first with one drive, then later with the other; and (2) the popping and cracking sounds.   Popping, cracking, stuttering, etc. is a strong clue that a drive is working in PIO mode.
   

willcomp forgot to include the link he referred to -- I suspect he'll correct that soon =>either while I'm typing this, or after he reads this :-)

But the bottom line is that the system will revert to PIO mode access if there are too many errors while accessing a device in DMA mode.   This can happen with both optical drives (your CD & DVD drives) or with hard drives -- if it happens with hard drives that's a BAD sign.   With optical drives, trying to read scratched or poor quality CDs (as willcomp noted) can cause this.

Before Service Pack 2, this would happen if there were a total of 6 errors accessing the device.   SP2 changed the behavior so it requires 6 CONSECUTIVE errors -- a major change in the behavior which makes it MUCH less likely to occur.   If you're not running Service Pack 2, then you should upgrade; but if there's some reason you don't want to, you can desensitize pre-SP2 versions of XP by adding a DWord named "ResetErrorCountersOnSuccess" to the same keys I listed earlier (the ones ending in 0001, 0002, etc.) and giving it a value of 1 (be sure and add it to all of the keys).
0
 
LVL 32

Expert Comment

by:willcomp
ID: 17013460
The missing link:

http://winhlp.com/WxDMA.htm

Got distracted and one track mind jumped the track.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I use more than 1 computer in my office for various reasons. Multiple keyboards and mice take up more than just extra space, they make working a little more complicated. Using one mouse and keyboard for all of my computers makes life easier. This co…
This is about my first experience with programming Arduino.
This video Micro Tutorial shows how to password-protect PDF files with free software. Many software products can do this, such as Adobe Acrobat (but not Adobe Reader), Nuance PaperPort, and Nuance Power PDF, but they are not free products. This vide…
Add bar graphs to Access queries using Unicode block characters. Graphs appear on every record in the color you want. Give life to numbers. Hopes this gives you ideas on visualizing your data in new ways ~ Create a calculated field in a query: …

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question