file/printer sharing win xp

hi,
i have a printer on my desktop and i want to share it so i can print with my laptop to it as well.
both systems have windows xp installed on them,
both are under the same domain.
laptop is directly connected to the linksys router and laptop is wireless connected to the router.
both computers see each other when i go to 'view workgroup computers' but when i try to click on it, i get the following error msg
----
\\laptop is not accessible. you might not have permission to use this network source. Contact the administrator of this server to find out if you have access permissions.
the network path was not found.
---
i have also created the exact same username on the laptop with the same password and everything, i thought that would fix the permission problem, but it didnt :-s
any idea guys what i have to do to fix this?
djsoltanAsked:
Who is Participating?
 
prashsaxConnect With a Mentor Commented:
Do this on your desktop.

1. Click Start, click Run, type mmc, and then click OK.
2. On the File menu, click Add/Remove Snap-in.
3. On the Standalone tab, click Add.
4. In the Available Standalone Snap-ins list, click Group Policy Object Editor, and then click Add.
5. In the Select Group Policy Object dialog box, click Browse.
6. Double-click the name of the computer that is running Terminal Services, click the policy name, and then click Finish.
7. Click Close, and then click OK.
8. Double-click the policy name, double-click Computer Configuration, and then double-click Administrative Templates.
9. Click Printers, and then double-click Allow Print Spooler to Accept Client Connections in the details pane.
10. On the Setting tab, click Enabled, and then click OK.

Restart your desktop.
0
 
NetAdmin2436Commented:
XP home or XP Professional?

Turn off firewalls and disable anti-virus/antispyware. I've seen these interfere more than they should.

On both machines do this. start --> run --> cmd --> ipconfig/all
Make sure both machines have the same network settings and different IP addresses.

With XP professional right click on your shared folder and choose properties. On the sharing security tabs, make sure appropriate rights are assigned.

Hope this helps
0
 
NetAdmin2436Commented:
oh, and after you do the ipconfig/all, see if you can ping each other. example, if computer B IP address is 192.168.0.3. From Computer A
start -->run -->cmd --> ping 192.168.0.3

And vice versa
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
djsoltanAuthor Commented:
desktop xp media center, laptop windows xp tablet edition,, i would say both would be categorized under with some customization cuase they dont have a "security tab".

both IPs look fine, one gets 192.168.1.100 and the other gets 192.168.1.102
i disabled the antivirus'
still the same problem :-s
0
 
djsoltanAuthor Commented:
i can ping the desktop from laptop, but i CANT ping the laptop from desktop :-s
0
 
prashsaxCommented:
Do this.

Start->Run

\\IP_ADDRESS                     of other computer.

This should open the shares on the other computer.

0
 
prashsaxCommented:
Forget to tell.
Do it on laptop.
0
 
djsoltanAuthor Commented:
\\ip works,
it openes up the shared stuff on the desktop, but i still cant ad the printer, it keeps saying
'windows cannot connect to the printer. Either the printer name was typed incorrectly, or the specified printer has lost its connection to the server.'
i know for a fact that i type the printers name right,
it looks like file sharing is ok, but printer sharing not working yet :-s
0
 
prashsaxCommented:
You should be able to see the shared printer when you open the desktop.

Now all you have to do is to double click on that icon.

It will install the printer on laptop.
0
 
gbirkemeierCommented:
Have you shared the printer yet? You will get that error untill you actually set up a share.

open a command prompt on the laptop and type:

\\ip_address_desktop\c$

Does it open a windows explorer window?


0
 
prashsaxCommented:
To share your printer on desktop, just right click on it and choose sharing...

Give a Share name for the printer and that it.
0
 
djsoltanAuthor Commented:
i see the printer there, when i double click on it, it says,
------
operation could not be completed. Either the printer name was typed incorrectly, or the specified printer has lost its connection to the server.
------
printer is shared, and i can see it on the desktop

p.s \\ip_address_desktop\c$ in 'command prompt' comes back with ' the network path was not found,'
0
 
djsoltanAuthor Commented:
6. Double-click the name of the computer that is running Terminal Services, which one would this be? desktop or laptop?
or in a way, computer that the printer is hooked up too, or the other one that is trying to connect to the network printer?
0
 
djsoltanAuthor Commented:
ps. i am on a workgroup, not a domain!
0
 
prashsaxCommented:
That would be your local security policy.

When you client Group Policy object, It should show you local.

Just selct it and click finish.
0
 
gbirkemeierCommented:
On the desktop:

Open windows explorer and open the tools menu --> Folder Options...
Select the View tab
In advanced settings scroll all the way to the bottom
Uncheck simple file sharing

Open the "User accounts" in control panel
enable the guest account

Go the the security tab under the shared printer's properties.
Make sure that "Everyone" is set to allow everything

Open a command prompt
type "net share"
do you see the share name for the printer in the list of shares?
0
 
djsoltanAuthor Commented:
prashsax, thanks alot, that did it.
0
 
prashsaxCommented:
ThankQ.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.