Unable to install Wireless Driver - access is denied

Posted on 2006-06-29
Last Modified: 2007-12-19
Hi Guys,

I'm trying to upgrade the driver for the intel 2200BG wireless adapter in my notebook. I tried the standard method - Device-manager -> Device Properties -> Upgrade Driver... - I select the new driver file, and some files appear to copy correctly, but then I get a 'Cannot install this hardware' message, with 'Access is Denied' as the cause.

I'm logged as the local administrator, I've tried disabling the device first, I've tried the same procedure in safe mode - all with the same result.

I've also tried the installer that comes with the package (even though this installs a lot of software I don't want) - this fails too, though it doesn't give a reason.

I've tried removing the device entirely, in the hope that I can tell Windows where to get the new driver during install, but I'm never given the chance - windows takes it's previous version and just uses that.

Does anyone know what could cause this error, and a way to work around it?

Thanks in advance!
Question by:kibatsu
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
LVL 13

Expert Comment

ID: 17014813
Download a signed driver from the Net.  Sounds like the one you have there is corrupt or an older version.


Author Comment

ID: 17014866
The package I got came straight from intel - it's definitely signed.

I've downloaded the package twice - and checked that they match - they do, so I don't think it's a corrupt download issue. The other software in the package installs no problems at all.
LVL 13

Expert Comment

ID: 17014890
Must be... send a mail to their support.

Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users


Author Comment

ID: 17015213
Turns out the intel installer also has a repair utility - running this fixed the problem, and I'm now running the correct version.

Thanks for your help itcoza!

LVL 30

Expert Comment

by:Marc Z
ID: 17018411

Accepted Solution

GhostMod earned 0 total points
ID: 17047204
Closed, 125 points refunded.

Community Support Moderator

Featured Post

Instantly Create Instructional Tutorials

Contextual Guidance at the moment of need helps your employees adopt to new software or processes instantly. Boost knowledge retention and employee engagement step-by-step with one easy solution.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Can you find a fax from a vendor you saved a decade ago in seconds? Have you ever cursed your PC under your breath during an audit because you couldn’t find the requested statement or driver history?  If you answered no to the first question or yes …
Ok I have been working on this for some time having learned and gained certification in XenDesktop 4 along came version 5 which was released last month. Since then I have been working to deploy XenDesktop 5 in a small environment with only 2 virt…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question