Solved

PPTP Passthrough on a Cisco PIX 515E to Windows 2003 RRAS VPN server

Posted on 2006-06-30
3
3,080 Views
Last Modified: 2013-11-16
Allright experts?

Can anyone help me with the following...?

I need to passthrough PPTP traffic from external Internet clients to an internal Windows 2003 RRAS server. The RRAS server is correctly configured. I just need to add the appropriate lines to the PIX.

Setup:                    192.168.170.5    (RRAS server)
                              80.70.60.10       (outside interface on the PIX)

I need PPTP clients from /anywhere/ on the Internet to be allowed to create a VPN connection.

Config:

: Saved
: Written by enable_15 at 09:09:37.327 UTC Wed Jun 28 2006
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password BGogFIdB6jmwTyg7 encrypted
passwd BGogFIdB6jmwTyg7 encrypted
hostname LimavadyFW
domain-name limavady.gov.uk
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 217.45.122.25 mail_outside
name 80.76.207.130 maildefence_mx1
name 69.10.158.251 maildefence_mx2
name 192.168.170.2 mail_inside
name 80.76.207.129 maildefence_mx3
name 217.147.82.67 maildefence_mx4
name 217.45.122.28 tibusssh
access-list acl_outside permit icmp any any echo-reply
access-list acl_outside permit icmp any any unreachable
access-list acl_outside permit icmp any any source-quench
access-list acl_outside permit tcp host maildefence_mx1 host mail_outside eq smtp
access-list acl_outside permit tcp host maildefence_mx2 host mail_outside eq smtp
access-list acl_outside permit tcp host maildefence_mx4 host mail_outside eq smtp
access-list acl_outside permit tcp host maildefence_mx3 host mail_outside eq smtp
access-list acl_outside permit tcp 213.83.66.0 255.255.255.0 host mail_outside eq smtp
access-list acl_outside permit tcp host 212.108.64.250 any eq ssh
access-list acl_outside permit tcp host 212.108.64.250 any eq 220
access-list acl_outside permit tcp 212.108.64.0 255.255.255.0 host tibusssh eq ssh
access-list acl_outside permit tcp 212.108.64.0 255.255.255.0 host tibusssh eq www
access-list Limavadyvpn_splitTunnelAcl permit ip 192.168.170.0 255.255.255.0 any
access-list inside_outbound_nat0_acl permit ip 192.168.170.0 255.255.255.0 172.30.100.0 255.255.255.224
access-list outside_cryptomap_dyn_20 permit ip any 172.30.100.0 255.255.255.224
pager lines 24
logging on
logging buffered debugging
logging trap debugging
logging facility 7
mtu outside 1500
mtu inside 1500
ip address outside 80.70.60.10 255.255.255.248
ip address inside 192.168.170.254 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnpool 172.30.100.1-172.30.100.30
pdm location 192.168.170.5 255.255.255.255 inside
pdm history enable
arp timeout 14400
global (outside) 1 217.45.122.27
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 192.168.170.0 255.255.255.0 0 0
static (inside,outside) mail_outside mail_inside netmask 255.255.255.255 0 0
static (inside,outside) tibusssh 192.168.170.3 netmask 255.255.255.255 0 0
access-group acl_outside in interface outside
route outside 0.0.0.0 0.0.0.0 217.45.122.30 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.170.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp nat-traversal 30
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup Limavadyvpn address-pool vpnpool
vpngroup Limavadyvpn dns-server 194.73.82.242 194.72.6.51
vpngroup Limavadyvpn wins-server mail_inside
vpngroup Limavadyvpn default-domain limavady.gov.uk
vpngroup Limavadyvpn split-tunnel Limavadyvpn_splitTunnelAcl
vpngroup Limavadyvpn idle-time 1800
vpngroup Limavadyvpn password ********
telnet 192.168.170.0 255.255.255.0 inside
telnet timeout 30
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:18ded6b317e40f4fbcdbcf2c921ea8a1

We have a spare, unused IP address of 80.70.60.12. I would like to use that for the VPN passthrough.

What lines do I need to add to my PIX?

I have added:

name 80.70.60.12 vpn_external
name 192.168.170.5 vpn_internal

access-list acl-out permit gre any host vpn_external
access-list acl-out permit tcp any host vpn_external eq 1723
static (inside,outside) vpn_external vpn_internal netmask 255.255.255.255 0 0
access-group acl-out in interface outside

as per:

http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a0080094a5a.shtml


Should this work?

Thanks,
Andrew
0
Comment
Question by:gam1002
3 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 17019643
Your expected changes should be all you need. However, beware that the proposed "acl-out" does not match your existing "acl_outside", and I'm sure you want to keep what is already working...

\\-- Create the 1-1 static NAT with your unused public IP (good idea to run "clear xlate" first):
clear xlate
static (inside,outside) vpn_external vpn_internal netmask 255.255.255.255
 
\\-- add the access-list rules to permit tcp 1723 and GRE to your existing acl:
access-list acl_outside permit gre any host vpn_external
access-list acl_outside permit tcp any host vpn_external eq 1723

\\-- re-apply the acl to the interface
 access-group acl_outside in interface outside

Done!
0
 
LVL 9

Expert Comment

by:jjoseph_x
ID: 17029195
You might also require fixup protocol pptp 1723

http://www.cisco.com/warp/public/110/pix_pptp.html
0
 
LVL 1

Expert Comment

by:Jaedub
ID: 17042739
you do not need the fixup since the taffic is originating from the outside.

Your additions are all you need as long as you make sure you have the same ACL names as mentioned above.

-J
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

Wikipedia defines 'Script Kiddies' in this informal way: "In hacker culture, a script kiddie, occasionally script bunny, skiddie, script kitty, script-running juvenile (SRJ), or similar, is a derogatory term used to describe those who use scripts or…
Do you have a windows based Checkpoint SmartCenter for centralized Checkpoint management?  Have you ever backed up the firewall policy residing on the SmartCenter?  If you have then you know the hassles of connecting to the server, doing an upgrade_…
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
This tutorial demonstrates a quick way of adding group price to multiple Magento products.

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now