[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 573
  • Last Modified:

How to avoid the password prompt when connecting to Exchange via RPC over HTTP

Hello:

I have seen many previous posts on this issue and was hoping not to add to it again, however, I just can't seem to get this to work.  I cannot bypass the password prompt when accessing outlook over http.

On the client, when I use NTLM authentication I am continually prompted for the password.  I did make the necessary changes to the lmcompatibilitylevel key in the registry setting to to both 2 and 3 still with no luck.  The client is on the same domain as the exchange server

On the Exchange server (and the RPC virtual directory in IIS) I currently have none of the authentication options selected.  I have tried selecting Basic authentication as well still with no luck!

Can anyone help me with this issue?  Where am I going wrong?
0
tdcitstaff
Asked:
tdcitstaff
1 Solution
 
amaheshwariCommented:
0
 
tdcitstaffAuthor Commented:
Thanks for the link, however, I am not using a Frontend/Backend configuration.  Only one Exchange server.  I still tried the configuration as suggested, however it still did not work, once I set the client to use NTLM it keeps continually prompting for the password.
0
 
SembeeCommented:
If the client machine is on the same domain as the Exchange server, you shouldn't get the prompt.
Make sure that the authentication settings are correct on the /rpc virtual directory in IIS Manager. They should be integrated and basic ONLY.
Using basic authentication isn't an issue as you are also using SSL.

Simon.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
tdcitstaffAuthor Commented:
You say the /rpc virtual directory should be set to integrated AND basic?  I'ver set it to both, however, once I select NTLM on the client, it does not allow me to connect at all, as it keeps prompting for the password.   With Basic authentication set on the client, I am prompted once, but once I enter the password I am connected via http (I am running outlook with the /rpcdiag switch).  Any further suggestions?
0
 
SembeeCommented:
I go by my working deployments, of which there are many.

With the client machine being a member of the same domain as the Exchange server, with the authentication settings as I have outlined above, and NTLM Authentication set in Outlook - I get no authentication prompt. I deploy this feature so that it is totally transparent to the users.

The KEY thing is that the machines are all in the same domain so that pass through authentication is used.

Simon.
0
 
mostymCommented:
I am having the same problem...
0
 
tdcitstaffAuthor Commented:
Simon.

What firewall are you using in your configurations?  I am using ISA 2004 and I suspect that the problems may be with the ISA rules.  I tried this - http://support.microsoft.com/kb/884506/en-us - however that too did not seem to work.

Can you shed any light in this area?
0
 
SembeeCommented:
I don't use ISA in any configuration.
I have deployed RPC over HTTPS lots of times with real firewalls. Cisco PIX and Watchguards accept it with very little configuration.

Simon.
0

Featured Post

Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now