• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 604
  • Last Modified:

Crystal Reports and word document formatting within vb.net

I have been able to successfully export my report to a word document, however, the formatting on the document file is not correct. I need to fix the formatting of the word document. I am using visual studio 2003 which has a crystal report component version 9. How can i do this without using a macro in vb.net?
0
janjuama84
Asked:
janjuama84
  • 3
  • 3
2 Solutions
 
frodomanCommented:
In general there isn't anything crystal-related that you can do to fix the formatting.  By this I mean that the export to Word is a compiled dll that is going to behave the same way every time and doesn't have any flags or parameters that allow you to alter the way it works.  You can however make changes to your report that will affect the final output of the document file - adding / removing borders around fields, etc.

If you can be a little more specific about how the formatting isn't correct, I may be able to answer more directly.

frodoman
0
 
janjuama84Author Commented:
When i export the report to word document, forexample, all the text has border around them, thus in order to edit the file, either one has to clear all formatting, to edit it else its really hard to edit it. All i need is that when the exported word document file is opened, editing should be simpler, and not be done within the border.
0
 
frodomanCommented:
Do you have borders around your fields within Crystal?  If so, there is no way to prevent them from being included in your Word document - the only way is to remove them from within your report.  This is an example of what I mean - you can change the report to get different results.
0
New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

 
janjuama84Author Commented:
I do have them in my report. How can i change it? Please advice.
0
 
janjuama84Author Commented:
However, actually i am using crystal report formulas to populate my fields. Perhaps, they have a border that might be causing it?
0
 
frodomanCommented:
If you rt-click on the field and select format you can get rid of the borders -- this applies whether it's a normal data field or if it's a formula.
0
 
mlmccCommented:
UNfortunately when Crystal released CR9 they eliminated the export to Word document format and replaced it with export to RTF format (even though the option still says Word).  RTF includes the borders on fields where as the Word export didn't.  What you are really seeing is frames in the RTF document which make editting the document difficult.

mlmcc
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now