Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1152
  • Last Modified:

Online MP3's Open in Browser with QuickTime

Hi

I'm having a really irritating problem at the moment and hope someone here might have a solution.

Until recently, when I've clicked a link to an MP3 file in Firefox, I've been prompted to either open the file or save it.  This is expected and is my preferred behavior.  However, since I installed iTunes I've been having real trouble.

When iTunes is installed, QuickTime is installed along with it.  Now, whenever I click an MP3 file in Firefox, the file is loaded in a new browser tab using the QuickTime plugin.  This is not something I have QuickTime permission to do.  Additionally, I've checked the file associations for MP3 files and they don't match how the software is behaving.  Windows Media Player is set as the default player for MP3 files as it should be.  I've been into the QuickTime preferences and made sure that QuickTime is not set as the default player for MP3 files on both the "File Types" tab and the "MIME Types" button under the "Browser" button.  However, still, online MP3s load with QuickTime in a Firefox tab.

I cannot seem to fix this problem and it's starting to drive me insane.  I'm irritated enough that I have to install QuickTime just to be able to use iTunes, but for it to be effectively hijacking my settings is making the whole situation even worse.

Any suggestions that anyone could offer would indeed be welcomed.
0
musicalmidget
Asked:
musicalmidget
  • 2
  • 2
1 Solution
 
shuboarderCommented:
Have a look under control panel.
Double click Quicktime

Look at the Browser and File Types tabs here and uncheck as necessary.
There are additional settings here which override other file associations.

Hope this helps!
0
 
musicalmidgetAuthor Commented:
Hi.

I took a look in that area of the QuickTime preferences but wasn't able to find anything else to tweak.  However, I've managed to fix the problem by telling QuickTime not to be the default player for anything unless it's a format that only QuickTime can handle.  Additionally, tweaking a few Firefox settings has helped and things seem to be running smoothly once more.

Thanks anyway.
0
 
shuboarderCommented:
Yes, you did this here right?

Under control panel >> Quicktime >> File Types

If not, please explain what you changed, as this may be useful for someone else in future.

Thanks.
0
 
musicalmidgetAuthor Commented:
Not exactly.

As I said in my initial post, I had already unset QuickTime as the default MP3 player.  The solution however was to remove the download action associated with MP3 from the Firefox settings.  Doing so meant that next time an MP3 was clicked, no action was found so I was prompted to open or save the file, as expected.

As a precaution, I removed all of the file associations from the QuickTime preferences, althou MP3 was already disabled.
0
 
NetminderCommented:
Closed, 125 points refunded.
Netminder
Site Admin
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now