Laptop without permissions

Charlie Weston
Charlie Weston used Ask the Experts™
on
I have a notebook computer that refuses to allow any other workgroup members to share/access/see its files.  All macines including the laptop are set for file and printer sharing.  The machines are all in the same workgroup (called "WORKGROUP") and I can see an icon for the laptop on the screen of the other computers.  When I ask the Laptop to show me a list of workgroup computers, i get the message:

"Workgroup is not accessible.  You might not have permission to use this network resource.  Contact the administrator of this server to see if you have access permissions.

The list of servers is not currently accessible."

Conversely, when I try from one of the other workgroup computers to see the laptop, I get:

"\\Laptop is not accessible.  You might not have permission to use this network resource.  Contact the administrator of this server to see if you have access permissions.

The network path was not found."

I also have a printer conected to the laptop, and I set it for sharing.  When I try to Add the Priner from one of the other machines, I tell them to browse for a printer, at which point I can see the Laptop mentioned in the list, but no associated printer is shown.

This exact same scenario has happend on two otherwise-normal networks. The laptop is shunned as a sharing partner.

This question is pretty urgent.

chaz4
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Check your firewall settings.
Top Expert 2010

Commented:
along with the firewall, also make sure the computer is up to date on windows updates.

Commented:
Try to disable the windows firewall and any AV such  as norton AV which usaully comes with personal firewall.
then try to map the share like this:

open my computer >>> tools >>> map network drive
then type in:
Z:
\\ip-address-of-the-laptop\shareName

and see what you get.
Make sure to enable the share permission to read or read/write
and to give one user the read or read/write or modfiy access on the security

so remember 2 permissions to the user accessing it:
share permissions
and security permissions

hope this helps!
Erik BjersPrincipal Systems Administrator

Commented:
Windows XP file sharing works better when all computers in a work group have the same accounts, with the same user names and passwords.

eb
If the Q is urgent, how about listing the OS???  This is TOTALLY dependent on which OS is running on which computers, and cannot be accurately answered without that info.

Commented:
these below address your error, but different resolutions
http://support.microsoft.com/kb/915107/en-us   (guest acct)
http://support.microsoft.com/kb/285035/en-us   (pc is set as a master browser, or netbios over tcp not enabled)
http://support.microsoft.com/kb/318030/en-us   (turn on netbios over tcp, start computer browser service)
Windows XP with SP2 have Windows Firewall Enabled by Default.

To Disable Firewall :

1. Click Start, Control Panel.
2. Double–click Network Connections.
3. Right-click the desired connection (LAN), Properties, Advanced tab, Under Internet Connection Firewall,
4. Click "Settings" Button
5. Select "OFF"

Disable IEEE 802.1x Authentication :

1. Click Start, Control Panel.
2. Double–click Network Connections.
3. Right-click the desired connection (LAN), Properties, Authentication tab.
4. Uncheck "Enable IEEE 802.1x Authentication for this network.

Now try both  "\\IP.of.La.ptop\Sharename" at run    and    "\\IP" at run one by one

If the above does not solve your problem then only try free SafeXP :

SafeXP Tool which optimise entire Windows XP settings at one button click
Info : http://www.theorica.net/safexp.htm
Download : http://www.theorica.net/download/SafeXP.zip

Press "Recomended Settings" button and then Apply button.

Reboot the machine.

Now try both  "\\IP.of.La.ptop\Sharename" at run    and    "\\IP" at run one by one

Also try logging on the desktop with the same usename and password that exists on the Laptop.

Author

Commented:
Sorry, I neglected to mention this is Windows XP

Disabled firewalls.  

Latest updates installed.

Mapping network drive z: to \\lap.tp.ip.addr\laptop produced "Network path could

not be found."

I am clear on the share permissions, but I can't see where or how to set

Security permissions.

Microsoft page 1:  Guest accounts was not enabled.  Changed this.
Microsoft page 2:  Made the suggested change.
Microsoft page 3:  this appears to contradict the recommendationhs in page 2.  

Anyhow, I made sure the computer browser was Started (which it was), then re-

booted and tried to See Network Computers.  

Same message again:  You may not have permission, etc., etc.

Disabled Norton Internet Security.   I had previously disabled this without any result.

Suddenly I am seeing the other computers and am able to connect to a network printer.  Wow.

My last question is, Do I have to just work without a firewall and damn the consequences?  Or is there some way I can get the firewall to accept my local network?

chaz4
Commented:
No,
put the firewall back on, but make sure you use either norton firewall or windows firewall. don't use both.

if you are going to use windows firewall you just need to open the "file and printer sharing" mainly port 445, make sure to edit it to include other subnets if the computer accessing the share on other subnet.

Commented:
>> Or is there some way I can get the firewall to accept my local network?
go to control panel >> 
firewall
exceptions
check on: file and printer sharing >> click on edit >> and change the scope to accept your network

-- make sure to disable norton firewall though.
Norton Internet security is THE problem.  I had one system to where it totally disabled networking and you could NOT get it back, not even by reinstalling networking completely.  NIS does some serious damage to the registry keys, which dont seem to be recoverable without a full reinstall.  I recommend you stop using it, and if you are behind a router with good firewall, you dont need it -- if not, then use windows own firewall -- even before SP2, it put all ports in stealth mode, that is good enough.

If you can recover from NIS without reinstalling the OS, consider yourself lucky.  If not, remove the program completely, then reinstall networking by deleting it from network properties, and then removing the adapter from Device Manager.  A reboot will redetect the adapter and install all the networking properties again, all you have to do is run the network connect wizard, and choose residential gateway.  With luck, you will be back up networking.  Good luck.
Have you taken a look at the user credentials that the laptop is using?

Make sure the laptop in pulling the user account credential of the server. Make sure that you give all the users access to the shared resources.

If there's no PDC then you will have to add all the users of the network to the laptop's user list.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial