Solved

Gigabyte K8U motherboard fails to detect SATA drive

Posted on 2006-07-01
15
5,077 Views
Last Modified: 2008-02-26
Hello,
   I am having trouble getting my GA-K8U up and running.
I have it hooked up to a single SATA drive [Seagate Barracuda 7200.8 ST3250823AS 250GB 7200 RPM Serial ATA150] and cannot seem to get it to recognize the drive. When I boot into the BIOS CMOS setup and attempt to switch channel 2 to auto detect the BIOS sceen locks and forces me to reboot. Suspecting that I must have the RAID configuration wrong, I entered the RAID, JBOD foniguration setup, which interestingly shows the drive, but will not accept any keybord inputs. Interestingly, I do see the drive on vethis screen.

I have also tried booting from both the Windows CD and the Gigabyte drivers and utilities CD that came with the board. The driver CD fails to recognize the drive and forces me to reboot. The windows install CD either hangs at the "Stating up windows" phase of the install (most often) or occasionally gives me the the cannot detect storage device message.

I have also attempted to install windows on a USB drive, just to get the machine booting up.
After completing the DOS style phase of the process, Windows is bluescreening on reboot.
0
Comment
Question by:greiber
  • 6
  • 4
  • 3
  • +2
15 Comments
 
LVL 70

Assisted Solution

by:garycase
garycase earned 150 total points
ID: 17024411
You can't use it in RAID mode with a single drive.  In the BIOS set your On-Chip SATA Mode to IDE instead of RAID  (see Page 35 of your manual -- which is here if you need it:  http://tw.giga-byte.com/Support/Motherboard/Manual_DownloadFile.aspx?FileType=Manual&FileID=16448).

You cannot, by the way, install Windows on a USB drive :-)

Depending on what you've changed in the BIOS, you may need to do a BIOS reset;  or you may need to enter the BIOS with the hard drive disconnected to change the SATA mode.   But once it's set to IDE mode it should work fine.   Post back if you need further help.

0
 
LVL 32

Accepted Solution

by:
willcomp earned 350 total points
ID: 17026513
Apparently, F6 drivers are required for a single SATA drive installation on ULi chipset motherboards (have no experience with those chipsets).

Quote from Gigabyte manual:

"To install Windows 2000/XP onto a Serial ATA hard disk sucessfully, you need to install  required driver for
the SATA controller on your motherboard during OS installation. Without the driver, the hard disk may not be
recognized during the Windows setup process.

"First of all, you have to copy the driver for the SATA controller on your motherboard from the motherboard
driver CD to a floppy disk. See the instructions below about how to copy the driver."

Instructions are on Page 71 of mobo manual.

As an alternative, you can download SATA driver from ULi website and prepare a floppy disk to install drivers.

http://www.uli.com.tw/eng/support/drivers.php

Note:  F6 drivers (Press F6 to install additional drivers at start of W2K and XP setup) must be installed from a floppy drive.  A flash drive will not work.

As a side note, nVidia has acquired ULi.

0
 
LVL 44

Expert Comment

by:scrathcyboy
ID: 17028948
Even if the right SATA drivers are installed, which they must be, as GC said above, you CANNOT make a RIAD with a single drive. You must have at least 2 drives for RAID 1 (mirror - most reliable), or 3 for RAID 5 (faster but less recoverable).  SO no, one drive will not work.
0
 

Author Comment

by:greiber
ID: 17046540
Thank you all of you for your quick responses.
Scrathcyboy,
   Am I understanding you correctly that a single SATA drive will never work?
   I don't need or particularly want to have a RAID setup at this point. I am hoping to use the single SATA drive as a standalone drive. I should be able to do that, no?

Not having a reliable internal floppy drive, I was able to install win2k from floppy via my USB floppy drive and install the correct win2k SATA driver. I made it all the way through the DOS style phase of the setup, only to be rewarded by a 'cannot find boot volume' bluescreen.

 ...Can you tell me, the BIOS screen hanging should have nothing to do with not having the correct Windows drivers, yeah? That and the fact that with the drivers loaded as described for win2k I am still bluescreening makes me think there is a problem in the BIOS or in the integrated disk controller. F6 is my BIOS version, which seems to be the latest.

0
 
LVL 32

Expert Comment

by:willcomp
ID: 17046774
Assume you were able to partition and format HDD.  If that's the case, SATA drivers were loaded correctly at that point.

You can install from CD as long as you have a floppy drive to install F6 drivers.

A single SATA drive will work just fine.  You can't configure a RAID array with only one drive.

Without knowing exactly what setup steps were completed, can't speculate on cause for error.

Try re-installing from CD.  Delete partitions on HDD and start over.
0
 
LVL 2

Expert Comment

by:monkeyjr
ID: 17048903
I would like to ask can you see the page to let you partition the hard disk before installation of Windows XP? Check the Windows can discover the correct driver or not.
0
 

Author Comment

by:greiber
ID: 17052854
I am now installing the correct drivers, thanks to the advice from willcomp which was echoed by Gigabyte tech support.
With the win2k SATA driver loaded I am able to choose my boot partition and complete the DOS shell/OS loading phase of the install. But, when the machine reboot and --should-- proceed into the GUI phase of the windows setup (where you see the little 'wait aprox. 42 minutes' and you get encouragement to register while the drivers continue to load) the machine --instead-- bluescreens with the typical 'cannot access boot volume... [something useless about viruses]... reboot windows'.

...so I am now getting into the OS, but it is immediately crashing.
Not being an expert by any stretch, it feels like I still have a problem with the driver as everyone has pointed out. But, since I cannot access the IDE Channel 2 in the BIOS setup (as described on page 30, "2-1 Standard CMOS Features/ IDE Channel 2/3 Master", of my manual) without the BIOS hanging, I am suspicious that there is a problem in the board. From this section of the manual, it looks like I need to select Channel 2 and set "Extended IDE Drive" to auto. Unfortunately, as I said, I cannot get passed the CMOS main page. Selecting IDE Channel 2 Master causes the machine to lock.

That can't possibly be right BIOS behvior can it?
I should be able to enter that submenu regardless of what OS is or is not on the drive, no?

I have an RMA number from NewEgg for a replacement, so I will be trying again with a new board so I was hoping to get a little more information on how the CMOS setup should work.







0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:greiber
ID: 17052908
PS. I want to thank willcomp again, he has definately earned some share of the points.
0
 
LVL 32

Assisted Solution

by:willcomp
willcomp earned 350 total points
ID: 17053042
Is On-Chip SATA Mode set to IDE and not RAID?  IDE channels 2 and 3 are for SATA drives without RAID enabled.

Did you delete partitions on hard disk when re-installing W2K?

Verify BIOS settings before sending back what may be a working mobo.  If BIOS settings are incorrect, that would explain problems.
0
 
LVL 70

Assisted Solution

by:garycase
garycase earned 150 total points
ID: 17053083
Check the on-chip SATA mode as willcomp suggested.   As I noted in the first post, you can't use this in RAID mode with only a single drive.   If your BIOS settings are incorrect, that would explain why the system fails on reboot -- it may be "hunting" for a non-existent array :-)
0
 
LVL 32

Assisted Solution

by:willcomp
willcomp earned 350 total points
ID: 17053176
Gary, you covered the IDE vs RAID rather well earlier and I ASSUMED settings were correct.  Appears they may not be.

It is preferable to completely wipe hard disk before installing W2K again.  This utility will do the job:

http://dban.sourceforge.net/

Run DBAN in quick mode to save time.  One pass is sufficient.
0
 
LVL 70

Expert Comment

by:garycase
ID: 17053212
... agree that DBAN is a good idea => guarantees no residual "stuff" on the drive before doing the install :-)
0
 

Author Comment

by:greiber
ID: 17059684
Since I cannot access the IDE Channel 2 settings or the ALi RAID settings without locking up the BIOS, should I reset the BIOS with the mechanical jumper? I have tried using the failsafe defaults with no change in behavior. I have not wiped the drive, but will do so. I hadn't thought that could be contributing, but I guess since I am getting into Windows it could be.

Thanks for all your help.
I certainly have a complete reference now.
0
 
LVL 32

Expert Comment

by:willcomp
ID: 17059783
You're welcome.

BIOS reset may well help.  If it doesn't, try flashing BIOS.
0
 
LVL 32

Expert Comment

by:willcomp
ID: 17059799
Check RAID controller BIOS settings as well to ensure that no RAID is configured.  It shouldn't let you set RAID with only one drive, but one never knows.
0

Featured Post

Scale it in WD Gold

With up to ten times the workload capacity of desktop drives, WD Gold hard drives employ advanced technology to deliver among the best in reliability, capacity, power efficiency and performance.

Join & Write a Comment

Suggested Solutions

The Rasberry PI is a low cost piece of hardware that you can have a lot of fun with through experimenting and building/working on projects like media players, running a low cost computer, build data loggers etc. - see: https://www.raspberrypi.org
This paper addresses the security of Sennheiser DECT Contact Center and Office (CC&O) headsets. It describes the DECT security chain comprised of “Pairing”, “Per Call Authentication” and “Encryption”, which are all part of the standard DECT protocol.
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now